devel/p5-Log-Any - The NetBSD Packages Collection

Perl5 module to bring loggers and listeners together

Log::Any allows CPAN modules to safely and efficiently log messages, while
letting the application choose (or decline to choose) a logging mechanism
such as Log::Dispatch or Log::Log4perl.

Log::Any has a very tiny footprint and no dependencies beyond Perl 5.6,
which makes it appropriate for even small CPAN modules to use. It defaults
to 'null' logging activity, so a module can safely log without worrying
about whether the application has chosen (or will ever choose) a logging
mechanism.

The application, in turn, may choose one or more logging mechanisms via
Log::Any::Adapter.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Log-Any-1.70.8nb1.tgz
NetBSD 8.0earmv7hfp5-Log-Any-1.70.8nb1.tgz
NetBSD 8.0earmv7hfp5-Log-Any-1.70.8nb1.tgz
NetBSD 8.0i386p5-Log-Any-1.70.8nb1.tgz
NetBSD 8.0i386p5-Log-Any-1.70.8nb1.tgz
NetBSD 8.0i386p5-Log-Any-1.70.8nb1.tgz
NetBSD 8.0powerpcp5-Log-Any-1.70.8nb1.tgz
NetBSD 8.0powerpcp5-Log-Any-1.70.8nb1.tgz
NetBSD 8.0powerpcp5-Log-Any-1.70.8nb1.tgz
NetBSD 8.0x86_64p5-Log-Any-1.70.8nb1.tgz
NetBSD 8.0x86_64p5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0aarch64p5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0aarch64p5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0aarch64p5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0alphap5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0alphap5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0alphap5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0earmp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0earmp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0earmp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0earmv6hfp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0earmv6hfp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0earmv6hfp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0earmv6hfp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0earmv7hfp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0earmv7hfp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0earmv7hfp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0earmv7hfp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0i386p5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0i386p5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0m68kp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0m68kp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0m68kp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0mips64ebp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0mips64ebp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0mips64ebp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0mipselp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0mipselp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0powerpcp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0powerpcp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0sh3elp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0sh3elp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0sh3elp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0sparc64p5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0sparc64p5-Log-Any-1.70.8.tgz
NetBSD 9.0sparc64p5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0sparc64p5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0sparcp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0sparcp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0sparcp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0vaxp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0vaxp5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0x86_64p5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0x86_64p5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0x86_64p5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0x86_64p5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0x86_64p5-Log-Any-1.70.8nb1.tgz
NetBSD 9.0x86_64p5-Log-Any-1.70.8nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.