devel/p5-MooseX-Params-Validate - The NetBSD Packages Collection

Extension of Params::Validate for using Moose's types

This module fills a gap in Moose by adding method parameter validation to
Moose. This is just one of many developing options, it should not be
considered the "official" one by any means though.

Build dependencies

devel/p5-Test-Exception devel/p5-Package-DeprecationManager pkgtools/cwrappers

Runtime dependencies

devel/p5-Devel-Caller devel/p5-Moose devel/p5-Params-Validate devel/p5-Sub-Exporter lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 8.0earmv7hfp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 8.0earmv7hfp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 8.0i386p5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 8.0i386p5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 8.0powerpcp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 8.0powerpcp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 8.0powerpcp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 8.0x86_64p5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 8.0x86_64p5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0aarch64p5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0aarch64p5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0aarch64p5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0alphap5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0alphap5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0alphap5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0earmp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0earmp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0earmp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0earmv6hfp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0earmv6hfp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0earmv6hfp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0earmv6hfp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0earmv7hfp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0earmv7hfp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0earmv7hfp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0earmv7hfp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0i386p5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0i386p5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0m68kp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0mips64ebp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0mips64ebp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0mips64ebp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0powerpcp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0powerpcp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0sh3elp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0sh3elp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0sh3elp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0sparc64p5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0sparc64p5-MooseX-Params-Validate-0.21nb5.tgz
NetBSD 9.0sparc64p5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0sparc64p5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0sparcp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0sparcp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0sparcp5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0x86_64p5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0x86_64p5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0x86_64p5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0x86_64p5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0x86_64p5-MooseX-Params-Validate-0.21nb6.tgz
NetBSD 9.0x86_64p5-MooseX-Params-Validate-0.21nb6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.