devel/p5-Package-DeprecationManager - The NetBSD Packages Collection

Perl 5 module to manage deprecation warnings

The Perl 5 module Package::DeprecationManager allows you to manage
a set of deprecations for one or more modules.

Build dependencies

devel/p5-Test-Exception devel/p5-Test-Warn devel/p5-Test-Fatal devel/p5-Test-Requires devel/p5-Test-Warnings devel/p5-Sub-Name pkgtools/cwrappers

Runtime dependencies

devel/p5-Package-Stash devel/p5-namespace-autoclean devel/p5-Params-Util devel/p5-Sub-Install lang/perl5 lang/perl5

Available binary packages

aarch64:p5-Package-DeprecationManager-0.17nb3.tgz(NetBSD 9.0)
aarch64:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
aarch64:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
alpha:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
alpha:p5-Package-DeprecationManager-0.17nb3.tgz(NetBSD 9.0)
alpha:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
earm:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
earm:p5-Package-DeprecationManager-0.17nb3.tgz(NetBSD 9.0)
earm:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
earmv6hf:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
earmv6hf:p5-Package-DeprecationManager-0.17nb3.tgz(NetBSD 9.0)
earmv6hf:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
earmv6hf:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
earmv7hf:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 8.0)
earmv7hf:p5-Package-DeprecationManager-0.17nb3.tgz(NetBSD 8.0)
earmv7hf:p5-Package-DeprecationManager-0.17nb3.tgz(NetBSD 8.0)
earmv7hf:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 8.0)
earmv7hf:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
earmv7hf:p5-Package-DeprecationManager-0.17nb3.tgz(NetBSD 9.0)
earmv7hf:p5-Package-DeprecationManager-0.17nb3.tgz(NetBSD 9.0)
earmv7hf:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
earmv7hf:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
i386:p5-Package-DeprecationManager-0.17nb3.tgz(NetBSD 8.0)
i386:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 8.0)
i386:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 8.0)
i386:p5-Package-DeprecationManager-0.17nb3.tgz(NetBSD 9.0)
i386:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
i386:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
m68k:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
mips64eb:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
mips64eb:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
mipsel:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
powerpc:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 8.0)
powerpc:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 8.0)
powerpc:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
powerpc:p5-Package-DeprecationManager-0.17nb3.tgz(NetBSD 9.0)
sh3el:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
sh3el:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
sparc64:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
sparc64:p5-Package-DeprecationManager-0.17nb3.tgz(NetBSD 9.0)
sparc64:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
sparc:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
sparc:p5-Package-DeprecationManager-0.17nb3.tgz(NetBSD 9.0)
sparc:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
x86_64:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
x86_64:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
x86_64:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
x86_64:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
x86_64:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 8.0)
x86_64:p5-Package-DeprecationManager-0.17nb3.tgz(NetBSD 8.0)
x86_64:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 8.0)
x86_64:p5-Package-DeprecationManager-0.17nb3.tgz(NetBSD 9.0)
x86_64:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
x86_64:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)
x86_64:p5-Package-DeprecationManager-0.17nb4.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]