devel/p5-PerlIO-utf8_strict - The NetBSD Packages Collection

Perl extension to provide fast and correct UTF-8 I/O

This module provides a fast and correct UTF-8 PerlIO layer. Unlike
perl's default :utf8 layer it checks the input for correctness.

Build dependencies

devel/p5-Test-Exception pkgtools/cwrappers

Runtime dependencies

lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 8.0earmv7hfp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 8.0earmv7hfp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 8.0i386p5-PerlIO-utf8_strict-0.008.tgz
NetBSD 8.0i386p5-PerlIO-utf8_strict-0.008.tgz
NetBSD 8.0i386p5-PerlIO-utf8_strict-0.008.tgz
NetBSD 8.0powerpcp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 8.0powerpcp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 8.0powerpcp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 8.0x86_64p5-PerlIO-utf8_strict-0.008.tgz
NetBSD 8.0x86_64p5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0aarch64p5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0aarch64p5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0aarch64p5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0alphap5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0alphap5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0alphap5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0earmp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0earmp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0earmp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0earmv6hfp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0earmv6hfp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0earmv6hfp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0earmv6hfp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0earmv7hfp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0earmv7hfp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0earmv7hfp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0earmv7hfp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0i386p5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0i386p5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0m68kp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0m68kp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0m68kp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0mips64ebp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0mips64ebp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0mips64ebp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0mipselp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0mipselp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0powerpcp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0powerpcp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0sh3elp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0sh3elp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0sh3elp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0sparc64p5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0sparc64p5-PerlIO-utf8_strict-0.007nb3.tgz
NetBSD 9.0sparc64p5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0sparc64p5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0sparcp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0sparcp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0sparcp5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0x86_64p5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0x86_64p5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0x86_64p5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0x86_64p5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0x86_64p5-PerlIO-utf8_strict-0.008.tgz
NetBSD 9.0x86_64p5-PerlIO-utf8_strict-0.008.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.