devel/p5-Readonly - The NetBSD Packages Collection

Perl 5 module for creating read-only scalars, arrays and hashes

The Perl 5 module Readonly provides a facility for creating
non-modifiable scalars, arrays, and hashes. This facility also
overcomes the limitations of the Perl built-in mechanism (the "use
constant" pragma) to create constant scalars and lists.

Build dependencies

devel/p5-Module-Build-Tiny pkgtools/cwrappers

Runtime dependencies

lang/perl5 lang/perl5

Available binary packages

aarch64:p5-Readonly-2.05nb3.tgz(NetBSD 9.0)
aarch64:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
aarch64:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
alpha:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
alpha:p5-Readonly-2.05nb3.tgz(NetBSD 9.0)
alpha:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
earm:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
earm:p5-Readonly-2.05nb3.tgz(NetBSD 9.0)
earm:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
earmv6hf:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
earmv6hf:p5-Readonly-2.05nb3.tgz(NetBSD 9.0)
earmv6hf:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
earmv6hf:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
earmv7hf:p5-Readonly-2.05nb4.tgz(NetBSD 8.0)
earmv7hf:p5-Readonly-2.05nb3.tgz(NetBSD 8.0)
earmv7hf:p5-Readonly-2.05nb3.tgz(NetBSD 8.0)
earmv7hf:p5-Readonly-2.05nb4.tgz(NetBSD 8.0)
earmv7hf:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
earmv7hf:p5-Readonly-2.05nb3.tgz(NetBSD 9.0)
earmv7hf:p5-Readonly-2.05nb3.tgz(NetBSD 9.0)
earmv7hf:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
earmv7hf:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
i386:p5-Readonly-2.05nb3.tgz(NetBSD 8.0)
i386:p5-Readonly-2.05nb4.tgz(NetBSD 8.0)
i386:p5-Readonly-2.05nb4.tgz(NetBSD 8.0)
i386:p5-Readonly-2.05nb3.tgz(NetBSD 9.0)
i386:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
i386:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
m68k:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
m68k:p5-Readonly-2.05nb3.tgz(NetBSD 9.0)
m68k:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
mips64eb:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
mips64eb:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
mipsel:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
powerpc:p5-Readonly-2.05nb4.tgz(NetBSD 8.0)
powerpc:p5-Readonly-2.05nb4.tgz(NetBSD 8.0)
powerpc:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
powerpc:p5-Readonly-2.05nb3.tgz(NetBSD 9.0)
sh3el:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
sh3el:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
sparc64:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
sparc64:p5-Readonly-2.05nb3.tgz(NetBSD 9.0)
sparc64:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
sparc:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
sparc:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
vax:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
x86_64:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
x86_64:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
x86_64:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
x86_64:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
x86_64:p5-Readonly-2.05nb4.tgz(NetBSD 8.0)
x86_64:p5-Readonly-2.05nb3.tgz(NetBSD 8.0)
x86_64:p5-Readonly-2.05nb4.tgz(NetBSD 8.0)
x86_64:p5-Readonly-2.05nb3.tgz(NetBSD 9.0)
x86_64:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
x86_64:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)
x86_64:p5-Readonly-2.05nb4.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]