devel/p5-Shell-Guess - The NetBSD Packages Collection

Make an educated guess about the shell in use

Shell::Guess makes a reasonably aggressive attempt to determine the
shell being employed by the user, either the shell that executed
the perl script directly (the "running" shell), or the users' login
shell (the "login" shell). It does this by a variety of means
available to it, depending on the platform that it is running on.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

sysutils/p5-Unix-Process lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Shell-Guess-0.09nb2.tgz
NetBSD 8.0earmv7hfp5-Shell-Guess-0.09nb1.tgz
NetBSD 8.0earmv7hfp5-Shell-Guess-0.09nb1.tgz
NetBSD 8.0earmv7hfp5-Shell-Guess-0.09nb2.tgz
NetBSD 8.0i386p5-Shell-Guess-0.09nb1.tgz
NetBSD 8.0i386p5-Shell-Guess-0.09nb2.tgz
NetBSD 8.0i386p5-Shell-Guess-0.09nb2.tgz
NetBSD 8.0powerpcp5-Shell-Guess-0.09nb2.tgz
NetBSD 8.0powerpcp5-Shell-Guess-0.09nb2.tgz
NetBSD 8.0powerpcp5-Shell-Guess-0.09nb2.tgz
NetBSD 8.0x86_64p5-Shell-Guess-0.09nb2.tgz
NetBSD 8.0x86_64p5-Shell-Guess-0.09nb1.tgz
NetBSD 8.0x86_64p5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0aarch64p5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0aarch64p5-Shell-Guess-0.09nb1.tgz
NetBSD 9.0aarch64p5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0aarch64p5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0alphap5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0alphap5-Shell-Guess-0.09nb1.tgz
NetBSD 9.0alphap5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0alphap5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0earmp5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0earmp5-Shell-Guess-0.09nb1.tgz
NetBSD 9.0earmp5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0earmp5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0earmv6hfp5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0earmv6hfp5-Shell-Guess-0.09nb1.tgz
NetBSD 9.0earmv6hfp5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0earmv6hfp5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0earmv6hfp5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0earmv7hfp5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0earmv7hfp5-Shell-Guess-0.09nb1.tgz
NetBSD 9.0earmv7hfp5-Shell-Guess-0.09nb1.tgz
NetBSD 9.0earmv7hfp5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0earmv7hfp5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0earmv7hfp5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0i386p5-Shell-Guess-0.09nb1.tgz
NetBSD 9.0i386p5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0i386p5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0mips64ebp5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0mips64ebp5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0mips64ebp5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0powerpcp5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0powerpcp5-Shell-Guess-0.09nb1.tgz
NetBSD 9.0powerpcp5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0sh3elp5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0sh3elp5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0sparc64p5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0sparc64p5-Shell-Guess-0.09nb1.tgz
NetBSD 9.0sparc64p5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0sparc64p5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0sparcp5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0sparcp5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0sparcp5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0x86_64p5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0x86_64p5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0x86_64p5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0x86_64p5-Shell-Guess-0.09nb1.tgz
NetBSD 9.0x86_64p5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0x86_64p5-Shell-Guess-0.09nb2.tgz
NetBSD 9.0x86_64p5-Shell-Guess-0.09nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.