devel/p5-Test-Modern - The NetBSD Packages Collection

Precision testing for modern perl

Test::Modern provides the best features of Test::More, Test::Fatal,
Test::Warnings, Test::API, Test::LongString, and Test::Deep, as well as
ideas from Test::Requires, Test::DescribeMe, Test::Moose, and
Test::CleanNamespaces.

Test::Modern also automatically imposes strict and warnings on your script,
and loads IO::File. (Much of the same stuff Modern::Perl does.)

Although Test::Modern is a modern testing framework, it should run fine on
pre-modern versions of Perl. It should be easy to install on Perl 5.8.9 and
above; and if you can persuade its dependencies to install (not necessarily
easy!), should be OK on anything back to Perl 5.6.1.

Build dependencies

devel/p5-Test-API devel/p5-Test-Deep devel/p5-Test-Fatal devel/p5-Test-Warnings pkgtools/cwrappers

Runtime dependencies

devel/p5-Module-Runtime devel/p5-Exporter-Tiny devel/p5-Import-Into lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Test-Modern-0.013nb5.tgz
NetBSD 8.0earmv7hfp5-Test-Modern-0.013nb4.tgz
NetBSD 8.0earmv7hfp5-Test-Modern-0.013nb4.tgz
NetBSD 8.0earmv7hfp5-Test-Modern-0.013nb5.tgz
NetBSD 8.0i386p5-Test-Modern-0.013nb4.tgz
NetBSD 8.0i386p5-Test-Modern-0.013nb5.tgz
NetBSD 8.0i386p5-Test-Modern-0.013nb5.tgz
NetBSD 8.0powerpcp5-Test-Modern-0.013nb5.tgz
NetBSD 8.0powerpcp5-Test-Modern-0.013nb5.tgz
NetBSD 8.0powerpcp5-Test-Modern-0.013nb5.tgz
NetBSD 8.0x86_64p5-Test-Modern-0.013nb5.tgz
NetBSD 8.0x86_64p5-Test-Modern-0.013nb4.tgz
NetBSD 8.0x86_64p5-Test-Modern-0.013nb5.tgz
NetBSD 9.0aarch64p5-Test-Modern-0.013nb5.tgz
NetBSD 9.0aarch64p5-Test-Modern-0.013nb4.tgz
NetBSD 9.0aarch64p5-Test-Modern-0.013nb5.tgz
NetBSD 9.0aarch64p5-Test-Modern-0.013nb5.tgz
NetBSD 9.0alphap5-Test-Modern-0.013nb5.tgz
NetBSD 9.0alphap5-Test-Modern-0.013nb4.tgz
NetBSD 9.0alphap5-Test-Modern-0.013nb5.tgz
NetBSD 9.0alphap5-Test-Modern-0.013nb5.tgz
NetBSD 9.0earmp5-Test-Modern-0.013nb5.tgz
NetBSD 9.0earmp5-Test-Modern-0.013nb4.tgz
NetBSD 9.0earmp5-Test-Modern-0.013nb5.tgz
NetBSD 9.0earmp5-Test-Modern-0.013nb5.tgz
NetBSD 9.0earmv6hfp5-Test-Modern-0.013nb5.tgz
NetBSD 9.0earmv6hfp5-Test-Modern-0.013nb4.tgz
NetBSD 9.0earmv6hfp5-Test-Modern-0.013nb5.tgz
NetBSD 9.0earmv6hfp5-Test-Modern-0.013nb5.tgz
NetBSD 9.0earmv6hfp5-Test-Modern-0.013nb5.tgz
NetBSD 9.0earmv7hfp5-Test-Modern-0.013nb5.tgz
NetBSD 9.0earmv7hfp5-Test-Modern-0.013nb4.tgz
NetBSD 9.0earmv7hfp5-Test-Modern-0.013nb4.tgz
NetBSD 9.0earmv7hfp5-Test-Modern-0.013nb5.tgz
NetBSD 9.0earmv7hfp5-Test-Modern-0.013nb5.tgz
NetBSD 9.0earmv7hfp5-Test-Modern-0.013nb5.tgz
NetBSD 9.0i386p5-Test-Modern-0.013nb4.tgz
NetBSD 9.0i386p5-Test-Modern-0.013nb5.tgz
NetBSD 9.0i386p5-Test-Modern-0.013nb5.tgz
NetBSD 9.0mips64ebp5-Test-Modern-0.013nb5.tgz
NetBSD 9.0mips64ebp5-Test-Modern-0.013nb5.tgz
NetBSD 9.0mips64ebp5-Test-Modern-0.013nb5.tgz
NetBSD 9.0powerpcp5-Test-Modern-0.013nb5.tgz
NetBSD 9.0powerpcp5-Test-Modern-0.013nb4.tgz
NetBSD 9.0powerpcp5-Test-Modern-0.013nb5.tgz
NetBSD 9.0sh3elp5-Test-Modern-0.013nb5.tgz
NetBSD 9.0sh3elp5-Test-Modern-0.013nb5.tgz
NetBSD 9.0sparc64p5-Test-Modern-0.013nb5.tgz
NetBSD 9.0sparc64p5-Test-Modern-0.013nb4.tgz
NetBSD 9.0sparc64p5-Test-Modern-0.013nb5.tgz
NetBSD 9.0sparc64p5-Test-Modern-0.013nb5.tgz
NetBSD 9.0sparcp5-Test-Modern-0.013nb5.tgz
NetBSD 9.0sparcp5-Test-Modern-0.013nb4.tgz
NetBSD 9.0sparcp5-Test-Modern-0.013nb5.tgz
NetBSD 9.0sparcp5-Test-Modern-0.013nb5.tgz
NetBSD 9.0x86_64p5-Test-Modern-0.013nb5.tgz
NetBSD 9.0x86_64p5-Test-Modern-0.013nb5.tgz
NetBSD 9.0x86_64p5-Test-Modern-0.013nb5.tgz
NetBSD 9.0x86_64p5-Test-Modern-0.013nb4.tgz
NetBSD 9.0x86_64p5-Test-Modern-0.013nb5.tgz
NetBSD 9.0x86_64p5-Test-Modern-0.013nb5.tgz
NetBSD 9.0x86_64p5-Test-Modern-0.013nb5.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.