devel/p5-Test-More-Behaviour - The NetBSD Packages Collection

BDD module for Perl modeled after Rspec

Test::More::Behaviour is a Behaviour-Driven Development module for
Perl programmers. It is modeled after Rspec (http://rspec.info),
the BDD tool for Ruby programmers. Test::More::Behaviour uses the
words `describe` and `it` so we can express concepts of the application
as we would in conversation.

Because Test::More::Behaviour uses Test::More as its 'base', you
can treat every Test::More::Behaviour test as if it were Test::More!

Build dependencies

devel/p5-IO-Capture pkgtools/cwrappers

Runtime dependencies

lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 8.0earmv7hfp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 8.0earmv7hfp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 8.0i386p5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 8.0i386p5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 8.0i386p5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 8.0powerpcp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 8.0powerpcp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 8.0powerpcp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 8.0x86_64p5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 8.0x86_64p5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0aarch64p5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0aarch64p5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0aarch64p5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0alphap5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0alphap5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0alphap5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0earmp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0earmp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0earmp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0earmv6hfp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0earmv6hfp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0earmv6hfp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0earmv6hfp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0earmv7hfp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0earmv7hfp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0earmv7hfp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0earmv7hfp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0i386p5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0i386p5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0i386p5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0mips64ebp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0mips64ebp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0mips64ebp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0mipselp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0mipselp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0powerpcp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0powerpcp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0sh3elp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0sh3elp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0sparc64p5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0sparc64p5-Test-More-Behaviour-1.0.1nb8.tgz
NetBSD 9.0sparc64p5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0sparc64p5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0sparcp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0sparcp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0sparcp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0vaxp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0vaxp5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0x86_64p5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0x86_64p5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0x86_64p5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0x86_64p5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0x86_64p5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0x86_64p5-Test-More-Behaviour-1.0.1nb9.tgz
NetBSD 9.0x86_64p5-Test-More-Behaviour-1.0.1nb9.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.