Daemon Power

The NetBSD Packages Collection: devel/py-angr

Brief description of the package:
Platform-agnostic binary analysis framework

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://github.com/angr/angr/.

Please note that this package has a 2-clause-bsd license.

The package is located in the "devel/py-angr" directory. The current source version of the package is "py37-angr-9.0.4378". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for devel/py-angr :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: py37-CppHeaderParser-[0-9]* py37-ply>=0 py37-setuptools-[0-9]* py37-expat-[0-9]* python37>=3.7 libffi>=1.20 cwrappers>=20150314 libuuid>=2.18 libffi>=3.3nb1 readline>=2.2 readline>=6.0 python37>=3.7.0 python37>=3.7.9 py37-archinfo>=9.0.4378 py37-future-[0-9]* py37-cachetools-[0-9]* py37-capstone>=4.0.2 capstone>=3.0 py37-cffi-[0-9]* py37-cparser-[0-9]* py37-claripy>=9.0.4378 py37-cachetools>=0 py37-decorator>=0 py37-future>=0 py37-smt>=0 py37-six>=0 py37-z3solver>=0 py37-cle>=9.0.4378 py37-cffi>=0 py37-minidump>=0 py37-pefile>=0 py37-pyelftools>=0.25 py37-pyvex>= py37-ailment>=9.0.4378 py37-bitstring-[0-9]* py37-cffi>=1.0.3 py37-sortedcontainers>=2.0 py37-xbe>=0.0.2 py37-itanium_demangler-[0-9]* py37-mulpyplexer-[0-9]* py37-networkx-[0-9]* py37-decorator>=4.3.0 py37-progressbar2-[0-9]* py37-utils>=0 py37-protobuf-[0-9]* py37-six>=1.9 protobuf>=3.0.0 protobuf>=3.12.0 py37-psutil-[0-9]* py37-pyvex>=9.0.4378 py37-unicorn-[0-9]* unicorn>=1.0.1 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 glib2>=2.4.0 pcre>=3.4nb1 pcre>=8.30nb1 meson-[0-9]* ninja-build>=1.7 re2c>=0.11.3 python27>=2.7.1nb2 glib2>=2.64.0nb1 .

This package requires the following package(s) to run: py37-CppHeaderParser-[0-9]* py37-ply>=0 py37-setuptools-[0-9]* py37-expat-[0-9]* python37>=3.7 libffi>=1.20 libuuid>=2.18 libffi>=3.3nb1 python37>=3.7.0 python37>=3.7.9 py37-archinfo>=9.0.4378 py37-future-[0-9]* py37-cachetools-[0-9]* py37-capstone>=4.0.2 capstone>=3.0 py37-cffi-[0-9]* py37-cparser-[0-9]* py37-claripy>=9.0.4378 py37-cachetools>=0 py37-decorator>=0 py37-future>=0 py37-smt>=0 py37-six>=0 py37-z3solver>=0 py37-cle>=9.0.4378 py37-cffi>=0 py37-minidump>=0 py37-pefile>=0 py37-pyelftools>=0.25 py37-pyvex>= py37-ailment>=9.0.4378 py37-bitstring-[0-9]* py37-cffi>=1.0.3 py37-sortedcontainers>=2.0 py37-xbe>=0.0.2 py37-itanium_demangler-[0-9]* py37-mulpyplexer-[0-9]* py37-networkx-[0-9]* py37-decorator>=4.3.0 py37-progressbar2-[0-9]* py37-utils>=0 py37-protobuf-[0-9]* py37-six>=1.9 protobuf>=3.0.0 protobuf>=3.12.0 py37-psutil-[0-9]* py37-pyvex>=9.0.4378 py37-unicorn-[0-9]* unicorn>=1.0.1 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 glib2>=2.4.0 pcre>=3.4nb1 pcre>=8.30nb1 python27>=2.7.1nb2 glib2>=2.64.0nb1 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
aarch64:py36-angr-8.20.1.7.tgz(NetBSD 9.0)
aarch64:py37-angr-8.20.1.7.tgz(NetBSD 9.0)
aarch64:py38-angr-8.20.1.7.tgz(NetBSD 9.0)
earmv7hf:py36-angr-8.20.1.7.tgz(NetBSD 8.0)
earmv7hf:py37-angr-8.20.1.7.tgz(NetBSD 8.0)
earmv7hf:py38-angr-8.20.1.7.tgz(NetBSD 8.0)
earmv7hf:py36-angr-8.20.1.7.tgz(NetBSD 9.0)
earmv7hf:py37-angr-8.20.1.7.tgz(NetBSD 9.0)
earmv7hf:py38-angr-8.20.1.7.tgz(NetBSD 9.0)
i386:py27-angr-7.8.2.21.tgz(NetBSD 7.0)
i386:py27-angr-7.8.2.21.tgz(NetBSD 7.0)
i386:py27-angr-7.8.2.21.tgz(NetBSD 7.1)
i386:py27-angr-7.8.2.21.tgz(NetBSD 7.1)
i386:py36-angr-8.20.1.7.tgz(NetBSD 7.1)
i386:py37-angr-8.20.1.7.tgz(NetBSD 7.1)
i386:py38-angr-8.20.1.7.tgz(NetBSD 7.1)
i386:py36-angr-8.20.7.27.tgz(NetBSD 8.0)
i386:py37-angr-8.20.7.27.tgz(NetBSD 8.0)
i386:py38-angr-8.20.7.27.tgz(NetBSD 8.0)
i386:py27-angr-7.8.2.21.tgz(NetBSD 8.0)
i386:py27-angr-7.8.2.21.tgz(NetBSD 8.0)
i386:py36-angr-8.20.1.7.tgz(NetBSD 8.0)
i386:py37-angr-8.20.1.7.tgz(NetBSD 8.0)
i386:py38-angr-8.20.1.7.tgz(NetBSD 8.0)
i386:py36-angr-8.20.7.27.tgz(NetBSD 9.0)
i386:py37-angr-8.20.7.27.tgz(NetBSD 9.0)
i386:py38-angr-8.20.7.27.tgz(NetBSD 9.0)
i386:py27-angr-7.8.2.21.tgz(NetBSD 9.0)
i386:py36-angr-8.20.1.7.tgz(NetBSD 9.0)
i386:py37-angr-8.20.1.7.tgz(NetBSD 9.0)
i386:py38-angr-8.20.1.7.tgz(NetBSD 9.0)
x86_64:py36-angr-8.20.1.7.tgz(NetBSD 9.0)
x86_64:py37-angr-8.20.1.7.tgz(NetBSD 9.0)
x86_64:py38-angr-8.20.1.7.tgz(NetBSD 9.0)
x86_64:py36-angr-8.20.1.7.tgz(NetBSD 9.0)
x86_64:py37-angr-8.20.1.7.tgz(NetBSD 9.0)
x86_64:py38-angr-8.20.1.7.tgz(NetBSD 9.0)
x86_64:py27-angr-7.8.2.21.tgz(NetBSD 7.0)
x86_64:py27-angr-7.8.2.21.tgz(NetBSD 7.0)
x86_64:py36-angr-8.20.1.7.tgz(NetBSD 7.1)
x86_64:py37-angr-8.20.1.7.tgz(NetBSD 7.1)
x86_64:py38-angr-8.20.1.7.tgz(NetBSD 7.1)
x86_64:py27-angr-7.8.2.21.tgz(NetBSD 7.1)
x86_64:py27-angr-7.8.2.21.tgz(NetBSD 7.1)
x86_64:py27-angr-7.8.2.21.tgz(NetBSD 8.0)
x86_64:py27-angr-7.8.2.21.tgz(NetBSD 8.0)
x86_64:py36-angr-8.20.1.7.tgz(NetBSD 8.0)
x86_64:py37-angr-8.20.1.7.tgz(NetBSD 8.0)
x86_64:py38-angr-8.20.1.7.tgz(NetBSD 8.0)
x86_64:py36-angr-8.20.7.27.tgz(NetBSD 8.0)
x86_64:py37-angr-8.20.7.27.tgz(NetBSD 8.0)
x86_64:py38-angr-8.20.7.27.tgz(NetBSD 8.0)
x86_64:py36-angr-8.20.7.27.tgz(NetBSD 9.0)
x86_64:py37-angr-8.20.7.27.tgz(NetBSD 9.0)
x86_64:py38-angr-8.20.7.27.tgz(NetBSD 9.0)
x86_64:py27-angr-7.8.2.21.tgz(NetBSD 9.0)
x86_64:py36-angr-8.20.1.7.tgz(NetBSD 9.0)
x86_64:py37-angr-8.20.1.7.tgz(NetBSD 9.0)
x86_64:py38-angr-8.20.1.7.tgz(NetBSD 9.0)
x86_64:py36-angr-8.20.7.27.tgz(NetBSD 9.0)
x86_64:py37-angr-8.20.7.27.tgz(NetBSD 9.0)
x86_64:py38-angr-8.20.7.27.tgz(NetBSD 9.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]