devel/py-bcolz - The NetBSD Packages Collection

Columnar and compressed data containers

bcolz provides columnar and compressed data containers. Column storage
allows for efficiently querying tables with a large number of
columns. It also allows for cheap addition and removal of column. In
addition, bcolz objects are compressed by default for reducing
memory/disk I/O needs. The compression process is carried out
internally by Blosc, a high-performance compressor that is optimized
for binary data.

Build dependencies

devel/py-setuptools_scm pkgtools/cwrappers

Runtime dependencies

devel/py-setuptools devel/blosc devel/py-cython math/py-numpy math/py-numpy math/py-numpy

Binary packages

OSArchitectureVersion
NetBSD 8.0i386py27-bcolz-1.2.1.tgz
NetBSD 8.0i386py36-bcolz-1.2.1.tgz
NetBSD 8.0i386py37-bcolz-1.2.1.tgz
NetBSD 8.0i386py38-bcolz-1.2.1.tgz
NetBSD 8.0i386py27-bcolz-1.2.1nb1.tgz
NetBSD 8.0i386py36-bcolz-1.2.1nb1.tgz
NetBSD 8.0i386py37-bcolz-1.2.1nb1.tgz
NetBSD 8.0i386py38-bcolz-1.2.1nb1.tgz
NetBSD 8.0powerpcpy27-bcolz-1.2.1.tgz
NetBSD 8.0powerpcpy36-bcolz-1.2.1.tgz
NetBSD 8.0powerpcpy37-bcolz-1.2.1.tgz
NetBSD 8.0powerpcpy38-bcolz-1.2.1.tgz
NetBSD 8.0powerpcpy27-bcolz-1.2.1nb1.tgz
NetBSD 8.0powerpcpy36-bcolz-1.2.1nb1.tgz
NetBSD 8.0powerpcpy37-bcolz-1.2.1nb1.tgz
NetBSD 8.0powerpcpy38-bcolz-1.2.1nb1.tgz
NetBSD 8.0powerpcpy27-bcolz-1.2.1nb1.tgz
NetBSD 8.0powerpcpy36-bcolz-1.2.1nb1.tgz
NetBSD 8.0powerpcpy37-bcolz-1.2.1nb1.tgz
NetBSD 8.0powerpcpy38-bcolz-1.2.1nb1.tgz
NetBSD 8.0x86_64py27-bcolz-1.2.1.tgz
NetBSD 8.0x86_64py36-bcolz-1.2.1.tgz
NetBSD 8.0x86_64py37-bcolz-1.2.1.tgz
NetBSD 8.0x86_64py38-bcolz-1.2.1.tgz
NetBSD 8.0x86_64py27-bcolz-1.2.1nb1.tgz
NetBSD 8.0x86_64py36-bcolz-1.2.1nb1.tgz
NetBSD 8.0x86_64py37-bcolz-1.2.1nb1.tgz
NetBSD 8.0x86_64py38-bcolz-1.2.1nb1.tgz
NetBSD 9.0aarch64py27-bcolz-1.2.1nb1.tgz
NetBSD 9.0aarch64py36-bcolz-1.2.1nb1.tgz
NetBSD 9.0aarch64py37-bcolz-1.2.1nb1.tgz
NetBSD 9.0aarch64py38-bcolz-1.2.1nb1.tgz
NetBSD 9.0aarch64py27-bcolz-1.2.1.tgz
NetBSD 9.0aarch64py36-bcolz-1.2.1.tgz
NetBSD 9.0aarch64py37-bcolz-1.2.1.tgz
NetBSD 9.0aarch64py38-bcolz-1.2.1.tgz
NetBSD 9.0aarch64py27-bcolz-1.2.1nb1.tgz
NetBSD 9.0aarch64py36-bcolz-1.2.1nb1.tgz
NetBSD 9.0aarch64py37-bcolz-1.2.1nb1.tgz
NetBSD 9.0aarch64py38-bcolz-1.2.1nb1.tgz
NetBSD 9.0alphapy27-bcolz-1.2.1nb1.tgz
NetBSD 9.0alphapy27-bcolz-1.2.1.tgz
NetBSD 9.0alphapy27-bcolz-1.2.1nb1.tgz
NetBSD 9.0i386py27-bcolz-1.2.1.tgz
NetBSD 9.0i386py36-bcolz-1.2.1.tgz
NetBSD 9.0i386py37-bcolz-1.2.1.tgz
NetBSD 9.0i386py38-bcolz-1.2.1.tgz
NetBSD 9.0i386py27-bcolz-1.2.1nb1.tgz
NetBSD 9.0i386py36-bcolz-1.2.1nb1.tgz
NetBSD 9.0i386py37-bcolz-1.2.1nb1.tgz
NetBSD 9.0i386py38-bcolz-1.2.1nb1.tgz
NetBSD 9.0powerpcpy27-bcolz-1.2.1nb1.tgz
NetBSD 9.0powerpcpy36-bcolz-1.2.1nb1.tgz
NetBSD 9.0powerpcpy37-bcolz-1.2.1nb1.tgz
NetBSD 9.0powerpcpy38-bcolz-1.2.1nb1.tgz
NetBSD 9.0powerpcpy27-bcolz-1.2.1.tgz
NetBSD 9.0powerpcpy36-bcolz-1.2.1.tgz
NetBSD 9.0powerpcpy37-bcolz-1.2.1.tgz
NetBSD 9.0powerpcpy38-bcolz-1.2.1.tgz
NetBSD 9.0x86_64py27-bcolz-1.2.1nb1.tgz
NetBSD 9.0x86_64py36-bcolz-1.2.1nb1.tgz
NetBSD 9.0x86_64py37-bcolz-1.2.1nb1.tgz
NetBSD 9.0x86_64py38-bcolz-1.2.1nb1.tgz
NetBSD 9.0x86_64py27-bcolz-1.2.1nb1.tgz
NetBSD 9.0x86_64py36-bcolz-1.2.1nb1.tgz
NetBSD 9.0x86_64py37-bcolz-1.2.1nb1.tgz
NetBSD 9.0x86_64py38-bcolz-1.2.1nb1.tgz
NetBSD 9.0x86_64py27-bcolz-1.2.1nb1.tgz
NetBSD 9.0x86_64py36-bcolz-1.2.1nb1.tgz
NetBSD 9.0x86_64py37-bcolz-1.2.1nb1.tgz
NetBSD 9.0x86_64py38-bcolz-1.2.1nb1.tgz
NetBSD 9.0x86_64py27-bcolz-1.2.1.tgz
NetBSD 9.0x86_64py36-bcolz-1.2.1.tgz
NetBSD 9.0x86_64py37-bcolz-1.2.1.tgz
NetBSD 9.0x86_64py38-bcolz-1.2.1.tgz
NetBSD 9.0x86_64py27-bcolz-1.2.1nb1.tgz
NetBSD 9.0x86_64py36-bcolz-1.2.1nb1.tgz
NetBSD 9.0x86_64py37-bcolz-1.2.1nb1.tgz
NetBSD 9.0x86_64py38-bcolz-1.2.1nb1.tgz
NetBSD 9.0x86_64py27-bcolz-1.2.1nb1.tgz
NetBSD 9.0x86_64py36-bcolz-1.2.1nb1.tgz
NetBSD 9.0x86_64py37-bcolz-1.2.1nb1.tgz
NetBSD 9.0x86_64py38-bcolz-1.2.1nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.