devel/py-pygit2 - The NetBSD Packages Collection

Python bindings to libgit2

pygit2 is a set of Python bindings to the libgit2 linkable C Git library.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/py-cffi devel/py-cparser devel/py-cached-property devel/py-setuptools devel/libgit2 lang/python38 lang/python38 devel/libgit2

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfpy36-pygit2-1.4.0.tgz
NetBSD 8.0earmv7hfpy37-pygit2-1.4.0.tgz
NetBSD 8.0earmv7hfpy38-pygit2-1.4.0.tgz
NetBSD 8.0earmv7hfpy39-pygit2-1.4.0.tgz
NetBSD 8.0earmv7hfpy36-pygit2-1.1.1nb1.tgz
NetBSD 8.0earmv7hfpy37-pygit2-1.1.1nb1.tgz
NetBSD 8.0earmv7hfpy38-pygit2-1.1.1nb1.tgz
NetBSD 8.0earmv7hfpy36-pygit2-1.2.1.tgz
NetBSD 8.0earmv7hfpy37-pygit2-1.2.1.tgz
NetBSD 8.0earmv7hfpy38-pygit2-1.2.1.tgz
NetBSD 8.0earmv7hfpy37-pygit2-1.2.1.tgz
NetBSD 8.0i386py36-pygit2-1.2.1.tgz
NetBSD 8.0i386py37-pygit2-1.2.1.tgz
NetBSD 8.0i386py38-pygit2-1.2.1.tgz
NetBSD 8.0i386py36-pygit2-1.2.1.tgz
NetBSD 8.0i386py37-pygit2-1.2.1.tgz
NetBSD 8.0i386py38-pygit2-1.2.1.tgz
NetBSD 8.0i386py36-pygit2-1.4.0.tgz
NetBSD 8.0i386py37-pygit2-1.4.0.tgz
NetBSD 8.0i386py38-pygit2-1.4.0.tgz
NetBSD 8.0i386py39-pygit2-1.4.0.tgz
NetBSD 8.0powerpcpy36-pygit2-1.2.1.tgz
NetBSD 8.0powerpcpy37-pygit2-1.2.1.tgz
NetBSD 8.0powerpcpy38-pygit2-1.2.1.tgz
NetBSD 8.0powerpcpy36-pygit2-1.4.0.tgz
NetBSD 8.0powerpcpy37-pygit2-1.4.0.tgz
NetBSD 8.0powerpcpy38-pygit2-1.4.0.tgz
NetBSD 8.0powerpcpy39-pygit2-1.4.0.tgz
NetBSD 8.0powerpcpy36-pygit2-1.4.0.tgz
NetBSD 8.0powerpcpy37-pygit2-1.4.0.tgz
NetBSD 8.0powerpcpy38-pygit2-1.4.0.tgz
NetBSD 8.0powerpcpy39-pygit2-1.4.0.tgz
NetBSD 8.0x86_64py36-pygit2-1.2.1.tgz
NetBSD 8.0x86_64py37-pygit2-1.2.1.tgz
NetBSD 8.0x86_64py38-pygit2-1.2.1.tgz
NetBSD 8.0x86_64py36-pygit2-1.2.1.tgz
NetBSD 8.0x86_64py37-pygit2-1.2.1.tgz
NetBSD 8.0x86_64py38-pygit2-1.2.1.tgz
NetBSD 8.0x86_64py36-pygit2-1.4.0.tgz
NetBSD 8.0x86_64py37-pygit2-1.4.0.tgz
NetBSD 8.0x86_64py38-pygit2-1.4.0.tgz
NetBSD 8.0x86_64py39-pygit2-1.4.0.tgz
NetBSD 9.0aarch64py36-pygit2-1.5.0.tgz
NetBSD 9.0aarch64py37-pygit2-1.5.0.tgz
NetBSD 9.0aarch64py38-pygit2-1.5.0.tgz
NetBSD 9.0aarch64py39-pygit2-1.5.0.tgz
NetBSD 9.0aarch64py36-pygit2-1.2.1.tgz
NetBSD 9.0aarch64py37-pygit2-1.2.1.tgz
NetBSD 9.0aarch64py38-pygit2-1.2.1.tgz
NetBSD 9.0aarch64py36-pygit2-1.2.1.tgz
NetBSD 9.0aarch64py37-pygit2-1.2.1.tgz
NetBSD 9.0aarch64py38-pygit2-1.2.1.tgz
NetBSD 9.0aarch64py36-pygit2-1.4.0.tgz
NetBSD 9.0aarch64py37-pygit2-1.4.0.tgz
NetBSD 9.0aarch64py38-pygit2-1.4.0.tgz
NetBSD 9.0aarch64py39-pygit2-1.4.0.tgz
NetBSD 9.0alphapy36-pygit2-1.2.1.tgz
NetBSD 9.0alphapy37-pygit2-1.2.1.tgz
NetBSD 9.0alphapy38-pygit2-1.2.1.tgz
NetBSD 9.0alphapy36-pygit2-1.4.0.tgz
NetBSD 9.0alphapy37-pygit2-1.4.0.tgz
NetBSD 9.0alphapy38-pygit2-1.4.0.tgz
NetBSD 9.0alphapy39-pygit2-1.4.0.tgz
NetBSD 9.0earmpy36-pygit2-1.2.1.tgz
NetBSD 9.0earmpy37-pygit2-1.2.1.tgz
NetBSD 9.0earmpy38-pygit2-1.2.1.tgz
NetBSD 9.0earmv6hfpy36-pygit2-1.5.0.tgz
NetBSD 9.0earmv6hfpy37-pygit2-1.5.0.tgz
NetBSD 9.0earmv6hfpy38-pygit2-1.5.0.tgz
NetBSD 9.0earmv6hfpy39-pygit2-1.5.0.tgz
NetBSD 9.0earmv6hfpy36-pygit2-1.2.1.tgz
NetBSD 9.0earmv6hfpy37-pygit2-1.2.1.tgz
NetBSD 9.0earmv6hfpy38-pygit2-1.2.1.tgz
NetBSD 9.0earmv6hfpy36-pygit2-1.2.1.tgz
NetBSD 9.0earmv6hfpy37-pygit2-1.2.1.tgz
NetBSD 9.0earmv6hfpy38-pygit2-1.2.1.tgz
NetBSD 9.0earmv6hfpy36-pygit2-1.4.0.tgz
NetBSD 9.0earmv6hfpy37-pygit2-1.4.0.tgz
NetBSD 9.0earmv6hfpy38-pygit2-1.4.0.tgz
NetBSD 9.0earmv6hfpy39-pygit2-1.4.0.tgz
NetBSD 9.0earmv6hfpy36-pygit2-1.4.0.tgz
NetBSD 9.0earmv6hfpy37-pygit2-1.4.0.tgz
NetBSD 9.0earmv6hfpy38-pygit2-1.4.0.tgz
NetBSD 9.0earmv6hfpy39-pygit2-1.4.0.tgz
NetBSD 9.0earmv7hfpy36-pygit2-1.5.0.tgz
NetBSD 9.0earmv7hfpy37-pygit2-1.5.0.tgz
NetBSD 9.0earmv7hfpy38-pygit2-1.5.0.tgz
NetBSD 9.0earmv7hfpy39-pygit2-1.5.0.tgz
NetBSD 9.0earmv7hfpy36-pygit2-1.1.1nb1.tgz
NetBSD 9.0earmv7hfpy37-pygit2-1.1.1nb1.tgz
NetBSD 9.0earmv7hfpy38-pygit2-1.1.1nb1.tgz
NetBSD 9.0earmv7hfpy36-pygit2-1.2.1.tgz
NetBSD 9.0earmv7hfpy37-pygit2-1.2.1.tgz
NetBSD 9.0earmv7hfpy38-pygit2-1.2.1.tgz
NetBSD 9.0earmv7hfpy36-pygit2-1.2.1.tgz
NetBSD 9.0earmv7hfpy37-pygit2-1.2.1.tgz
NetBSD 9.0earmv7hfpy38-pygit2-1.2.1.tgz
NetBSD 9.0earmv7hfpy36-pygit2-1.4.0.tgz
NetBSD 9.0earmv7hfpy37-pygit2-1.4.0.tgz
NetBSD 9.0earmv7hfpy38-pygit2-1.4.0.tgz
NetBSD 9.0earmv7hfpy39-pygit2-1.4.0.tgz
NetBSD 9.0earmv7hfpy36-pygit2-1.4.0.tgz
NetBSD 9.0earmv7hfpy37-pygit2-1.4.0.tgz
NetBSD 9.0earmv7hfpy38-pygit2-1.4.0.tgz
NetBSD 9.0earmv7hfpy39-pygit2-1.4.0.tgz
NetBSD 9.0i386py36-pygit2-1.2.1.tgz
NetBSD 9.0i386py37-pygit2-1.2.1.tgz
NetBSD 9.0i386py38-pygit2-1.2.1.tgz
NetBSD 9.0i386py36-pygit2-1.2.1.tgz
NetBSD 9.0i386py37-pygit2-1.2.1.tgz
NetBSD 9.0i386py38-pygit2-1.2.1.tgz
NetBSD 9.0i386py36-pygit2-1.4.0.tgz
NetBSD 9.0i386py37-pygit2-1.4.0.tgz
NetBSD 9.0i386py38-pygit2-1.4.0.tgz
NetBSD 9.0i386py39-pygit2-1.4.0.tgz
NetBSD 9.0mips64ebpy36-pygit2-1.2.1.tgz
NetBSD 9.0mips64ebpy37-pygit2-1.2.1.tgz
NetBSD 9.0mips64ebpy38-pygit2-1.2.1.tgz
NetBSD 9.0mips64ebpy36-pygit2-1.4.0.tgz
NetBSD 9.0mips64ebpy37-pygit2-1.4.0.tgz
NetBSD 9.0mips64ebpy38-pygit2-1.4.0.tgz
NetBSD 9.0mips64ebpy39-pygit2-1.4.0.tgz
NetBSD 9.0powerpcpy36-pygit2-1.4.0.tgz
NetBSD 9.0powerpcpy37-pygit2-1.4.0.tgz
NetBSD 9.0powerpcpy38-pygit2-1.4.0.tgz
NetBSD 9.0powerpcpy39-pygit2-1.4.0.tgz
NetBSD 9.0powerpcpy36-pygit2-1.2.1.tgz
NetBSD 9.0powerpcpy37-pygit2-1.2.1.tgz
NetBSD 9.0powerpcpy38-pygit2-1.2.1.tgz
NetBSD 9.0powerpcpy36-pygit2-1.2.1.tgz
NetBSD 9.0powerpcpy37-pygit2-1.2.1.tgz
NetBSD 9.0powerpcpy38-pygit2-1.2.1.tgz
NetBSD 9.0sparc64py36-pygit2-1.2.1.tgz
NetBSD 9.0sparc64py37-pygit2-1.2.1.tgz
NetBSD 9.0sparc64py38-pygit2-1.2.1.tgz
NetBSD 9.0sparc64py36-pygit2-1.4.0.tgz
NetBSD 9.0sparc64py37-pygit2-1.4.0.tgz
NetBSD 9.0sparc64py38-pygit2-1.4.0.tgz
NetBSD 9.0sparc64py39-pygit2-1.4.0.tgz
NetBSD 9.0sparcpy36-pygit2-1.4.0.tgz
NetBSD 9.0sparcpy37-pygit2-1.4.0.tgz
NetBSD 9.0sparcpy38-pygit2-1.4.0.tgz
NetBSD 9.0sparcpy39-pygit2-1.4.0.tgz
NetBSD 9.0x86_64py36-pygit2-1.4.0.tgz
NetBSD 9.0x86_64py37-pygit2-1.4.0.tgz
NetBSD 9.0x86_64py38-pygit2-1.4.0.tgz
NetBSD 9.0x86_64py39-pygit2-1.4.0.tgz
NetBSD 9.0x86_64py36-pygit2-1.4.0.tgz
NetBSD 9.0x86_64py37-pygit2-1.4.0.tgz
NetBSD 9.0x86_64py38-pygit2-1.4.0.tgz
NetBSD 9.0x86_64py39-pygit2-1.4.0.tgz
NetBSD 9.0x86_64py36-pygit2-1.5.0.tgz
NetBSD 9.0x86_64py37-pygit2-1.5.0.tgz
NetBSD 9.0x86_64py38-pygit2-1.5.0.tgz
NetBSD 9.0x86_64py39-pygit2-1.5.0.tgz
NetBSD 9.0x86_64py36-pygit2-1.2.1.tgz
NetBSD 9.0x86_64py37-pygit2-1.2.1.tgz
NetBSD 9.0x86_64py38-pygit2-1.2.1.tgz
NetBSD 9.0x86_64py36-pygit2-1.2.1.tgz
NetBSD 9.0x86_64py37-pygit2-1.2.1.tgz
NetBSD 9.0x86_64py38-pygit2-1.2.1.tgz
NetBSD 9.0x86_64py36-pygit2-1.4.0.tgz
NetBSD 9.0x86_64py37-pygit2-1.4.0.tgz
NetBSD 9.0x86_64py38-pygit2-1.4.0.tgz
NetBSD 9.0x86_64py39-pygit2-1.4.0.tgz
NetBSD 9.0x86_64py36-pygit2-1.5.0.tgz
NetBSD 9.0x86_64py37-pygit2-1.5.0.tgz
NetBSD 9.0x86_64py38-pygit2-1.5.0.tgz
NetBSD 9.0x86_64py39-pygit2-1.5.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.