devel/py-subprocess32 - The NetBSD Packages Collection

Backport of the subprocess module from Python 3.2/3.3 for use on 2.x

Backport of the subprocess module from Python 3.2/3.3 for use on 2.x.

This is a backport of the subprocess standard library module from Python
3.2 & 3.3 for use on Python 2.4, 2.5, 2.6 and 2.7. It includes bugfixes
and new features. On POSIX systems it is guaranteed to be reliable when
used in threaded applications. Bonus: It includes timeout support from
Python 3.3.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/py-setuptools44 lang/python27 lang/python27

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfpy27-subprocess32-3.5.4.tgz
NetBSD 8.0earmv7hfpy27-subprocess32-3.5.4.tgz
NetBSD 8.0earmv7hfpy27-subprocess32-3.5.4.tgz
NetBSD 8.0earmv7hfpy27-subprocess32-3.5.4.tgz
NetBSD 8.0i386py27-subprocess32-3.5.4.tgz
NetBSD 8.0i386py27-subprocess32-3.5.4.tgz
NetBSD 8.0i386py27-subprocess32-3.5.4.tgz
NetBSD 8.0powerpcpy27-subprocess32-3.5.4.tgz
NetBSD 8.0powerpcpy27-subprocess32-3.5.4.tgz
NetBSD 8.0powerpcpy27-subprocess32-3.5.4.tgz
NetBSD 8.0x86_64py27-subprocess32-3.5.4.tgz
NetBSD 8.0x86_64py27-subprocess32-3.5.4.tgz
NetBSD 8.0x86_64py27-subprocess32-3.5.4.tgz
NetBSD 9.0aarch64py27-subprocess32-3.5.4.tgz
NetBSD 9.0aarch64py27-subprocess32-3.5.4.tgz
NetBSD 9.0aarch64py27-subprocess32-3.5.4.tgz
NetBSD 9.0aarch64py27-subprocess32-3.5.4.tgz
NetBSD 9.0alphapy27-subprocess32-3.5.4.tgz
NetBSD 9.0alphapy27-subprocess32-3.5.4.tgz
NetBSD 9.0alphapy27-subprocess32-3.5.4.tgz
NetBSD 9.0alphapy27-subprocess32-3.5.4.tgz
NetBSD 9.0earmpy27-subprocess32-3.5.4.tgz
NetBSD 9.0earmpy27-subprocess32-3.5.4.tgz
NetBSD 9.0earmpy27-subprocess32-3.5.4.tgz
NetBSD 9.0earmpy27-subprocess32-3.5.4.tgz
NetBSD 9.0earmv6hfpy27-subprocess32-3.5.4.tgz
NetBSD 9.0earmv6hfpy27-subprocess32-3.5.4.tgz
NetBSD 9.0earmv6hfpy27-subprocess32-3.5.4.tgz
NetBSD 9.0earmv6hfpy27-subprocess32-3.5.4.tgz
NetBSD 9.0earmv6hfpy27-subprocess32-3.5.4.tgz
NetBSD 9.0earmv7hfpy27-subprocess32-3.5.4.tgz
NetBSD 9.0earmv7hfpy27-subprocess32-3.5.4.tgz
NetBSD 9.0earmv7hfpy27-subprocess32-3.5.4.tgz
NetBSD 9.0earmv7hfpy27-subprocess32-3.5.4.tgz
NetBSD 9.0earmv7hfpy27-subprocess32-3.5.4.tgz
NetBSD 9.0earmv7hfpy27-subprocess32-3.5.4.tgz
NetBSD 9.0i386py27-subprocess32-3.5.4.tgz
NetBSD 9.0i386py27-subprocess32-3.5.4.tgz
NetBSD 9.0i386py27-subprocess32-3.5.4.tgz
NetBSD 9.0mips64ebpy27-subprocess32-3.5.4.tgz
NetBSD 9.0mips64ebpy27-subprocess32-3.5.4.tgz
NetBSD 9.0mips64ebpy27-subprocess32-3.5.4.tgz
NetBSD 9.0mipselpy27-subprocess32-3.5.4.tgz
NetBSD 9.0mipselpy27-subprocess32-3.5.4.tgz
NetBSD 9.0powerpcpy27-subprocess32-3.5.4.tgz
NetBSD 9.0powerpcpy27-subprocess32-3.5.4.tgz
NetBSD 9.0powerpcpy27-subprocess32-3.5.4.tgz
NetBSD 9.0sh3elpy27-subprocess32-3.5.4.tgz
NetBSD 9.0sh3elpy27-subprocess32-3.5.4.tgz
NetBSD 9.0sparc64py27-subprocess32-3.5.4.tgz
NetBSD 9.0sparc64py27-subprocess32-3.5.4.tgz
NetBSD 9.0sparc64py27-subprocess32-3.5.4.tgz
NetBSD 9.0sparc64py27-subprocess32-3.5.4.tgz
NetBSD 9.0sparcpy27-subprocess32-3.5.4.tgz
NetBSD 9.0sparcpy27-subprocess32-3.5.4.tgz
NetBSD 9.0sparcpy27-subprocess32-3.5.4.tgz
NetBSD 9.0sparcpy27-subprocess32-3.5.4.tgz
NetBSD 9.0x86_64py27-subprocess32-3.5.4.tgz
NetBSD 9.0x86_64py27-subprocess32-3.5.4.tgz
NetBSD 9.0x86_64py27-subprocess32-3.5.4.tgz
NetBSD 9.0x86_64py27-subprocess32-3.5.4.tgz
NetBSD 9.0x86_64py27-subprocess32-3.5.4.tgz
NetBSD 9.0x86_64py27-subprocess32-3.5.4.tgz
NetBSD 9.0x86_64py27-subprocess32-3.5.4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.