devel/ruby-native-package-installer - The NetBSD Packages Collection

Helper to install native packages on "gem install"

Users need to install native packages to install an extension library that
depends on native packages.  It bores users because users need to install
native packages and an extension library separately.

native-package-installer helps to install native packages on "gem install".
Users can install both native packages and an extension library by one action,
"gem install"."

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/ruby26-base

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfruby25-native-package-installer-1.0.9.tgz
NetBSD 8.0earmv7hfruby26-native-package-installer-1.0.9.tgz
NetBSD 8.0earmv7hfruby27-native-package-installer-1.0.9.tgz
NetBSD 8.0earmv7hfruby25-native-package-installer-1.0.9.tgz
NetBSD 8.0earmv7hfruby26-native-package-installer-1.0.9.tgz
NetBSD 8.0earmv7hfruby27-native-package-installer-1.0.9.tgz
NetBSD 8.0earmv7hfruby25-native-package-installer-1.1.1.tgz
NetBSD 8.0earmv7hfruby26-native-package-installer-1.1.1.tgz
NetBSD 8.0earmv7hfruby27-native-package-installer-1.1.1.tgz
NetBSD 8.0i386ruby25-native-package-installer-1.0.9.tgz
NetBSD 8.0i386ruby26-native-package-installer-1.0.9.tgz
NetBSD 8.0i386ruby27-native-package-installer-1.0.9.tgz
NetBSD 8.0i386ruby25-native-package-installer-1.0.9.tgz
NetBSD 8.0i386ruby26-native-package-installer-1.0.9.tgz
NetBSD 8.0i386ruby27-native-package-installer-1.0.9.tgz
NetBSD 8.0powerpcruby25-native-package-installer-1.0.9.tgz
NetBSD 8.0powerpcruby26-native-package-installer-1.0.9.tgz
NetBSD 8.0powerpcruby27-native-package-installer-1.0.9.tgz
NetBSD 8.0powerpcruby25-native-package-installer-1.0.9.tgz
NetBSD 8.0powerpcruby26-native-package-installer-1.0.9.tgz
NetBSD 8.0powerpcruby27-native-package-installer-1.0.9.tgz
NetBSD 8.0powerpcruby25-native-package-installer-1.0.9.tgz
NetBSD 8.0powerpcruby26-native-package-installer-1.0.9.tgz
NetBSD 8.0powerpcruby27-native-package-installer-1.0.9.tgz
NetBSD 8.0x86_64ruby25-native-package-installer-1.0.9.tgz
NetBSD 8.0x86_64ruby26-native-package-installer-1.0.9.tgz
NetBSD 8.0x86_64ruby27-native-package-installer-1.0.9.tgz
NetBSD 8.0x86_64ruby25-native-package-installer-1.0.9.tgz
NetBSD 8.0x86_64ruby26-native-package-installer-1.0.9.tgz
NetBSD 8.0x86_64ruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0aarch64ruby25-native-package-installer-1.1.1.tgz
NetBSD 9.0aarch64ruby26-native-package-installer-1.1.1.tgz
NetBSD 9.0aarch64ruby27-native-package-installer-1.1.1.tgz
NetBSD 9.0aarch64ruby30-native-package-installer-1.1.1.tgz
NetBSD 9.0aarch64ruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0aarch64ruby26-native-package-installer-1.0.9.tgz
NetBSD 9.0aarch64ruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0aarch64ruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0aarch64ruby26-native-package-installer-1.0.9.tgz
NetBSD 9.0aarch64ruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0alpharuby25-native-package-installer-1.1.1.tgz
NetBSD 9.0alpharuby26-native-package-installer-1.1.1.tgz
NetBSD 9.0alpharuby27-native-package-installer-1.1.1.tgz
NetBSD 9.0alpharuby25-native-package-installer-1.0.9.tgz
NetBSD 9.0alpharuby26-native-package-installer-1.0.9.tgz
NetBSD 9.0alpharuby27-native-package-installer-1.0.9.tgz
NetBSD 9.0alpharuby25-native-package-installer-1.0.9.tgz
NetBSD 9.0alpharuby26-native-package-installer-1.0.9.tgz
NetBSD 9.0alpharuby27-native-package-installer-1.0.9.tgz
NetBSD 9.0earmruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0earmruby26-native-package-installer-1.0.9.tgz
NetBSD 9.0earmruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0earmruby26-native-package-installer-1.0.9.tgz
NetBSD 9.0earmruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0earmv6hfruby25-native-package-installer-1.1.1.tgz
NetBSD 9.0earmv6hfruby26-native-package-installer-1.1.1.tgz
NetBSD 9.0earmv6hfruby27-native-package-installer-1.1.1.tgz
NetBSD 9.0earmv6hfruby30-native-package-installer-1.1.1.tgz
NetBSD 9.0earmv6hfruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0earmv6hfruby26-native-package-installer-1.0.9.tgz
NetBSD 9.0earmv6hfruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0earmv6hfruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0earmv6hfruby26-native-package-installer-1.0.9.tgz
NetBSD 9.0earmv6hfruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0earmv6hfruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0earmv6hfruby26-native-package-installer-1.0.9.tgz
NetBSD 9.0earmv6hfruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0earmv7hfruby25-native-package-installer-1.1.1.tgz
NetBSD 9.0earmv7hfruby26-native-package-installer-1.1.1.tgz
NetBSD 9.0earmv7hfruby27-native-package-installer-1.1.1.tgz
NetBSD 9.0earmv7hfruby30-native-package-installer-1.1.1.tgz
NetBSD 9.0earmv7hfruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0earmv7hfruby26-native-package-installer-1.0.9.tgz
NetBSD 9.0earmv7hfruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0earmv7hfruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0earmv7hfruby26-native-package-installer-1.0.9.tgz
NetBSD 9.0earmv7hfruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0earmv7hfruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0earmv7hfruby26-native-package-installer-1.0.9.tgz
NetBSD 9.0earmv7hfruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0i386ruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0i386ruby26-native-package-installer-1.0.9.tgz
NetBSD 9.0i386ruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0i386ruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0i386ruby26-native-package-installer-1.0.9.tgz
NetBSD 9.0i386ruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0m68kruby26-native-package-installer-1.1.1.tgz
NetBSD 9.0m68kruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0m68kruby26-native-package-installer-1.0.9.tgz
NetBSD 9.0m68kruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0m68kruby26-native-package-installer-1.0.9.tgz
NetBSD 9.0mips64ebruby25-native-package-installer-1.1.1.tgz
NetBSD 9.0mips64ebruby26-native-package-installer-1.1.1.tgz
NetBSD 9.0mips64ebruby27-native-package-installer-1.1.1.tgz
NetBSD 9.0mips64ebruby30-native-package-installer-1.1.1.tgz
NetBSD 9.0mips64ebruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0mips64ebruby26-native-package-installer-1.0.9.tgz
NetBSD 9.0mips64ebruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0mips64ebruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0mips64ebruby26-native-package-installer-1.0.9.tgz
NetBSD 9.0mips64ebruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0mipselruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0mipselruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0powerpcruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0powerpcruby26-native-package-installer-1.0.9.tgz
NetBSD 9.0powerpcruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0powerpcruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0powerpcruby26-native-package-installer-1.0.9.tgz
NetBSD 9.0powerpcruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0sh3elruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0sh3elruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0sparc64ruby25-native-package-installer-1.1.1.tgz
NetBSD 9.0sparc64ruby26-native-package-installer-1.1.1.tgz
NetBSD 9.0sparc64ruby27-native-package-installer-1.1.1.tgz
NetBSD 9.0sparc64ruby30-native-package-installer-1.1.1.tgz
NetBSD 9.0sparc64ruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0sparc64ruby26-native-package-installer-1.0.9.tgz
NetBSD 9.0sparc64ruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0sparc64ruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0sparc64ruby26-native-package-installer-1.0.9.tgz
NetBSD 9.0sparc64ruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0sparc64ruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0sparc64ruby26-native-package-installer-1.0.9.tgz
NetBSD 9.0sparc64ruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0sparcruby25-native-package-installer-1.1.1.tgz
NetBSD 9.0sparcruby27-native-package-installer-1.1.1.tgz
NetBSD 9.0sparcruby30-native-package-installer-1.1.1.tgz
NetBSD 9.0sparcruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0sparcruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0sparcruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0sparcruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0vaxruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0vaxruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0x86_64ruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0x86_64ruby26-native-package-installer-1.0.9.tgz
NetBSD 9.0x86_64ruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0x86_64ruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0x86_64ruby26-native-package-installer-1.0.9.tgz
NetBSD 9.0x86_64ruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0x86_64ruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0x86_64ruby26-native-package-installer-1.0.9.tgz
NetBSD 9.0x86_64ruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0x86_64ruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0x86_64ruby26-native-package-installer-1.0.9.tgz
NetBSD 9.0x86_64ruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0x86_64ruby25-native-package-installer-1.0.9.tgz
NetBSD 9.0x86_64ruby26-native-package-installer-1.0.9.tgz
NetBSD 9.0x86_64ruby27-native-package-installer-1.0.9.tgz
NetBSD 9.0x86_64ruby25-native-package-installer-1.1.1.tgz
NetBSD 9.0x86_64ruby26-native-package-installer-1.1.1.tgz
NetBSD 9.0x86_64ruby27-native-package-installer-1.1.1.tgz
NetBSD 9.0x86_64ruby30-native-package-installer-1.1.1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.