devel/ruby-rugged - The NetBSD Packages Collection

Ruby bindings to libgit2

Rugged is a library for accessing libgit2 in Ruby. It gives you the speed
and portability of libgit2 with the beauty of the Ruby language.

Build dependencies

pkgtools/cwrappers devel/cmake devel/pkgconf

Runtime dependencies

devel/libgit2 lang/ruby26-base devel/libgit2

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfruby25-rugged-1.1.0.tgz
NetBSD 8.0earmv7hfruby26-rugged-1.1.0.tgz
NetBSD 8.0earmv7hfruby27-rugged-1.1.0.tgz
NetBSD 8.0earmv7hfruby25-rugged-1.0.1.tgz
NetBSD 8.0earmv7hfruby26-rugged-1.0.1.tgz
NetBSD 8.0earmv7hfruby27-rugged-1.0.1.tgz
NetBSD 8.0earmv7hfruby25-rugged-1.1.0.tgz
NetBSD 8.0earmv7hfruby26-rugged-1.1.0.tgz
NetBSD 8.0earmv7hfruby27-rugged-1.1.0.tgz
NetBSD 8.0i386ruby25-rugged-1.0.1.tgz
NetBSD 8.0i386ruby26-rugged-1.0.1.tgz
NetBSD 8.0i386ruby27-rugged-1.0.1.tgz
NetBSD 8.0i386ruby25-rugged-1.1.0.tgz
NetBSD 8.0i386ruby26-rugged-1.1.0.tgz
NetBSD 8.0i386ruby27-rugged-1.1.0.tgz
NetBSD 8.0i386ruby25-rugged-1.1.0.tgz
NetBSD 8.0i386ruby26-rugged-1.1.0.tgz
NetBSD 8.0i386ruby27-rugged-1.1.0.tgz
NetBSD 8.0powerpcruby25-rugged-1.0.1.tgz
NetBSD 8.0powerpcruby26-rugged-1.0.1.tgz
NetBSD 8.0powerpcruby27-rugged-1.0.1.tgz
NetBSD 8.0powerpcruby25-rugged-1.1.0.tgz
NetBSD 8.0powerpcruby26-rugged-1.1.0.tgz
NetBSD 8.0powerpcruby27-rugged-1.1.0.tgz
NetBSD 8.0powerpcruby25-rugged-1.1.0.tgz
NetBSD 8.0powerpcruby26-rugged-1.1.0.tgz
NetBSD 8.0powerpcruby27-rugged-1.1.0.tgz
NetBSD 8.0x86_64ruby25-rugged-1.0.1.tgz
NetBSD 8.0x86_64ruby26-rugged-1.0.1.tgz
NetBSD 8.0x86_64ruby27-rugged-1.0.1.tgz
NetBSD 8.0x86_64ruby25-rugged-1.1.0.tgz
NetBSD 8.0x86_64ruby26-rugged-1.1.0.tgz
NetBSD 8.0x86_64ruby27-rugged-1.1.0.tgz
NetBSD 9.0aarch64ruby25-rugged-1.1.0.tgz
NetBSD 9.0aarch64ruby26-rugged-1.1.0.tgz
NetBSD 9.0aarch64ruby27-rugged-1.1.0.tgz
NetBSD 9.0aarch64ruby30-rugged-1.1.0.tgz
NetBSD 9.0aarch64ruby25-rugged-1.0.1.tgz
NetBSD 9.0aarch64ruby26-rugged-1.0.1.tgz
NetBSD 9.0aarch64ruby27-rugged-1.0.1.tgz
NetBSD 9.0aarch64ruby25-rugged-1.1.0.tgz
NetBSD 9.0aarch64ruby26-rugged-1.1.0.tgz
NetBSD 9.0aarch64ruby27-rugged-1.1.0.tgz
NetBSD 9.0alpharuby25-rugged-1.1.0.tgz
NetBSD 9.0alpharuby26-rugged-1.1.0.tgz
NetBSD 9.0alpharuby27-rugged-1.1.0.tgz
NetBSD 9.0alpharuby25-rugged-1.0.1.tgz
NetBSD 9.0alpharuby26-rugged-1.0.1.tgz
NetBSD 9.0alpharuby27-rugged-1.0.1.tgz
NetBSD 9.0alpharuby25-rugged-1.1.0.tgz
NetBSD 9.0alpharuby26-rugged-1.1.0.tgz
NetBSD 9.0alpharuby27-rugged-1.1.0.tgz
NetBSD 9.0earmruby25-rugged-1.0.1.tgz
NetBSD 9.0earmruby26-rugged-1.0.1.tgz
NetBSD 9.0earmv6hfruby25-rugged-1.1.0.tgz
NetBSD 9.0earmv6hfruby26-rugged-1.1.0.tgz
NetBSD 9.0earmv6hfruby27-rugged-1.1.0.tgz
NetBSD 9.0earmv6hfruby30-rugged-1.1.0.tgz
NetBSD 9.0earmv6hfruby25-rugged-1.0.1.tgz
NetBSD 9.0earmv6hfruby26-rugged-1.0.1.tgz
NetBSD 9.0earmv6hfruby27-rugged-1.0.1.tgz
NetBSD 9.0earmv6hfruby25-rugged-1.1.0.tgz
NetBSD 9.0earmv6hfruby26-rugged-1.1.0.tgz
NetBSD 9.0earmv6hfruby27-rugged-1.1.0.tgz
NetBSD 9.0earmv6hfruby25-rugged-1.1.0.tgz
NetBSD 9.0earmv6hfruby26-rugged-1.1.0.tgz
NetBSD 9.0earmv6hfruby27-rugged-1.1.0.tgz
NetBSD 9.0earmv7hfruby25-rugged-1.1.0.tgz
NetBSD 9.0earmv7hfruby26-rugged-1.1.0.tgz
NetBSD 9.0earmv7hfruby27-rugged-1.1.0.tgz
NetBSD 9.0earmv7hfruby30-rugged-1.1.0.tgz
NetBSD 9.0earmv7hfruby25-rugged-1.0.1.tgz
NetBSD 9.0earmv7hfruby26-rugged-1.0.1.tgz
NetBSD 9.0earmv7hfruby27-rugged-1.0.1.tgz
NetBSD 9.0earmv7hfruby25-rugged-1.1.0.tgz
NetBSD 9.0earmv7hfruby26-rugged-1.1.0.tgz
NetBSD 9.0earmv7hfruby27-rugged-1.1.0.tgz
NetBSD 9.0earmv7hfruby25-rugged-1.1.0.tgz
NetBSD 9.0earmv7hfruby26-rugged-1.1.0.tgz
NetBSD 9.0earmv7hfruby27-rugged-1.1.0.tgz
NetBSD 9.0i386ruby25-rugged-1.0.1.tgz
NetBSD 9.0i386ruby26-rugged-1.0.1.tgz
NetBSD 9.0i386ruby27-rugged-1.0.1.tgz
NetBSD 9.0i386ruby25-rugged-1.1.0.tgz
NetBSD 9.0i386ruby26-rugged-1.1.0.tgz
NetBSD 9.0i386ruby27-rugged-1.1.0.tgz
NetBSD 9.0mips64ebruby25-rugged-1.1.0.tgz
NetBSD 9.0mips64ebruby26-rugged-1.1.0.tgz
NetBSD 9.0mips64ebruby27-rugged-1.1.0.tgz
NetBSD 9.0mips64ebruby25-rugged-1.0.1.tgz
NetBSD 9.0mips64ebruby26-rugged-1.0.1.tgz
NetBSD 9.0mips64ebruby27-rugged-1.0.1.tgz
NetBSD 9.0mips64ebruby25-rugged-1.1.0.tgz
NetBSD 9.0mips64ebruby26-rugged-1.1.0.tgz
NetBSD 9.0mips64ebruby27-rugged-1.1.0.tgz
NetBSD 9.0powerpcruby25-rugged-1.1.0.tgz
NetBSD 9.0powerpcruby26-rugged-1.1.0.tgz
NetBSD 9.0powerpcruby27-rugged-1.1.0.tgz
NetBSD 9.0powerpcruby25-rugged-1.0.1.tgz
NetBSD 9.0powerpcruby26-rugged-1.0.1.tgz
NetBSD 9.0powerpcruby27-rugged-1.0.1.tgz
NetBSD 9.0sparc64ruby25-rugged-1.1.0.tgz
NetBSD 9.0sparc64ruby26-rugged-1.1.0.tgz
NetBSD 9.0sparc64ruby27-rugged-1.1.0.tgz
NetBSD 9.0sparc64ruby25-rugged-1.0.1.tgz
NetBSD 9.0sparc64ruby26-rugged-1.0.1.tgz
NetBSD 9.0sparc64ruby27-rugged-1.0.1.tgz
NetBSD 9.0sparc64ruby25-rugged-1.1.0.tgz
NetBSD 9.0sparc64ruby26-rugged-1.1.0.tgz
NetBSD 9.0sparc64ruby27-rugged-1.1.0.tgz
NetBSD 9.0sparcruby25-rugged-1.1.0.tgz
NetBSD 9.0sparcruby25-rugged-1.1.0.tgz
NetBSD 9.0x86_64ruby25-rugged-1.1.0.tgz
NetBSD 9.0x86_64ruby26-rugged-1.1.0.tgz
NetBSD 9.0x86_64ruby27-rugged-1.1.0.tgz
NetBSD 9.0x86_64ruby25-rugged-1.1.0.tgz
NetBSD 9.0x86_64ruby26-rugged-1.1.0.tgz
NetBSD 9.0x86_64ruby27-rugged-1.1.0.tgz
NetBSD 9.0x86_64ruby25-rugged-1.1.0.tgz
NetBSD 9.0x86_64ruby26-rugged-1.1.0.tgz
NetBSD 9.0x86_64ruby27-rugged-1.1.0.tgz
NetBSD 9.0x86_64ruby25-rugged-1.0.1.tgz
NetBSD 9.0x86_64ruby26-rugged-1.0.1.tgz
NetBSD 9.0x86_64ruby27-rugged-1.0.1.tgz
NetBSD 9.0x86_64ruby25-rugged-1.1.0.tgz
NetBSD 9.0x86_64ruby26-rugged-1.1.0.tgz
NetBSD 9.0x86_64ruby27-rugged-1.1.0.tgz
NetBSD 9.0x86_64ruby25-rugged-1.1.0.tgz
NetBSD 9.0x86_64ruby26-rugged-1.1.0.tgz
NetBSD 9.0x86_64ruby27-rugged-1.1.0.tgz
NetBSD 9.0x86_64ruby30-rugged-1.1.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.