devel/stfl - The NetBSD Packages Collection

Library which implements a curses-based widget set for text terminals

The STFL API can be used from C, SPL, Python, Perl and Ruby.
Since the API is only 14 simple function calls big and there
are already generic SWIG bindings it is very easy to port STFL
to additional scripting languages.

A special language (the Structured Terminal Forms Language) is
used to describe STFL GUIs. The language is designed to be easy
and fast to write so an application programmer does not need to
spend ages fiddling around with the GUI and can concentrate on
the more interesting programming tasks.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/gmake lang/perl5

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfstfl-0.24nb5.tgz
NetBSD 8.0earmv7hfstfl-0.24nb5.tgz
NetBSD 8.0earmv7hfstfl-0.24nb5.tgz
NetBSD 8.0i386stfl-0.24nb5.tgz
NetBSD 8.0i386stfl-0.24nb5.tgz
NetBSD 8.0i386stfl-0.24nb5.tgz
NetBSD 8.0powerpcstfl-0.24nb5.tgz
NetBSD 8.0powerpcstfl-0.24nb5.tgz
NetBSD 8.0powerpcstfl-0.24nb5.tgz
NetBSD 8.0x86_64stfl-0.24nb5.tgz
NetBSD 8.0x86_64stfl-0.24nb5.tgz
NetBSD 9.0aarch64stfl-0.24nb5.tgz
NetBSD 9.0aarch64stfl-0.24nb5.tgz
NetBSD 9.0aarch64stfl-0.24nb5.tgz
NetBSD 9.0alphastfl-0.24nb5.tgz
NetBSD 9.0alphastfl-0.24nb5.tgz
NetBSD 9.0alphastfl-0.24nb5.tgz
NetBSD 9.0earmstfl-0.24nb5.tgz
NetBSD 9.0earmstfl-0.24nb5.tgz
NetBSD 9.0earmstfl-0.24nb5.tgz
NetBSD 9.0earmv6hfstfl-0.24nb5.tgz
NetBSD 9.0earmv6hfstfl-0.24nb5.tgz
NetBSD 9.0earmv6hfstfl-0.24nb5.tgz
NetBSD 9.0earmv6hfstfl-0.24nb5.tgz
NetBSD 9.0earmv7hfstfl-0.24nb5.tgz
NetBSD 9.0earmv7hfstfl-0.24nb5.tgz
NetBSD 9.0earmv7hfstfl-0.24nb5.tgz
NetBSD 9.0earmv7hfstfl-0.24nb5.tgz
NetBSD 9.0i386stfl-0.24nb5.tgz
NetBSD 9.0i386stfl-0.24nb5.tgz
NetBSD 9.0mips64ebstfl-0.24nb5.tgz
NetBSD 9.0mips64ebstfl-0.24nb5.tgz
NetBSD 9.0mips64ebstfl-0.24nb5.tgz
NetBSD 9.0powerpcstfl-0.24nb5.tgz
NetBSD 9.0powerpcstfl-0.24nb5.tgz
NetBSD 9.0sparc64stfl-0.24nb5.tgz
NetBSD 9.0sparc64stfl-0.24nb4.tgz
NetBSD 9.0sparc64stfl-0.24nb5.tgz
NetBSD 9.0sparc64stfl-0.24nb5.tgz
NetBSD 9.0sparcstfl-0.24nb5.tgz
NetBSD 9.0sparcstfl-0.24nb5.tgz
NetBSD 9.0sparcstfl-0.24nb5.tgz
NetBSD 9.0x86_64stfl-0.24nb5.tgz
NetBSD 9.0x86_64stfl-0.24nb5.tgz
NetBSD 9.0x86_64stfl-0.24nb5.tgz
NetBSD 9.0x86_64stfl-0.24nb5.tgz
NetBSD 9.0x86_64stfl-0.24nb5.tgz
NetBSD 9.0x86_64stfl-0.24nb5.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.