devel/tclreadline - The NetBSD Packages Collection

GNU Readline library for interactive tcl shells

The tclreadline package makes the GNU Readline library available for
interactive tcl shells. This includes history expansion and file/command
completion. Command completion for all tcl/tk commands is provided and
commmand completers for user defined commands can be easily added.
tclreadline can also be used for tcl scripts which want to use a shell
like input interface. In this case the ::tclreadline::readline
read command has to be called explicitly.

Build dependencies

pkgtools/cwrappers devel/libtool-base

Runtime dependencies

lang/tcl devel/readline lang/tcl devel/readline

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hftclreadline-2.1.0nb4.tgz
NetBSD 8.0earmv7hftclreadline-2.1.0nb4.tgz
NetBSD 8.0earmv7hftclreadline-2.1.0nb4.tgz
NetBSD 8.0earmv7hftclreadline-2.1.0nb4.tgz
NetBSD 8.0i386tclreadline-2.1.0nb4.tgz
NetBSD 8.0i386tclreadline-2.1.0nb4.tgz
NetBSD 8.0i386tclreadline-2.1.0nb4.tgz
NetBSD 8.0powerpctclreadline-2.1.0nb4.tgz
NetBSD 8.0powerpctclreadline-2.1.0nb4.tgz
NetBSD 8.0powerpctclreadline-2.1.0nb4.tgz
NetBSD 8.0x86_64tclreadline-2.1.0nb4.tgz
NetBSD 8.0x86_64tclreadline-2.1.0nb4.tgz
NetBSD 8.0x86_64tclreadline-2.1.0nb4.tgz
NetBSD 9.0aarch64tclreadline-2.1.0nb4.tgz
NetBSD 9.0aarch64tclreadline-2.1.0nb4.tgz
NetBSD 9.0aarch64tclreadline-2.1.0nb4.tgz
NetBSD 9.0aarch64tclreadline-2.1.0nb4.tgz
NetBSD 9.0alphatclreadline-2.1.0nb4.tgz
NetBSD 9.0alphatclreadline-2.1.0nb4.tgz
NetBSD 9.0alphatclreadline-2.1.0nb4.tgz
NetBSD 9.0earmtclreadline-2.1.0nb4.tgz
NetBSD 9.0earmv6hftclreadline-2.1.0nb4.tgz
NetBSD 9.0earmv6hftclreadline-2.1.0nb4.tgz
NetBSD 9.0earmv6hftclreadline-2.1.0nb4.tgz
NetBSD 9.0earmv6hftclreadline-2.1.0nb4.tgz
NetBSD 9.0earmv6hftclreadline-2.1.0nb4.tgz
NetBSD 9.0earmv7hftclreadline-2.1.0nb4.tgz
NetBSD 9.0earmv7hftclreadline-2.1.0nb4.tgz
NetBSD 9.0earmv7hftclreadline-2.1.0nb4.tgz
NetBSD 9.0earmv7hftclreadline-2.1.0nb4.tgz
NetBSD 9.0earmv7hftclreadline-2.1.0nb4.tgz
NetBSD 9.0earmv7hftclreadline-2.1.0nb4.tgz
NetBSD 9.0i386tclreadline-2.1.0nb4.tgz
NetBSD 9.0i386tclreadline-2.1.0nb4.tgz
NetBSD 9.0i386tclreadline-2.1.0nb4.tgz
NetBSD 9.0mips64ebtclreadline-2.1.0nb4.tgz
NetBSD 9.0mips64ebtclreadline-2.1.0nb4.tgz
NetBSD 9.0mips64ebtclreadline-2.1.0nb4.tgz
NetBSD 9.0powerpctclreadline-2.1.0nb4.tgz
NetBSD 9.0powerpctclreadline-2.1.0nb4.tgz
NetBSD 9.0powerpctclreadline-2.1.0nb4.tgz
NetBSD 9.0sparc64tclreadline-2.1.0nb4.tgz
NetBSD 9.0sparc64tclreadline-2.1.0nb4.tgz
NetBSD 9.0sparc64tclreadline-2.1.0nb4.tgz
NetBSD 9.0sparc64tclreadline-2.1.0nb4.tgz
NetBSD 9.0sparctclreadline-2.1.0nb4.tgz
NetBSD 9.0sparctclreadline-2.1.0nb4.tgz
NetBSD 9.0sparctclreadline-2.1.0nb4.tgz
NetBSD 9.0x86_64tclreadline-2.1.0nb4.tgz
NetBSD 9.0x86_64tclreadline-2.1.0nb4.tgz
NetBSD 9.0x86_64tclreadline-2.1.0nb4.tgz
NetBSD 9.0x86_64tclreadline-2.1.0nb4.tgz
NetBSD 9.0x86_64tclreadline-2.1.0nb4.tgz
NetBSD 9.0x86_64tclreadline-2.1.0nb4.tgz
NetBSD 9.0x86_64tclreadline-2.1.0nb4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.