devel/threadweaver - The NetBSD Packages Collection

High-level multithreading framework

ThreadWeaver is a helper for multithreaded programming.  It uses a job-based
interface to queue tasks and execute them in an efficient way.

You simply divide the workload into jobs, state the dependencies between the
jobs and ThreadWeaver will work out the most efficient way of dividing the
work between threads within a set of resource limits.

Build dependencies

devel/extra-cmake-modules devel/extra-cmake-modules pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/cmake devel/cmake

Runtime dependencies

x11/qt5-qtbase x11/qt5-qtbase

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfthreadweaver-5.70.0nb2.tgz
NetBSD 8.0earmv7hfthreadweaver-5.70.0nb2.tgz
NetBSD 8.0i386threadweaver-5.70.0nb1.tgz
NetBSD 8.0i386threadweaver-5.70.0nb2.tgz
NetBSD 8.0i386threadweaver-5.70.0nb2.tgz
NetBSD 8.0powerpcthreadweaver-5.70.0nb1.tgz
NetBSD 8.0powerpcthreadweaver-5.70.0nb2.tgz
NetBSD 8.0powerpcthreadweaver-5.70.0nb2.tgz
NetBSD 8.0x86_64threadweaver-5.70.0nb1.tgz
NetBSD 8.0x86_64threadweaver-5.70.0nb2.tgz
NetBSD 9.0aarch64threadweaver-5.70.0nb2.tgz
NetBSD 9.0aarch64threadweaver-5.70.0nb1.tgz
NetBSD 9.0aarch64threadweaver-5.70.0nb2.tgz
NetBSD 9.0alphathreadweaver-5.70.0nb2.tgz
NetBSD 9.0alphathreadweaver-5.70.0nb1.tgz
NetBSD 9.0alphathreadweaver-5.70.0nb2.tgz
NetBSD 9.0earmv6hfthreadweaver-5.70.0nb2.tgz
NetBSD 9.0earmv6hfthreadweaver-5.70.0nb1.tgz
NetBSD 9.0earmv6hfthreadweaver-5.70.0nb2.tgz
NetBSD 9.0earmv6hfthreadweaver-5.70.0nb2.tgz
NetBSD 9.0earmv7hfthreadweaver-5.70.0nb2.tgz
NetBSD 9.0earmv7hfthreadweaver-5.70.0nb1.tgz
NetBSD 9.0earmv7hfthreadweaver-5.70.0nb2.tgz
NetBSD 9.0earmv7hfthreadweaver-5.70.0nb2.tgz
NetBSD 9.0i386threadweaver-5.70.0nb1.tgz
NetBSD 9.0i386threadweaver-5.70.0nb2.tgz
NetBSD 9.0i386threadweaver-5.70.0nb2.tgz
NetBSD 9.0mips64ebthreadweaver-5.70.0nb2.tgz
NetBSD 9.0mips64ebthreadweaver-5.70.0nb1.tgz
NetBSD 9.0mips64ebthreadweaver-5.70.0nb2.tgz
NetBSD 9.0powerpcthreadweaver-5.70.0nb2.tgz
NetBSD 9.0powerpcthreadweaver-5.70.0nb1.tgz
NetBSD 9.0sparc64threadweaver-5.70.0nb2.tgz
NetBSD 9.0sparc64threadweaver-5.70.0.tgz
NetBSD 9.0sparc64threadweaver-5.70.0nb1.tgz
NetBSD 9.0sparc64threadweaver-5.70.0nb2.tgz
NetBSD 9.0x86_64threadweaver-5.70.0nb2.tgz
NetBSD 9.0x86_64threadweaver-5.70.0nb2.tgz
NetBSD 9.0x86_64threadweaver-5.70.0nb2.tgz
NetBSD 9.0x86_64threadweaver-5.70.0nb1.tgz
NetBSD 9.0x86_64threadweaver-5.70.0nb2.tgz
NetBSD 9.0x86_64threadweaver-5.70.0nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.