editors/jove - The NetBSD Packages Collection

Small emacs-style editor, but lacks the LISP engine

JOVE ("Jonathan's Own Version of Emacs") is an emacs-like editor less all
the overhead of the LISP engine.  But for projects that don't require all
the chrome of EMACS, JOVE will get the job done.  It supports split
screens, shell windows, process control, customizable comment formatting
and other features.  No syntax highlighting, colorisation or any of the
other chrome.

There is an 'X' version of jove included but it only works with SunTools
or OpenWindows.  Hopefully this will be expanded.  It is not compiled in
by default.

If you want something more like EMACS, use EMACS.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfjove-4.16.0.74.tgz
NetBSD 8.0earmv7hfjove-4.16.0.74.tgz
NetBSD 8.0earmv7hfjove-4.16.0.74.tgz
NetBSD 8.0i386jove-4.16.0.74.tgz
NetBSD 8.0i386jove-4.16.0.74.tgz
NetBSD 8.0i386jove-4.16.0.74.tgz
NetBSD 8.0powerpcjove-4.16.0.74.tgz
NetBSD 8.0powerpcjove-4.16.0.74.tgz
NetBSD 8.0powerpcjove-4.16.0.74.tgz
NetBSD 8.0x86_64jove-4.16.0.74.tgz
NetBSD 8.0x86_64jove-4.16.0.74.tgz
NetBSD 8.0x86_64jove-4.16.0.74.tgz
NetBSD 9.0aarch64jove-4.16.0.74.tgz
NetBSD 9.0aarch64jove-4.16.0.74.tgz
NetBSD 9.0aarch64jove-4.16.0.74.tgz
NetBSD 9.0alphajove-4.16.0.74.tgz
NetBSD 9.0alphajove-4.16.0.74.tgz
NetBSD 9.0alphajove-4.16.0.74.tgz
NetBSD 9.0earmjove-4.16.0.74.tgz
NetBSD 9.0earmv6hfjove-4.16.0.74.tgz
NetBSD 9.0earmv6hfjove-4.16.0.74.tgz
NetBSD 9.0earmv6hfjove-4.16.0.74.tgz
NetBSD 9.0earmv6hfjove-4.16.0.74.tgz
NetBSD 9.0earmv7hfjove-4.16.0.74.tgz
NetBSD 9.0earmv7hfjove-4.16.0.74.tgz
NetBSD 9.0earmv7hfjove-4.16.0.74.tgz
NetBSD 9.0earmv7hfjove-4.16.0.74.tgz
NetBSD 9.0i386jove-4.16.0.74.tgz
NetBSD 9.0i386jove-4.16.0.74.tgz
NetBSD 9.0i386jove-4.16.0.74.tgz
NetBSD 9.0mips64ebjove-4.16.0.74.tgz
NetBSD 9.0mips64ebjove-4.16.0.74.tgz
NetBSD 9.0mips64ebjove-4.16.0.74.tgz
NetBSD 9.0powerpcjove-4.16.0.74.tgz
NetBSD 9.0powerpcjove-4.16.0.74.tgz
NetBSD 9.0sparc64jove-4.16.0.74.tgz
NetBSD 9.0sparc64jove-4.16.0.74.tgz
NetBSD 9.0sparc64jove-4.16.0.74.tgz
NetBSD 9.0sparc64jove-4.16.0.74.tgz
NetBSD 9.0sparcjove-4.16.0.74.tgz
NetBSD 9.0sparcjove-4.16.0.74.tgz
NetBSD 9.0sparcjove-4.16.0.74.tgz
NetBSD 9.0x86_64jove-4.16.0.74.tgz
NetBSD 9.0x86_64jove-4.16.0.74.tgz
NetBSD 9.0x86_64jove-4.16.0.74.tgz
NetBSD 9.0x86_64jove-4.16.0.74.tgz
NetBSD 9.0x86_64jove-4.16.0.74.tgz
NetBSD 9.0x86_64jove-4.16.0.74.tgz
NetBSD 9.0x86_64jove-4.16.0.74.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.