fonts/gbdfed - The NetBSD Packages Collection

GTK-based BDF font editor

gbdfed is a GTK-based BDF font editor with the following features:

  o  Multiple fonts can be loaded from the command line.
  o  Multiple fonts can be open at the same time.
  o  Cutting and pasting glyphs between fonts.
  o  Multiple glyph bitmap editors can be open at the same time.
  o  Cutting and pasting between glyph bitmap editors.
  o  Export of XBM files from glyph bitmap editors.
  o  Automatic correction of certain metrics when a font is loaded.
  o  Generation of XLFD font names for fonts without XLFD names.
  o  Update an XLFD font name from the font properties and vice-versa.
  o  Font property & comment editor.
  o  Supports unencoded glyphs (ENCODING of -1).
  o  Display of glyph encodings in octal, decimal, or hex.
  o  Builtin on-line help.

gbdfed imports and/or exports the following formats:

  o PK/GF, HBF (Han Bitmap Font)
  o PSF, CP, FNT (linux) and vfont (Sun) console fonts
  o X server built-in fonts
  o Windows FON/FNT
  o OpenType/TrueType fonts and collections
  o PSF/HEX fonts

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/libtool-base devel/pkgconf

Runtime dependencies

graphics/freetype2 graphics/freetype2 x11/gtk2 x11/gtk2

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgbdfed-1.6nb19.tgz
NetBSD 8.0earmv7hfgbdfed-1.6nb19.tgz
NetBSD 8.0i386gbdfed-1.6nb19.tgz
NetBSD 8.0i386gbdfed-1.6nb19.tgz
NetBSD 8.0i386gbdfed-1.6nb19.tgz
NetBSD 8.0powerpcgbdfed-1.6nb19.tgz
NetBSD 8.0powerpcgbdfed-1.6nb19.tgz
NetBSD 8.0powerpcgbdfed-1.6nb19.tgz
NetBSD 8.0x86_64gbdfed-1.6nb19.tgz
NetBSD 8.0x86_64gbdfed-1.6nb19.tgz
NetBSD 9.0aarch64gbdfed-1.6nb19.tgz
NetBSD 9.0aarch64gbdfed-1.6nb19.tgz
NetBSD 9.0aarch64gbdfed-1.6nb19.tgz
NetBSD 9.0alphagbdfed-1.6nb19.tgz
NetBSD 9.0alphagbdfed-1.6nb19.tgz
NetBSD 9.0alphagbdfed-1.6nb19.tgz
NetBSD 9.0earmv6hfgbdfed-1.6nb19.tgz
NetBSD 9.0earmv6hfgbdfed-1.6nb19.tgz
NetBSD 9.0earmv6hfgbdfed-1.6nb19.tgz
NetBSD 9.0earmv6hfgbdfed-1.6nb19.tgz
NetBSD 9.0earmv7hfgbdfed-1.6nb19.tgz
NetBSD 9.0earmv7hfgbdfed-1.6nb19.tgz
NetBSD 9.0earmv7hfgbdfed-1.6nb19.tgz
NetBSD 9.0earmv7hfgbdfed-1.6nb19.tgz
NetBSD 9.0i386gbdfed-1.6nb19.tgz
NetBSD 9.0i386gbdfed-1.6nb19.tgz
NetBSD 9.0i386gbdfed-1.6nb19.tgz
NetBSD 9.0mips64ebgbdfed-1.6nb19.tgz
NetBSD 9.0mips64ebgbdfed-1.6nb19.tgz
NetBSD 9.0mips64ebgbdfed-1.6nb19.tgz
NetBSD 9.0powerpcgbdfed-1.6nb19.tgz
NetBSD 9.0powerpcgbdfed-1.6nb19.tgz
NetBSD 9.0sparc64gbdfed-1.6nb19.tgz
NetBSD 9.0sparc64gbdfed-1.6nb18.tgz
NetBSD 9.0sparc64gbdfed-1.6nb19.tgz
NetBSD 9.0sparc64gbdfed-1.6nb19.tgz
NetBSD 9.0sparcgbdfed-1.6nb19.tgz
NetBSD 9.0x86_64gbdfed-1.6nb19.tgz
NetBSD 9.0x86_64gbdfed-1.6nb19.tgz
NetBSD 9.0x86_64gbdfed-1.6nb19.tgz
NetBSD 9.0x86_64gbdfed-1.6nb19.tgz
NetBSD 9.0x86_64gbdfed-1.6nb19.tgz
NetBSD 9.0x86_64gbdfed-1.6nb19.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.