fonts/py-fonttools - The NetBSD Packages Collection

Library for manipulating fonts

FontTools is a library for manipulating fonts, written in Python.  It
supports TrueType, OpenType, AFM and to an extent Type 1 and some
Mac-specific formats.

This package also includes TTX: a tool to convert OpenType and TrueType
fonts to and from XML.

Build dependencies

devel/py-cython pkgtools/cwrappers

Runtime dependencies

textproc/py-expat devel/py-setuptools lang/python38 lang/python38

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfpy36-fonttools-4.17.1.tgz
NetBSD 8.0earmv7hfpy37-fonttools-4.17.1.tgz
NetBSD 8.0earmv7hfpy38-fonttools-4.17.1.tgz
NetBSD 8.0earmv7hfpy39-fonttools-4.17.1.tgz
NetBSD 8.0earmv7hfpy36-fonttools-4.2.4.tgz
NetBSD 8.0earmv7hfpy37-fonttools-4.2.4.tgz
NetBSD 8.0earmv7hfpy38-fonttools-4.2.4.tgz
NetBSD 8.0earmv7hfpy36-fonttools-4.12.1.tgz
NetBSD 8.0earmv7hfpy37-fonttools-4.12.1.tgz
NetBSD 8.0earmv7hfpy38-fonttools-4.12.1.tgz
NetBSD 8.0earmv7hfpy37-fonttools-4.14.0.tgz
NetBSD 8.0i386py36-fonttools-4.12.1.tgz
NetBSD 8.0i386py37-fonttools-4.12.1.tgz
NetBSD 8.0i386py38-fonttools-4.12.1.tgz
NetBSD 8.0i386py36-fonttools-4.14.0.tgz
NetBSD 8.0i386py37-fonttools-4.14.0.tgz
NetBSD 8.0i386py38-fonttools-4.14.0.tgz
NetBSD 8.0i386py36-fonttools-4.17.1.tgz
NetBSD 8.0i386py37-fonttools-4.17.1.tgz
NetBSD 8.0i386py38-fonttools-4.17.1.tgz
NetBSD 8.0i386py39-fonttools-4.17.1.tgz
NetBSD 8.0powerpcpy36-fonttools-4.14.0.tgz
NetBSD 8.0powerpcpy37-fonttools-4.14.0.tgz
NetBSD 8.0powerpcpy38-fonttools-4.14.0.tgz
NetBSD 8.0powerpcpy36-fonttools-4.17.1.tgz
NetBSD 8.0powerpcpy37-fonttools-4.17.1.tgz
NetBSD 8.0powerpcpy38-fonttools-4.17.1.tgz
NetBSD 8.0powerpcpy39-fonttools-4.17.1.tgz
NetBSD 8.0powerpcpy36-fonttools-4.17.1.tgz
NetBSD 8.0powerpcpy37-fonttools-4.17.1.tgz
NetBSD 8.0powerpcpy38-fonttools-4.17.1.tgz
NetBSD 8.0powerpcpy39-fonttools-4.17.1.tgz
NetBSD 8.0x86_64py36-fonttools-4.14.0.tgz
NetBSD 8.0x86_64py37-fonttools-4.14.0.tgz
NetBSD 8.0x86_64py38-fonttools-4.14.0.tgz
NetBSD 8.0x86_64py36-fonttools-4.12.1.tgz
NetBSD 8.0x86_64py37-fonttools-4.12.1.tgz
NetBSD 8.0x86_64py38-fonttools-4.12.1.tgz
NetBSD 8.0x86_64py36-fonttools-4.17.1.tgz
NetBSD 8.0x86_64py37-fonttools-4.17.1.tgz
NetBSD 8.0x86_64py38-fonttools-4.17.1.tgz
NetBSD 8.0x86_64py39-fonttools-4.17.1.tgz
NetBSD 9.0aarch64py36-fonttools-4.21.1.tgz
NetBSD 9.0aarch64py37-fonttools-4.21.1.tgz
NetBSD 9.0aarch64py38-fonttools-4.21.1.tgz
NetBSD 9.0aarch64py39-fonttools-4.21.1.tgz
NetBSD 9.0aarch64py36-fonttools-4.12.1.tgz
NetBSD 9.0aarch64py37-fonttools-4.12.1.tgz
NetBSD 9.0aarch64py38-fonttools-4.12.1.tgz
NetBSD 9.0aarch64py36-fonttools-4.14.0.tgz
NetBSD 9.0aarch64py37-fonttools-4.14.0.tgz
NetBSD 9.0aarch64py38-fonttools-4.14.0.tgz
NetBSD 9.0aarch64py36-fonttools-4.17.1.tgz
NetBSD 9.0aarch64py37-fonttools-4.17.1.tgz
NetBSD 9.0aarch64py38-fonttools-4.17.1.tgz
NetBSD 9.0aarch64py39-fonttools-4.17.1.tgz
NetBSD 9.0alphapy38-fonttools-4.21.1.tgz
NetBSD 9.0alphapy36-fonttools-4.14.0.tgz
NetBSD 9.0alphapy37-fonttools-4.14.0.tgz
NetBSD 9.0alphapy38-fonttools-4.14.0.tgz
NetBSD 9.0alphapy36-fonttools-4.17.1.tgz
NetBSD 9.0alphapy37-fonttools-4.17.1.tgz
NetBSD 9.0alphapy38-fonttools-4.17.1.tgz
NetBSD 9.0alphapy39-fonttools-4.17.1.tgz
NetBSD 9.0earmpy36-fonttools-4.14.0.tgz
NetBSD 9.0earmpy37-fonttools-4.14.0.tgz
NetBSD 9.0earmpy38-fonttools-4.14.0.tgz
NetBSD 9.0earmpy38-fonttools-4.17.1.tgz
NetBSD 9.0earmv6hfpy36-fonttools-4.21.1.tgz
NetBSD 9.0earmv6hfpy37-fonttools-4.21.1.tgz
NetBSD 9.0earmv6hfpy38-fonttools-4.21.1.tgz
NetBSD 9.0earmv6hfpy39-fonttools-4.21.1.tgz
NetBSD 9.0earmv6hfpy36-fonttools-4.12.1.tgz
NetBSD 9.0earmv6hfpy37-fonttools-4.12.1.tgz
NetBSD 9.0earmv6hfpy38-fonttools-4.12.1.tgz
NetBSD 9.0earmv6hfpy36-fonttools-4.14.0.tgz
NetBSD 9.0earmv6hfpy37-fonttools-4.14.0.tgz
NetBSD 9.0earmv6hfpy38-fonttools-4.14.0.tgz
NetBSD 9.0earmv6hfpy36-fonttools-4.17.1.tgz
NetBSD 9.0earmv6hfpy37-fonttools-4.17.1.tgz
NetBSD 9.0earmv6hfpy38-fonttools-4.17.1.tgz
NetBSD 9.0earmv6hfpy39-fonttools-4.17.1.tgz
NetBSD 9.0earmv6hfpy36-fonttools-4.17.1.tgz
NetBSD 9.0earmv6hfpy37-fonttools-4.17.1.tgz
NetBSD 9.0earmv6hfpy38-fonttools-4.17.1.tgz
NetBSD 9.0earmv6hfpy39-fonttools-4.17.1.tgz
NetBSD 9.0earmv7hfpy36-fonttools-4.21.1.tgz
NetBSD 9.0earmv7hfpy37-fonttools-4.21.1.tgz
NetBSD 9.0earmv7hfpy38-fonttools-4.21.1.tgz
NetBSD 9.0earmv7hfpy39-fonttools-4.21.1.tgz
NetBSD 9.0earmv7hfpy36-fonttools-4.2.4.tgz
NetBSD 9.0earmv7hfpy37-fonttools-4.2.4.tgz
NetBSD 9.0earmv7hfpy38-fonttools-4.2.4.tgz
NetBSD 9.0earmv7hfpy36-fonttools-4.12.1.tgz
NetBSD 9.0earmv7hfpy37-fonttools-4.12.1.tgz
NetBSD 9.0earmv7hfpy38-fonttools-4.12.1.tgz
NetBSD 9.0earmv7hfpy36-fonttools-4.14.0.tgz
NetBSD 9.0earmv7hfpy37-fonttools-4.14.0.tgz
NetBSD 9.0earmv7hfpy38-fonttools-4.14.0.tgz
NetBSD 9.0earmv7hfpy36-fonttools-4.17.1.tgz
NetBSD 9.0earmv7hfpy37-fonttools-4.17.1.tgz
NetBSD 9.0earmv7hfpy38-fonttools-4.17.1.tgz
NetBSD 9.0earmv7hfpy39-fonttools-4.17.1.tgz
NetBSD 9.0earmv7hfpy36-fonttools-4.17.1.tgz
NetBSD 9.0earmv7hfpy37-fonttools-4.17.1.tgz
NetBSD 9.0earmv7hfpy38-fonttools-4.17.1.tgz
NetBSD 9.0earmv7hfpy39-fonttools-4.17.1.tgz
NetBSD 9.0i386py36-fonttools-4.12.1.tgz
NetBSD 9.0i386py37-fonttools-4.12.1.tgz
NetBSD 9.0i386py38-fonttools-4.12.1.tgz
NetBSD 9.0i386py36-fonttools-4.14.0.tgz
NetBSD 9.0i386py37-fonttools-4.14.0.tgz
NetBSD 9.0i386py38-fonttools-4.14.0.tgz
NetBSD 9.0i386py36-fonttools-4.17.1.tgz
NetBSD 9.0i386py37-fonttools-4.17.1.tgz
NetBSD 9.0i386py38-fonttools-4.17.1.tgz
NetBSD 9.0i386py39-fonttools-4.17.1.tgz
NetBSD 9.0mips64ebpy36-fonttools-4.14.0.tgz
NetBSD 9.0mips64ebpy37-fonttools-4.14.0.tgz
NetBSD 9.0mips64ebpy38-fonttools-4.14.0.tgz
NetBSD 9.0mips64ebpy36-fonttools-4.17.1.tgz
NetBSD 9.0mips64ebpy37-fonttools-4.17.1.tgz
NetBSD 9.0mips64ebpy38-fonttools-4.17.1.tgz
NetBSD 9.0mips64ebpy39-fonttools-4.17.1.tgz
NetBSD 9.0mipselpy38-fonttools-4.17.1.tgz
NetBSD 9.0powerpcpy36-fonttools-4.17.1.tgz
NetBSD 9.0powerpcpy37-fonttools-4.17.1.tgz
NetBSD 9.0powerpcpy38-fonttools-4.17.1.tgz
NetBSD 9.0powerpcpy39-fonttools-4.17.1.tgz
NetBSD 9.0powerpcpy36-fonttools-4.12.1.tgz
NetBSD 9.0powerpcpy37-fonttools-4.12.1.tgz
NetBSD 9.0powerpcpy38-fonttools-4.12.1.tgz
NetBSD 9.0powerpcpy36-fonttools-4.14.0.tgz
NetBSD 9.0powerpcpy37-fonttools-4.14.0.tgz
NetBSD 9.0powerpcpy38-fonttools-4.14.0.tgz
NetBSD 9.0sh3elpy38-fonttools-4.17.1.tgz
NetBSD 9.0sparc64py36-fonttools-4.14.0.tgz
NetBSD 9.0sparc64py37-fonttools-4.14.0.tgz
NetBSD 9.0sparc64py38-fonttools-4.14.0.tgz
NetBSD 9.0sparc64py36-fonttools-4.17.1.tgz
NetBSD 9.0sparc64py37-fonttools-4.17.1.tgz
NetBSD 9.0sparc64py38-fonttools-4.17.1.tgz
NetBSD 9.0sparc64py39-fonttools-4.17.1.tgz
NetBSD 9.0sparcpy36-fonttools-4.14.0.tgz
NetBSD 9.0sparcpy37-fonttools-4.14.0.tgz
NetBSD 9.0sparcpy38-fonttools-4.14.0.tgz
NetBSD 9.0sparcpy38-fonttools-4.17.1.tgz
NetBSD 9.0x86_64py36-fonttools-4.14.0.tgz
NetBSD 9.0x86_64py37-fonttools-4.14.0.tgz
NetBSD 9.0x86_64py38-fonttools-4.14.0.tgz
NetBSD 9.0x86_64py39-fonttools-4.14.0.tgz
NetBSD 9.0x86_64py36-fonttools-4.17.1.tgz
NetBSD 9.0x86_64py37-fonttools-4.17.1.tgz
NetBSD 9.0x86_64py38-fonttools-4.17.1.tgz
NetBSD 9.0x86_64py39-fonttools-4.17.1.tgz
NetBSD 9.0x86_64py36-fonttools-4.18.2.tgz
NetBSD 9.0x86_64py37-fonttools-4.18.2.tgz
NetBSD 9.0x86_64py38-fonttools-4.18.2.tgz
NetBSD 9.0x86_64py39-fonttools-4.18.2.tgz
NetBSD 9.0x86_64py36-fonttools-4.12.1.tgz
NetBSD 9.0x86_64py37-fonttools-4.12.1.tgz
NetBSD 9.0x86_64py38-fonttools-4.12.1.tgz
NetBSD 9.0x86_64py36-fonttools-4.14.0.tgz
NetBSD 9.0x86_64py37-fonttools-4.14.0.tgz
NetBSD 9.0x86_64py38-fonttools-4.14.0.tgz
NetBSD 9.0x86_64py36-fonttools-4.17.1.tgz
NetBSD 9.0x86_64py37-fonttools-4.17.1.tgz
NetBSD 9.0x86_64py38-fonttools-4.17.1.tgz
NetBSD 9.0x86_64py39-fonttools-4.17.1.tgz
NetBSD 9.0x86_64py36-fonttools-4.21.1.tgz
NetBSD 9.0x86_64py37-fonttools-4.21.1.tgz
NetBSD 9.0x86_64py38-fonttools-4.21.1.tgz
NetBSD 9.0x86_64py39-fonttools-4.21.1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.