fonts/t1lib - The NetBSD Packages Collection

Library for generating bitmaps from Adobe Type 1 fonts

t1lib is a library written in C which implements functions for generating
bitmaps from Adobe Type 1 fonts. It uses most internal parts of the Type 1
rasterizer provided with X11R5 and newer but tries avoid the disadvantages
known from that rasterizer. Although most people would use the rasterizer
under X11, having X11 is not necessary at all.

The rasterizer is implemented as a shared or static library to be linked
to the programs that want to use Type 1 fonts. In addition to this library
there is a test-program called xglyph which, as the name indicates,
requires X11. It can be used to show most of the features of the library.
xglyph can be run out of the box without doing any X11 configuration like
setting resources.

Build dependencies

pkgtools/x11-links x11/xorgproto pkgtools/cwrappers devel/libtool-base devel/gmake

Runtime dependencies

x11/libXpm

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hft1lib-5.1.2nb6.tgz
NetBSD 8.0earmv7hft1lib-5.1.2nb6.tgz
NetBSD 8.0earmv7hft1lib-5.1.2nb6.tgz
NetBSD 8.0earmv7hft1lib-5.1.2nb6.tgz
NetBSD 8.0i386t1lib-5.1.2nb6.tgz
NetBSD 8.0i386t1lib-5.1.2nb6.tgz
NetBSD 8.0i386t1lib-5.1.2nb6.tgz
NetBSD 8.0powerpct1lib-5.1.2nb6.tgz
NetBSD 8.0powerpct1lib-5.1.2nb6.tgz
NetBSD 8.0powerpct1lib-5.1.2nb6.tgz
NetBSD 8.0x86_64t1lib-5.1.2nb6.tgz
NetBSD 8.0x86_64t1lib-5.1.2nb6.tgz
NetBSD 8.0x86_64t1lib-5.1.2nb6.tgz
NetBSD 9.0aarch64t1lib-5.1.2nb6.tgz
NetBSD 9.0aarch64t1lib-5.1.2nb6.tgz
NetBSD 9.0aarch64t1lib-5.1.2nb6.tgz
NetBSD 9.0aarch64t1lib-5.1.2nb6.tgz
NetBSD 9.0alphat1lib-5.1.2nb6.tgz
NetBSD 9.0alphat1lib-5.1.2nb6.tgz
NetBSD 9.0alphat1lib-5.1.2nb6.tgz
NetBSD 9.0alphat1lib-5.1.2nb6.tgz
NetBSD 9.0earmt1lib-5.1.2nb6.tgz
NetBSD 9.0earmt1lib-5.1.2nb6.tgz
NetBSD 9.0earmv6hft1lib-5.1.2nb6.tgz
NetBSD 9.0earmv6hft1lib-5.1.2nb6.tgz
NetBSD 9.0earmv6hft1lib-5.1.2nb6.tgz
NetBSD 9.0earmv6hft1lib-5.1.2nb6.tgz
NetBSD 9.0earmv6hft1lib-5.1.2nb6.tgz
NetBSD 9.0earmv7hft1lib-5.1.2nb6.tgz
NetBSD 9.0earmv7hft1lib-5.1.2nb6.tgz
NetBSD 9.0earmv7hft1lib-5.1.2nb6.tgz
NetBSD 9.0earmv7hft1lib-5.1.2nb6.tgz
NetBSD 9.0earmv7hft1lib-5.1.2nb6.tgz
NetBSD 9.0earmv7hft1lib-5.1.2nb6.tgz
NetBSD 9.0i386t1lib-5.1.2nb6.tgz
NetBSD 9.0i386t1lib-5.1.2nb6.tgz
NetBSD 9.0i386t1lib-5.1.2nb6.tgz
NetBSD 9.0m68kt1lib-5.1.2nb6.tgz
NetBSD 9.0mips64ebt1lib-5.1.2nb6.tgz
NetBSD 9.0mips64ebt1lib-5.1.2nb6.tgz
NetBSD 9.0mipselt1lib-5.1.2nb6.tgz
NetBSD 9.0powerpct1lib-5.1.2nb6.tgz
NetBSD 9.0powerpct1lib-5.1.2nb6.tgz
NetBSD 9.0powerpct1lib-5.1.2nb6.tgz
NetBSD 9.0sh3elt1lib-5.1.2nb6.tgz
NetBSD 9.0sparc64t1lib-5.1.2nb6.tgz
NetBSD 9.0sparc64t1lib-5.1.2nb6.tgz
NetBSD 9.0sparc64t1lib-5.1.2nb6.tgz
NetBSD 9.0sparct1lib-5.1.2nb6.tgz
NetBSD 9.0sparct1lib-5.1.2nb6.tgz
NetBSD 9.0sparct1lib-5.1.2nb6.tgz
NetBSD 9.0vaxt1lib-5.1.2nb6.tgz
NetBSD 9.0x86_64t1lib-5.1.2nb6.tgz
NetBSD 9.0x86_64t1lib-5.1.2nb6.tgz
NetBSD 9.0x86_64t1lib-5.1.2nb6.tgz
NetBSD 9.0x86_64t1lib-5.1.2nb6.tgz
NetBSD 9.0x86_64t1lib-5.1.2nb6.tgz
NetBSD 9.0x86_64t1lib-5.1.2nb6.tgz
NetBSD 9.0x86_64t1lib-5.1.2nb6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

x11
Enable X11 support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.