fonts/ttftot42 - The NetBSD Packages Collection

TrueType font to Type 42 converter

  TrueType fonts cannot be converted to Type 1 fonts without loss of
quality, since conversion introduces rounding errors and loses hinting
information.  Therefore, newer PostScript interpreters (Adobe
PostScript since version 2013, ghostscript since 5.03) include a
TrueType rasterizers.  To use a TrueType font with them, it has to be
embedded in a PostScript font dictionary; this format is called Type 42.

  This program generates such Type 42 fonts from TrueType fonts.  It
can also generate Adobe Font Metrics files (AFM files), including
kerning information.

  Not yet supported are TrueType Collections and the creation of CID
keyed fonts from large TrueType fonts (East Asian or Unicode fonts).

Build dependencies

pkgtools/cwrappers

Runtime dependencies

graphics/freetype-lib graphics/freetype-lib graphics/freetype-lib

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfttftot42-0.3.1nb3.tgz
NetBSD 8.0earmv7hfttftot42-0.3.1nb3.tgz
NetBSD 8.0earmv7hfttftot42-0.3.1nb3.tgz
NetBSD 8.0i386ttftot42-0.3.1nb3.tgz
NetBSD 8.0i386ttftot42-0.3.1nb3.tgz
NetBSD 8.0i386ttftot42-0.3.1nb3.tgz
NetBSD 8.0powerpcttftot42-0.3.1nb3.tgz
NetBSD 8.0powerpcttftot42-0.3.1nb3.tgz
NetBSD 8.0powerpcttftot42-0.3.1nb3.tgz
NetBSD 8.0x86_64ttftot42-0.3.1nb3.tgz
NetBSD 8.0x86_64ttftot42-0.3.1nb3.tgz
NetBSD 9.0aarch64ttftot42-0.3.1nb3.tgz
NetBSD 9.0aarch64ttftot42-0.3.1nb3.tgz
NetBSD 9.0aarch64ttftot42-0.3.1nb3.tgz
NetBSD 9.0alphattftot42-0.3.1nb3.tgz
NetBSD 9.0alphattftot42-0.3.1nb3.tgz
NetBSD 9.0alphattftot42-0.3.1nb3.tgz
NetBSD 9.0earmttftot42-0.3.1nb3.tgz
NetBSD 9.0earmv6hfttftot42-0.3.1nb3.tgz
NetBSD 9.0earmv6hfttftot42-0.3.1nb3.tgz
NetBSD 9.0earmv6hfttftot42-0.3.1nb3.tgz
NetBSD 9.0earmv6hfttftot42-0.3.1nb3.tgz
NetBSD 9.0earmv7hfttftot42-0.3.1nb3.tgz
NetBSD 9.0earmv7hfttftot42-0.3.1nb3.tgz
NetBSD 9.0earmv7hfttftot42-0.3.1nb3.tgz
NetBSD 9.0earmv7hfttftot42-0.3.1nb3.tgz
NetBSD 9.0i386ttftot42-0.3.1nb3.tgz
NetBSD 9.0i386ttftot42-0.3.1nb3.tgz
NetBSD 9.0i386ttftot42-0.3.1nb3.tgz
NetBSD 9.0mips64ebttftot42-0.3.1nb3.tgz
NetBSD 9.0mips64ebttftot42-0.3.1nb3.tgz
NetBSD 9.0mips64ebttftot42-0.3.1nb3.tgz
NetBSD 9.0powerpcttftot42-0.3.1nb3.tgz
NetBSD 9.0powerpcttftot42-0.3.1nb3.tgz
NetBSD 9.0sparc64ttftot42-0.3.1nb3.tgz
NetBSD 9.0sparc64ttftot42-0.3.1nb3.tgz
NetBSD 9.0sparc64ttftot42-0.3.1nb3.tgz
NetBSD 9.0x86_64ttftot42-0.3.1nb3.tgz
NetBSD 9.0x86_64ttftot42-0.3.1nb3.tgz
NetBSD 9.0x86_64ttftot42-0.3.1nb3.tgz
NetBSD 9.0x86_64ttftot42-0.3.1nb3.tgz
NetBSD 9.0x86_64ttftot42-0.3.1nb3.tgz
NetBSD 9.0x86_64ttftot42-0.3.1nb3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.