games/assaultcube - The NetBSD Packages Collection

Cube-based FPS with realistic environments

AssaultCube is a FREE, multiplayer, first-person shooter game,
based on the CUBE engine.

Taking place in realistic environments, with fast, arcade gameplay,
it's addictive and fun!

With efficient bandwidth usage, it's low-latency and can even run
over a 56 Kbps connection.  It's tiny too, weighing in at a
lightweight about 50 MB package available for Windows, Mac and
Linux.  On the correct settings, it can even run on old hardware
(Pentium III and above).

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/gmake devel/pkgconf

Runtime dependencies

audio/libvorbis audio/openal-soft devel/SDL graphics/MesaLib graphics/hicolor-icon-theme graphics/SDL_image net/enet www/curl graphics/jpeg audio/libvorbis devel/SDL graphics/MesaLib graphics/hicolor-icon-theme graphics/SDL_image www/curl graphics/jpeg

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfassaultcube-1.2.0.2nb9.tgz
NetBSD 8.0earmv7hfassaultcube-1.2.0.2nb9.tgz
NetBSD 8.0earmv7hfassaultcube-1.2.0.2nb10.tgz
NetBSD 8.0i386assaultcube-1.2.0.2nb9.tgz
NetBSD 8.0i386assaultcube-1.2.0.2nb9.tgz
NetBSD 8.0i386assaultcube-1.2.0.2nb9.tgz
NetBSD 8.0i386assaultcube-1.2.0.2nb10.tgz
NetBSD 8.0powerpcassaultcube-1.2.0.2nb9.tgz
NetBSD 8.0powerpcassaultcube-1.2.0.2nb9.tgz
NetBSD 8.0powerpcassaultcube-1.2.0.2nb9.tgz
NetBSD 8.0powerpcassaultcube-1.2.0.2nb9.tgz
NetBSD 8.0x86_64assaultcube-1.2.0.2nb9.tgz
NetBSD 8.0x86_64assaultcube-1.2.0.2nb9.tgz
NetBSD 8.0x86_64assaultcube-1.2.0.2nb9.tgz
NetBSD 8.0x86_64assaultcube-1.2.0.2nb10.tgz
NetBSD 9.0aarch64assaultcube-1.2.0.2nb10.tgz
NetBSD 9.0aarch64assaultcube-1.2.0.2nb9.tgz
NetBSD 9.0aarch64assaultcube-1.2.0.2nb9.tgz
NetBSD 9.0aarch64assaultcube-1.2.0.2nb9.tgz
NetBSD 9.0earmv6hfassaultcube-1.2.0.2nb9.tgz
NetBSD 9.0earmv6hfassaultcube-1.2.0.2nb9.tgz
NetBSD 9.0earmv6hfassaultcube-1.2.0.2nb9.tgz
NetBSD 9.0earmv6hfassaultcube-1.2.0.2nb9.tgz
NetBSD 9.0earmv6hfassaultcube-1.2.0.2nb10.tgz
NetBSD 9.0earmv7hfassaultcube-1.2.0.2nb9.tgz
NetBSD 9.0earmv7hfassaultcube-1.2.0.2nb9.tgz
NetBSD 9.0earmv7hfassaultcube-1.2.0.2nb9.tgz
NetBSD 9.0earmv7hfassaultcube-1.2.0.2nb9.tgz
NetBSD 9.0earmv7hfassaultcube-1.2.0.2nb9.tgz
NetBSD 9.0earmv7hfassaultcube-1.2.0.2nb10.tgz
NetBSD 9.0i386assaultcube-1.2.0.2nb9.tgz
NetBSD 9.0i386assaultcube-1.2.0.2nb9.tgz
NetBSD 9.0i386assaultcube-1.2.0.2nb9.tgz
NetBSD 9.0i386assaultcube-1.2.0.2nb10.tgz
NetBSD 9.0mips64ebassaultcube-1.2.0.2nb9.tgz
NetBSD 9.0mips64ebassaultcube-1.2.0.2nb9.tgz
NetBSD 9.0mips64ebassaultcube-1.2.0.2nb9.tgz
NetBSD 9.0powerpcassaultcube-1.2.0.2nb9.tgz
NetBSD 9.0powerpcassaultcube-1.2.0.2nb9.tgz
NetBSD 9.0powerpcassaultcube-1.2.0.2nb9.tgz
NetBSD 9.0powerpcassaultcube-1.2.0.2nb9.tgz
NetBSD 9.0powerpcassaultcube-1.2.0.2nb9.tgz
NetBSD 9.0sparc64assaultcube-1.2.0.2nb9.tgz
NetBSD 9.0sparc64assaultcube-1.2.0.2nb10.tgz
NetBSD 9.0sparcassaultcube-1.2.0.2nb9.tgz
NetBSD 9.0x86_64assaultcube-1.2.0.2nb9.tgz
NetBSD 9.0x86_64assaultcube-1.2.0.2nb10.tgz
NetBSD 9.0x86_64assaultcube-1.2.0.2nb9.tgz
NetBSD 9.0x86_64assaultcube-1.2.0.2nb9.tgz
NetBSD 9.0x86_64assaultcube-1.2.0.2nb9.tgz
NetBSD 9.0x86_64assaultcube-1.2.0.2nb9.tgz
NetBSD 9.0x86_64assaultcube-1.2.0.2nb10.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.