graphics/GMT - The NetBSD Packages Collection

Generic Mapping Tools

GMT is a free collection of UNIX tools that allow users to manipulate
(x,y) and (x,y,z) data sets (including filtering, trend fitting,
gridding, projecting, etc.) and produce Encapsulated PostScript File
(EPS) illustrations ranging from simple x-y plots through contour maps
to artificially illuminated surfaces and 3-D perspective views in black
and white, gray tone, hachure patterns, and 24-bit color. GMT supports
25 common map projections plus linear, log, and power scaling, and
comes with support data such as coastlines, rivers, and political
boundaries.

The package also includes supplemental programs, html documentation,
and examples.

Build dependencies

pkgtools/x11-links pkgtools/cwrappers devel/libtool-base

Runtime dependencies

devel/netcdf devel/netcdf

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfGMT-4.1.4nb24.tgz
NetBSD 8.0earmv7hfGMT-4.1.4nb24.tgz
NetBSD 8.0earmv7hfGMT-4.1.4nb24.tgz
NetBSD 8.0i386GMT-4.1.4nb24.tgz
NetBSD 8.0i386GMT-4.1.4nb24.tgz
NetBSD 8.0i386GMT-4.1.4nb24.tgz
NetBSD 8.0powerpcGMT-4.1.4nb24.tgz
NetBSD 8.0powerpcGMT-4.1.4nb24.tgz
NetBSD 8.0powerpcGMT-4.1.4nb24.tgz
NetBSD 8.0x86_64GMT-4.1.4nb24.tgz
NetBSD 8.0x86_64GMT-4.1.4nb24.tgz
NetBSD 9.0aarch64GMT-4.1.4nb24.tgz
NetBSD 9.0aarch64GMT-4.1.4nb24.tgz
NetBSD 9.0aarch64GMT-4.1.4nb24.tgz
NetBSD 9.0alphaGMT-4.1.4nb24.tgz
NetBSD 9.0alphaGMT-4.1.4nb24.tgz
NetBSD 9.0alphaGMT-4.1.4nb24.tgz
NetBSD 9.0earmv6hfGMT-4.1.4nb24.tgz
NetBSD 9.0earmv6hfGMT-4.1.4nb24.tgz
NetBSD 9.0earmv6hfGMT-4.1.4nb24.tgz
NetBSD 9.0earmv6hfGMT-4.1.4nb24.tgz
NetBSD 9.0earmv7hfGMT-4.1.4nb24.tgz
NetBSD 9.0earmv7hfGMT-4.1.4nb24.tgz
NetBSD 9.0earmv7hfGMT-4.1.4nb24.tgz
NetBSD 9.0earmv7hfGMT-4.1.4nb24.tgz
NetBSD 9.0i386GMT-4.1.4nb24.tgz
NetBSD 9.0i386GMT-4.1.4nb24.tgz
NetBSD 9.0i386GMT-4.1.4nb24.tgz
NetBSD 9.0mips64ebGMT-4.1.4nb24.tgz
NetBSD 9.0mips64ebGMT-4.1.4nb24.tgz
NetBSD 9.0mips64ebGMT-4.1.4nb24.tgz
NetBSD 9.0powerpcGMT-4.1.4nb24.tgz
NetBSD 9.0powerpcGMT-4.1.4nb24.tgz
NetBSD 9.0sparc64GMT-4.1.4nb24.tgz
NetBSD 9.0sparc64GMT-4.1.4nb24.tgz
NetBSD 9.0sparc64GMT-4.1.4nb24.tgz
NetBSD 9.0sparc64GMT-4.1.4nb24.tgz
NetBSD 9.0sparcGMT-4.1.4nb24.tgz
NetBSD 9.0sparcGMT-4.1.4nb24.tgz
NetBSD 9.0sparcGMT-4.1.4nb24.tgz
NetBSD 9.0x86_64GMT-4.1.4nb24.tgz
NetBSD 9.0x86_64GMT-4.1.4nb24.tgz
NetBSD 9.0x86_64GMT-4.1.4nb24.tgz
NetBSD 9.0x86_64GMT-4.1.4nb24.tgz
NetBSD 9.0x86_64GMT-4.1.4nb24.tgz
NetBSD 9.0x86_64GMT-4.1.4nb24.tgz
NetBSD 9.0x86_64GMT-4.1.4nb24.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.