graphics/adaptagrams - The NetBSD Packages Collection

Tools for adaptive diagrams

Adaptagrams is a library of tools and reusable code for adaptive diagramming
applications, for example: drawing tools, automated document and diagram
layout, smart presentation software, graph drawing, chart layout, etc.

Currently, the Adaptagrams repository includes four cross-platform C++
libraries, These libraries are collectively known as cola (Constraint Layout):

 * libvpsc - a solver for the Variable Placement with Separation Constraints
              problem.

 * libcola - a library for constraint graph layout.

 * libavoid - a library providing high-quality object-avoiding polyline and
              orthogonalconnector routing for use in interactive diagram
              editors.

 * libtopology - a library containing extensions to libcola to support topology
                 preserving constraint-based layout.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/automake devel/autoconf devel/pkgconf

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfadaptagrams-0.20160901.tgz
NetBSD 8.0earmv7hfadaptagrams-0.20160901.tgz
NetBSD 8.0earmv7hfadaptagrams-0.20160901.tgz
NetBSD 8.0i386adaptagrams-0.20160901.tgz
NetBSD 8.0i386adaptagrams-0.20160901.tgz
NetBSD 8.0i386adaptagrams-0.20160901.tgz
NetBSD 8.0powerpcadaptagrams-0.20160901.tgz
NetBSD 8.0powerpcadaptagrams-0.20160901.tgz
NetBSD 8.0powerpcadaptagrams-0.20160901.tgz
NetBSD 8.0x86_64adaptagrams-0.20160901.tgz
NetBSD 8.0x86_64adaptagrams-0.20160901.tgz
NetBSD 8.0x86_64adaptagrams-0.20160901.tgz
NetBSD 9.0aarch64adaptagrams-0.20160901.tgz
NetBSD 9.0aarch64adaptagrams-0.20160901.tgz
NetBSD 9.0aarch64adaptagrams-0.20160901.tgz
NetBSD 9.0alphaadaptagrams-0.20160901.tgz
NetBSD 9.0alphaadaptagrams-0.20160901.tgz
NetBSD 9.0alphaadaptagrams-0.20160901.tgz
NetBSD 9.0earmv6hfadaptagrams-0.20160901.tgz
NetBSD 9.0earmv6hfadaptagrams-0.20160901.tgz
NetBSD 9.0earmv6hfadaptagrams-0.20160901.tgz
NetBSD 9.0earmv6hfadaptagrams-0.20160901.tgz
NetBSD 9.0earmv7hfadaptagrams-0.20160901.tgz
NetBSD 9.0earmv7hfadaptagrams-0.20160901.tgz
NetBSD 9.0earmv7hfadaptagrams-0.20160901.tgz
NetBSD 9.0earmv7hfadaptagrams-0.20160901.tgz
NetBSD 9.0i386adaptagrams-0.20160901.tgz
NetBSD 9.0i386adaptagrams-0.20160901.tgz
NetBSD 9.0i386adaptagrams-0.20160901.tgz
NetBSD 9.0mips64ebadaptagrams-0.20160901.tgz
NetBSD 9.0mips64ebadaptagrams-0.20160901.tgz
NetBSD 9.0mips64ebadaptagrams-0.20160901.tgz
NetBSD 9.0powerpcadaptagrams-0.20160901.tgz
NetBSD 9.0powerpcadaptagrams-0.20160901.tgz
NetBSD 9.0sparc64adaptagrams-0.20160901.tgz
NetBSD 9.0sparc64adaptagrams-0.20160901.tgz
NetBSD 9.0sparc64adaptagrams-0.20160901.tgz
NetBSD 9.0sparc64adaptagrams-0.20160901.tgz
NetBSD 9.0sparcadaptagrams-0.20160901.tgz
NetBSD 9.0x86_64adaptagrams-0.20160901.tgz
NetBSD 9.0x86_64adaptagrams-0.20160901.tgz
NetBSD 9.0x86_64adaptagrams-0.20160901.tgz
NetBSD 9.0x86_64adaptagrams-0.20160901.tgz
NetBSD 9.0x86_64adaptagrams-0.20160901.tgz
NetBSD 9.0x86_64adaptagrams-0.20160901.tgz
NetBSD 9.0x86_64adaptagrams-0.20160901.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.