graphics/cairomm - The NetBSD Packages Collection

C++ API for cairo

cairomm is a C++ wrapper for the cairo graphics library. It offers all the
power of cairo with an interface familiar to C++ developers, including use of
the Standard Template Library where it makes sense.

Build dependencies

pkgtools/x11-links devel/mm-common x11/xcb-proto x11/xorgproto pkgtools/cwrappers devel/meson lang/perl5 devel/pkgconf

Runtime dependencies

devel/libsigc++ graphics/cairo graphics/cairo devel/libsigc++ graphics/cairo

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfcairomm-1.12.2nb6.tgz
NetBSD 8.0earmv7hfcairomm-1.12.2nb6.tgz
NetBSD 8.0earmv7hfcairomm-1.12.2nb6.tgz
NetBSD 8.0i386cairomm-1.12.2nb6.tgz
NetBSD 8.0i386cairomm-1.12.2nb6.tgz
NetBSD 8.0i386cairomm-1.12.2nb6.tgz
NetBSD 8.0powerpccairomm-1.12.2nb6.tgz
NetBSD 8.0powerpccairomm-1.12.2nb6.tgz
NetBSD 8.0powerpccairomm-1.12.2nb6.tgz
NetBSD 8.0x86_64cairomm-1.12.2nb6.tgz
NetBSD 8.0x86_64cairomm-1.12.2nb6.tgz
NetBSD 8.0x86_64cairomm-1.12.2nb6.tgz
NetBSD 9.0aarch64cairomm-1.12.2nb6.tgz
NetBSD 9.0aarch64cairomm-1.12.2nb6.tgz
NetBSD 9.0alphacairomm-1.12.2nb6.tgz
NetBSD 9.0alphacairomm-1.12.2nb6.tgz
NetBSD 9.0alphacairomm-1.12.2nb6.tgz
NetBSD 9.0earmcairomm-1.12.2nb6.tgz
NetBSD 9.0earmcairomm-1.12.2nb6.tgz
NetBSD 9.0earmv6hfcairomm-1.12.2nb6.tgz
NetBSD 9.0earmv6hfcairomm-1.12.2nb6.tgz
NetBSD 9.0earmv6hfcairomm-1.12.2nb6.tgz
NetBSD 9.0earmv7hfcairomm-1.12.2nb6.tgz
NetBSD 9.0earmv7hfcairomm-1.12.2nb6.tgz
NetBSD 9.0earmv7hfcairomm-1.12.2nb6.tgz
NetBSD 9.0i386cairomm-1.12.2nb6.tgz
NetBSD 9.0i386cairomm-1.12.2nb6.tgz
NetBSD 9.0i386cairomm-1.12.2nb6.tgz
NetBSD 9.0mips64ebcairomm-1.12.2nb6.tgz
NetBSD 9.0mips64ebcairomm-1.12.2nb6.tgz
NetBSD 9.0mips64ebcairomm-1.12.2nb6.tgz
NetBSD 9.0mipselcairomm-1.12.2nb6.tgz
NetBSD 9.0mipselcairomm-1.12.2nb6.tgz
NetBSD 9.0powerpccairomm-1.12.2nb6.tgz
NetBSD 9.0powerpccairomm-1.12.2nb6.tgz
NetBSD 9.0sh3elcairomm-1.12.2nb6.tgz
NetBSD 9.0sh3elcairomm-1.12.2nb6.tgz
NetBSD 9.0sparc64cairomm-1.12.2nb6.tgz
NetBSD 9.0sparc64cairomm-1.12.2nb4.tgz
NetBSD 9.0sparc64cairomm-1.12.2nb6.tgz
NetBSD 9.0sparc64cairomm-1.12.2nb6.tgz
NetBSD 9.0sparccairomm-1.12.2nb6.tgz
NetBSD 9.0sparccairomm-1.12.2nb6.tgz
NetBSD 9.0sparccairomm-1.12.2nb6.tgz
NetBSD 9.0x86_64cairomm-1.12.2nb6.tgz
NetBSD 9.0x86_64cairomm-1.12.2nb6.tgz
NetBSD 9.0x86_64cairomm-1.12.2nb6.tgz
NetBSD 9.0x86_64cairomm-1.12.2nb6.tgz
NetBSD 9.0x86_64cairomm-1.12.2nb6.tgz
NetBSD 9.0x86_64cairomm-1.12.2nb6.tgz
NetBSD 9.0x86_64cairomm-1.12.2nb6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.