graphics/graphviz - The NetBSD Packages Collection

Graph Drawing Programs from AT&T Research and Lucent Bell Labs

Graphviz is a set of graph drawing tools from AT&T Research and Lucent Bell
Laboratories.

It includes:
- dot: makes hierarchical layouts of directed graphs
- neato: makes "spring" model layouts of undirected graphs
- lefty: a programmable graphics editor
- dotty: a customizable interface written in LEFTY
- tcldot: a customizable graphical interface written in TCL
- libgraph: the base library for graph tools
- various associated utilities

Build dependencies

pkgtools/x11-links x11/xorgproto devel/swig x11/xcb-proto pkgtools/cwrappers devel/swig print/ghostscript devel/glib2-tools devel/libtool-base devel/automake devel/autoconf devel/bison devel/gmake lang/perl5 devel/pkgconf

Runtime dependencies

graphics/gd fonts/fontconfig fonts/fontconfig graphics/libwebp lang/lua53 x11/tk lang/perl5 lang/perl5 devel/libltdl devel/pango graphics/cairo graphics/gts graphics/gd fonts/fontconfig graphics/libwebp x11/tk devel/libltdl devel/pango graphics/cairo graphics/gts

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgraphviz-2.44.1nb6.tgz
NetBSD 8.0earmv7hfgraphviz-2.44.1nb3.tgz
NetBSD 8.0earmv7hfgraphviz-2.44.1nb7.tgz
NetBSD 8.0i386graphviz-2.44.1nb3.tgz
NetBSD 8.0i386graphviz-2.44.1nb6.tgz
NetBSD 8.0i386graphviz-2.44.1nb7.tgz
NetBSD 8.0x86_64graphviz-2.44.1nb7.tgz
NetBSD 8.0x86_64graphviz-2.44.1nb3.tgz
NetBSD 8.0x86_64graphviz-2.44.1nb6.tgz
NetBSD 9.0aarch64graphviz-2.44.1nb7.tgz
NetBSD 9.0aarch64graphviz-2.44.1nb3.tgz
NetBSD 9.0aarch64graphviz-2.44.1nb6.tgz
NetBSD 9.0alphagraphviz-2.44.1nb7.tgz
NetBSD 9.0alphagraphviz-2.44.1nb3.tgz
NetBSD 9.0alphagraphviz-2.44.1nb6.tgz
NetBSD 9.0earmgraphviz-2.44.1nb3.tgz
NetBSD 9.0earmgraphviz-2.44.1nb7.tgz
NetBSD 9.0earmv6hfgraphviz-2.44.1nb7.tgz
NetBSD 9.0earmv6hfgraphviz-2.44.1nb3.tgz
NetBSD 9.0earmv6hfgraphviz-2.44.1nb6.tgz
NetBSD 9.0earmv6hfgraphviz-2.44.1nb6.tgz
NetBSD 9.0earmv7hfgraphviz-2.44.1nb7.tgz
NetBSD 9.0earmv7hfgraphviz-2.44.1nb3.tgz
NetBSD 9.0earmv7hfgraphviz-2.44.1nb6.tgz
NetBSD 9.0earmv7hfgraphviz-2.44.1nb6.tgz
NetBSD 9.0i386graphviz-2.44.1nb3.tgz
NetBSD 9.0i386graphviz-2.44.1nb6.tgz
NetBSD 9.0i386graphviz-2.44.1nb7.tgz
NetBSD 9.0m68kgraphviz-2.44.1nb7.tgz
NetBSD 9.0m68kgraphviz-2.44.1nb6.tgz
NetBSD 9.0mips64ebgraphviz-2.44.1nb7.tgz
NetBSD 9.0mips64ebgraphviz-2.44.1nb6.tgz
NetBSD 9.0mipselgraphviz-2.44.1nb7.tgz
NetBSD 9.0sparc64graphviz-2.44.1nb7.tgz
NetBSD 9.0sparc64graphviz-2.40.1nb47.tgz
NetBSD 9.0sparc64graphviz-2.44.1nb3.tgz
NetBSD 9.0sparc64graphviz-2.44.1nb6.tgz
NetBSD 9.0x86_64graphviz-2.44.1nb5.tgz
NetBSD 9.0x86_64graphviz-2.44.1nb6.tgz
NetBSD 9.0x86_64graphviz-2.44.1nb6.tgz
NetBSD 9.0x86_64graphviz-2.44.1nb7.tgz
NetBSD 9.0x86_64graphviz-2.44.1nb3.tgz
NetBSD 9.0x86_64graphviz-2.44.1nb6.tgz
NetBSD 9.0x86_64graphviz-2.44.1nb7.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

gd
Use GD to render graphical output.
ghostscript
Enable GhostScript support.
gtk
Enable support for GTK.
lua
Enable Lua support.
ocaml
Enable OCaml support.
perl
Enable Perl support.
poppler
Enable poppler-utils support.
svg
Enable SVG support.
tcl
Enable Tcl scripting support.
x11
Enable X11 support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.