graphics/kiconthemes - The NetBSD Packages Collection

Support for icon themes

This library contains classes to improve the handling of icons
in applications using the KDE Frameworks. Provided are:

- KIconDialog: Dialog class to let the user select an icon
    from the list of installed icons.
- KIconButton: Custom button class that displays an icon.
    When clicking it, the user can change it using the icon dialog.
- KIconEffect: Applies various colorization effects to icons,
    which can be used to create selected/disabled icon images.

Other classes in this repository are used internally by the icon
theme configuration dialogs, and should not be used by applications.

Build dependencies

devel/extra-cmake-modules devel/extra-cmake-modules pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/cmake devel/cmake

Runtime dependencies

lang/python38 lang/python38 archivers/karchive x11/qt5-qtbase x11/kconfigwidgets x11/kitemviews x11/qt5-qtsvg x11/qt5-qttools archivers/karchive x11/qt5-qtbase x11/kconfigwidgets x11/kitemviews x11/qt5-qtsvg x11/qt5-qttools

Binary packages

OSArchitectureVersion
NetBSD 8.0i386kiconthemes-5.70.0nb2.tgz
NetBSD 8.0powerpckiconthemes-5.70.0nb2.tgz
NetBSD 8.0x86_64kiconthemes-5.70.0nb6.tgz
NetBSD 8.0x86_64kiconthemes-5.70.0nb2.tgz
NetBSD 8.0x86_64kiconthemes-5.70.0nb4.tgz
NetBSD 9.0aarch64kiconthemes-5.70.0nb6.tgz
NetBSD 9.0aarch64kiconthemes-5.70.0nb2.tgz
NetBSD 9.0aarch64kiconthemes-5.70.0nb4.tgz
NetBSD 9.0earmv7hfkiconthemes-5.70.0nb2.tgz
NetBSD 9.0i386kiconthemes-5.70.0nb2.tgz
NetBSD 9.0i386kiconthemes-5.70.0nb4.tgz
NetBSD 9.0i386kiconthemes-5.70.0nb6.tgz
NetBSD 9.0powerpckiconthemes-5.70.0nb4.tgz
NetBSD 9.0sparc64kiconthemes-5.70.0nb6.tgz
NetBSD 9.0sparc64kiconthemes-5.70.0.tgz
NetBSD 9.0sparc64kiconthemes-5.70.0nb2.tgz
NetBSD 9.0x86_64kiconthemes-5.70.0nb3.tgz
NetBSD 9.0x86_64kiconthemes-5.70.0nb5.tgz
NetBSD 9.0x86_64kiconthemes-5.70.0nb5.tgz
NetBSD 9.0x86_64kiconthemes-5.70.0nb2.tgz
NetBSD 9.0x86_64kiconthemes-5.70.0nb4.tgz
NetBSD 9.0x86_64kiconthemes-5.70.0nb6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.