graphics/libansilove - The NetBSD Packages Collection

Library for converting ANSI, ASCII, and other formats to PNG

Library for converting ANSI, ASCII, and other formats to PNG, allowing
to render ANSI and artscene-related file formats into PNG images, and
supporting ANSI (.ANS), PCBoard (.PCB), Binary (.BIN), Artworx (.ADF),
iCE Draw (.IDF), Tundra (.TND) and XBin (.XB) formats.

It creates size optimized 4-bit PNG files and supports SAUCE (Standard
Architecture for Universal Comment Extentions), 80x25 and 80x50 PC fonts
(including all the 14 MS-DOS charsets), Amiga fonts, and iCE colors.

Build dependencies

pkgtools/cwrappers devel/cmake

Runtime dependencies

graphics/gd graphics/gd

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibansilove-1.2.8.tgz
NetBSD 8.0earmv7hflibansilove-1.2.5.tgz
NetBSD 8.0earmv7hflibansilove-1.2.8.tgz
NetBSD 8.0i386libansilove-1.2.5.tgz
NetBSD 8.0i386libansilove-1.2.8.tgz
NetBSD 8.0i386libansilove-1.2.8.tgz
NetBSD 8.0powerpclibansilove-1.2.5.tgz
NetBSD 8.0powerpclibansilove-1.2.8.tgz
NetBSD 8.0powerpclibansilove-1.2.8.tgz
NetBSD 8.0x86_64libansilove-1.2.5.tgz
NetBSD 8.0x86_64libansilove-1.2.8.tgz
NetBSD 9.0aarch64libansilove-1.2.8.tgz
NetBSD 9.0aarch64libansilove-1.2.5.tgz
NetBSD 9.0aarch64libansilove-1.2.8.tgz
NetBSD 9.0alphalibansilove-1.2.8.tgz
NetBSD 9.0alphalibansilove-1.2.5.tgz
NetBSD 9.0alphalibansilove-1.2.8.tgz
NetBSD 9.0earmv6hflibansilove-1.2.8.tgz
NetBSD 9.0earmv6hflibansilove-1.2.5.tgz
NetBSD 9.0earmv6hflibansilove-1.2.8.tgz
NetBSD 9.0earmv6hflibansilove-1.2.8.tgz
NetBSD 9.0earmv7hflibansilove-1.2.8.tgz
NetBSD 9.0earmv7hflibansilove-1.2.5.tgz
NetBSD 9.0earmv7hflibansilove-1.2.8.tgz
NetBSD 9.0earmv7hflibansilove-1.2.8.tgz
NetBSD 9.0i386libansilove-1.2.5.tgz
NetBSD 9.0i386libansilove-1.2.8.tgz
NetBSD 9.0i386libansilove-1.2.8.tgz
NetBSD 9.0mips64eblibansilove-1.2.8.tgz
NetBSD 9.0mips64eblibansilove-1.2.5.tgz
NetBSD 9.0mips64eblibansilove-1.2.8.tgz
NetBSD 9.0powerpclibansilove-1.2.8.tgz
NetBSD 9.0powerpclibansilove-1.2.5.tgz
NetBSD 9.0sparc64libansilove-1.2.8.tgz
NetBSD 9.0sparc64libansilove-1.2.4.tgz
NetBSD 9.0sparc64libansilove-1.2.5.tgz
NetBSD 9.0sparc64libansilove-1.2.8.tgz
NetBSD 9.0sparclibansilove-1.2.8.tgz
NetBSD 9.0sparclibansilove-1.2.5.tgz
NetBSD 9.0sparclibansilove-1.2.8.tgz
NetBSD 9.0x86_64libansilove-1.2.8.tgz
NetBSD 9.0x86_64libansilove-1.2.8.tgz
NetBSD 9.0x86_64libansilove-1.2.8.tgz
NetBSD 9.0x86_64libansilove-1.2.5.tgz
NetBSD 9.0x86_64libansilove-1.2.8.tgz
NetBSD 9.0x86_64libansilove-1.2.8.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.