graphics/ruby-gdk_pixbuf2 - The NetBSD Packages Collection

Ruby binding of GdkPixbuf-2.x

Ruby-GNOME is a set of Ruby language bindings for the various
application development libraries included with the GNOME/GTK+
environment.

Ruby/GdkPixbuf2 is a Ruby binding of GdkPixbuf-2.x.

Build dependencies

pkgtools/cwrappers devel/glib2-tools

Runtime dependencies

devel/ruby-gio2 graphics/gdk-pixbuf2 graphics/gdk-pixbuf2 lang/ruby26-base graphics/gdk-pixbuf2

Available binary packages

aarch64:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
aarch64:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
aarch64:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
aarch64:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
aarch64:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
aarch64:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
aarch64:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
aarch64:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
aarch64:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
alpha:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
alpha:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
alpha:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
alpha:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
alpha:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
alpha:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
alpha:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
alpha:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
alpha:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earm:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earm:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earm:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earm:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earm:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earmv6hf:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earmv6hf:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earmv6hf:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earmv6hf:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earmv6hf:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earmv6hf:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earmv6hf:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earmv6hf:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earmv6hf:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earmv6hf:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earmv6hf:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earmv6hf:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earmv7hf:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
earmv7hf:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
earmv7hf:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
earmv7hf:ruby24-gdk_pixbuf2-3.4.1nb1.tgz(NetBSD 8.0)
earmv7hf:ruby25-gdk_pixbuf2-3.4.1nb1.tgz(NetBSD 8.0)
earmv7hf:ruby26-gdk_pixbuf2-3.4.1nb1.tgz(NetBSD 8.0)
earmv7hf:ruby27-gdk_pixbuf2-3.4.1nb1.tgz(NetBSD 8.0)
earmv7hf:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
earmv7hf:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
earmv7hf:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
earmv7hf:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
earmv7hf:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
earmv7hf:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
earmv7hf:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earmv7hf:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earmv7hf:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earmv7hf:ruby24-gdk_pixbuf2-3.4.1nb1.tgz(NetBSD 9.0)
earmv7hf:ruby25-gdk_pixbuf2-3.4.1nb1.tgz(NetBSD 9.0)
earmv7hf:ruby26-gdk_pixbuf2-3.4.1nb1.tgz(NetBSD 9.0)
earmv7hf:ruby27-gdk_pixbuf2-3.4.1nb1.tgz(NetBSD 9.0)
earmv7hf:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earmv7hf:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earmv7hf:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earmv7hf:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earmv7hf:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earmv7hf:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earmv7hf:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earmv7hf:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
earmv7hf:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
i386:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
i386:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
i386:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
i386:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
i386:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
i386:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
i386:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
i386:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
i386:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
i386:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
i386:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
i386:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
i386:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
i386:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
i386:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
i386:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
i386:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
i386:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
m68k:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
m68k:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
m68k:ruby26-gdk_pixbuf2-3.4.1nb1.tgz(NetBSD 9.0)
mips64eb:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
mips64eb:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
mips64eb:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
mips64eb:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
mips64eb:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
mips64eb:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
mipsel:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
powerpc:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
powerpc:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
powerpc:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
powerpc:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
powerpc:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
powerpc:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
powerpc:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
powerpc:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
powerpc:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
powerpc:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
powerpc:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
powerpc:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
powerpc:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
powerpc:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
powerpc:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
sh3el:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
sh3el:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
sparc64:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
sparc64:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
sparc64:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
sparc64:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
sparc64:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
sparc64:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
sparc64:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
sparc64:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
sparc64:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
sparc:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
sparc:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
x86_64:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
x86_64:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
x86_64:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
x86_64:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
x86_64:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
x86_64:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
x86_64:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
x86_64:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 8.0)
x86_64:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby25-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby26-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)
x86_64:ruby27-gdk_pixbuf2-3.4.2.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]