ham/flxmlrpc - The NetBSD Packages Collection

XmlRpc protocol written in C++ for fl*, ham emergency communications

This is flxmlrpc, an implementation of the XmlRpc protocol
written in C++, based upon XmlRpc++0.7 and modified to provide additional XmlRpc
Variable types.  It is used in fldigi, flrig, flnet, flmsg, flarq, flamp, fllog;
a suite of programs written for amateur radio emergency communications.

flxmlrpc is designed to make it easy to incorporate xmlrpc client and server
support into C++ applications. Or use both client and server objects in your
application for easy peer-to-peer support.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfflxmlrpc-0.1.4.tgz
NetBSD 8.0earmv7hfflxmlrpc-0.1.4.tgz
NetBSD 8.0earmv7hfflxmlrpc-0.1.4.tgz
NetBSD 8.0i386flxmlrpc-0.1.4.tgz
NetBSD 8.0i386flxmlrpc-0.1.4.tgz
NetBSD 8.0i386flxmlrpc-0.1.4.tgz
NetBSD 8.0powerpcflxmlrpc-0.1.4.tgz
NetBSD 8.0powerpcflxmlrpc-0.1.4.tgz
NetBSD 8.0powerpcflxmlrpc-0.1.4.tgz
NetBSD 8.0x86_64flxmlrpc-0.1.4.tgz
NetBSD 8.0x86_64flxmlrpc-0.1.4.tgz
NetBSD 9.0aarch64flxmlrpc-0.1.4.tgz
NetBSD 9.0aarch64flxmlrpc-0.1.4.tgz
NetBSD 9.0aarch64flxmlrpc-0.1.4.tgz
NetBSD 9.0alphaflxmlrpc-0.1.4.tgz
NetBSD 9.0alphaflxmlrpc-0.1.4.tgz
NetBSD 9.0alphaflxmlrpc-0.1.4.tgz
NetBSD 9.0earmflxmlrpc-0.1.4.tgz
NetBSD 9.0earmflxmlrpc-0.1.4.tgz
NetBSD 9.0earmflxmlrpc-0.1.4.tgz
NetBSD 9.0earmv6hfflxmlrpc-0.1.4.tgz
NetBSD 9.0earmv6hfflxmlrpc-0.1.4.tgz
NetBSD 9.0earmv6hfflxmlrpc-0.1.4.tgz
NetBSD 9.0earmv6hfflxmlrpc-0.1.4.tgz
NetBSD 9.0earmv7hfflxmlrpc-0.1.4.tgz
NetBSD 9.0earmv7hfflxmlrpc-0.1.4.tgz
NetBSD 9.0earmv7hfflxmlrpc-0.1.4.tgz
NetBSD 9.0earmv7hfflxmlrpc-0.1.4.tgz
NetBSD 9.0i386flxmlrpc-0.1.4.tgz
NetBSD 9.0i386flxmlrpc-0.1.4.tgz
NetBSD 9.0mips64ebflxmlrpc-0.1.4.tgz
NetBSD 9.0mips64ebflxmlrpc-0.1.4.tgz
NetBSD 9.0mips64ebflxmlrpc-0.1.4.tgz
NetBSD 9.0powerpcflxmlrpc-0.1.4.tgz
NetBSD 9.0powerpcflxmlrpc-0.1.4.tgz
NetBSD 9.0sparc64flxmlrpc-0.1.4.tgz
NetBSD 9.0sparc64flxmlrpc-0.1.4.tgz
NetBSD 9.0sparc64flxmlrpc-0.1.4.tgz
NetBSD 9.0sparc64flxmlrpc-0.1.4.tgz
NetBSD 9.0sparcflxmlrpc-0.1.4.tgz
NetBSD 9.0sparcflxmlrpc-0.1.4.tgz
NetBSD 9.0sparcflxmlrpc-0.1.4.tgz
NetBSD 9.0x86_64flxmlrpc-0.1.4.tgz
NetBSD 9.0x86_64flxmlrpc-0.1.4.tgz
NetBSD 9.0x86_64flxmlrpc-0.1.4.tgz
NetBSD 9.0x86_64flxmlrpc-0.1.4.tgz
NetBSD 9.0x86_64flxmlrpc-0.1.4.tgz
NetBSD 9.0x86_64flxmlrpc-0.1.4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.