lang/nodejs10 - The NetBSD Packages Collection

V8 JavaScript for clients and servers

Node.js is an evented I/O framework for the V8 JavaScript engine. It is
intended for writing scalable network programs such as web servers.

This package holds the 10.x LTS release.

Build dependencies

sysutils/lockf lang/python27 pkgtools/cwrappers lang/python27 shells/bash devel/gmake devel/pkgconf

Runtime dependencies

devel/libuv devel/libuv net/libcares textproc/icu www/http-parser www/http-parser www/nghttp2 www/nghttp2 net/libcares textproc/icu www/nghttp2

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfnodejs-10.23.0.tgz
NetBSD 8.0earmv7hfnodejs-10.21.0.tgz
NetBSD 8.0earmv7hfnodejs-10.24.0.tgz
NetBSD 8.0i386nodejs-10.21.0.tgz
NetBSD 8.0i386nodejs-10.23.0.tgz
NetBSD 8.0i386nodejs-10.24.0.tgz
NetBSD 8.0x86_64nodejs-10.24.0.tgz
NetBSD 8.0x86_64nodejs-10.21.0.tgz
NetBSD 8.0x86_64nodejs-10.23.0.tgz
NetBSD 9.0aarch64nodejs-10.24.0.tgz
NetBSD 9.0aarch64nodejs-10.21.0.tgz
NetBSD 9.0aarch64nodejs-10.23.0.tgz
NetBSD 9.0earmv6hfnodejs-10.24.0.tgz
NetBSD 9.0earmv6hfnodejs-10.21.0.tgz
NetBSD 9.0earmv6hfnodejs-10.23.0.tgz
NetBSD 9.0earmv6hfnodejs-10.23.0.tgz
NetBSD 9.0earmv7hfnodejs-10.24.0.tgz
NetBSD 9.0earmv7hfnodejs-10.21.0.tgz
NetBSD 9.0earmv7hfnodejs-10.23.0.tgz
NetBSD 9.0earmv7hfnodejs-10.23.0.tgz
NetBSD 9.0i386nodejs-10.21.0.tgz
NetBSD 9.0i386nodejs-10.23.0.tgz
NetBSD 9.0i386nodejs-10.24.0.tgz
NetBSD 9.0x86_64nodejs-10.23.0.tgz
NetBSD 9.0x86_64nodejs-10.23.0.tgz
NetBSD 9.0x86_64nodejs-10.23.1.tgz
NetBSD 9.0x86_64nodejs-10.24.0.tgz
NetBSD 9.0x86_64nodejs-10.21.0.tgz
NetBSD 9.0x86_64nodejs-10.23.0.tgz
NetBSD 9.0x86_64nodejs-10.24.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

dtrace
Enable DTrace support.
openssl
Enable OpenSSL support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.