lang/ossp-js - The NetBSD Packages Collection

Sanitized distribution of Mozilla's JavaScript implementation

OSSP js is a stand-alone distribution of the JavaScript (JS)
programming language reference implementation from Mozilla -- aka
"JSRef" or "SpiderMonkey". This distribution provides a smart,
stand-alone and portable distribution of Mozilla JavaScript through a
GNU autotools-based build environment.  Additionally,
the C API in "libjs" contains both the JavaScript engine and the
required Sun math library ("fdlibm") and with all internal symbols
carefully protected under the "js" namespace. Finally, a js-config(1)
utility and a pkg-config(1) specification is provided to allow
applications to easily build with the JavaScript C API.

OSSP js was created because for OSSP and similar pedantic C coding
projects a smart, stand-alone, portable, clean, powerful and
robust scripting language engine is required. JavaScript is a
great programming language and Mozilla JavaScript "SpiderMonkey"
definitely is an acceptable clean, powerful and robust implementation.
Unfortunately there is just a stand-alone distribution released from
time to time by Mozilla and it is far away from really being smart,
stand-alone and portable. OSSP js combines the best from two worlds:
the 1:1 repackaged JavaScript code base from Mozilla with the GNU
autotools-based build environment as always used by OSSP.  Additionally,
this package provides stdio-based file object support and does not depend
upon the Mozilla NSPR library.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/pkgconf

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfossp-js-1.6.20070208nb11.tgz
NetBSD 8.0earmv7hfossp-js-1.6.20070208nb11.tgz
NetBSD 8.0earmv7hfossp-js-1.6.20070208nb11.tgz
NetBSD 8.0i386ossp-js-1.6.20070208nb11.tgz
NetBSD 8.0i386ossp-js-1.6.20070208nb11.tgz
NetBSD 8.0i386ossp-js-1.6.20070208nb11.tgz
NetBSD 8.0powerpcossp-js-1.6.20070208nb11.tgz
NetBSD 8.0powerpcossp-js-1.6.20070208nb11.tgz
NetBSD 8.0powerpcossp-js-1.6.20070208nb11.tgz
NetBSD 8.0x86_64ossp-js-1.6.20070208nb11.tgz
NetBSD 8.0x86_64ossp-js-1.6.20070208nb11.tgz
NetBSD 8.0x86_64ossp-js-1.6.20070208nb11.tgz
NetBSD 9.0aarch64ossp-js-1.6.20070208nb11.tgz
NetBSD 9.0aarch64ossp-js-1.6.20070208nb11.tgz
NetBSD 9.0aarch64ossp-js-1.6.20070208nb11.tgz
NetBSD 9.0alphaossp-js-1.6.20070208nb11.tgz
NetBSD 9.0alphaossp-js-1.6.20070208nb11.tgz
NetBSD 9.0alphaossp-js-1.6.20070208nb11.tgz
NetBSD 9.0earmv6hfossp-js-1.6.20070208nb11.tgz
NetBSD 9.0earmv6hfossp-js-1.6.20070208nb11.tgz
NetBSD 9.0earmv6hfossp-js-1.6.20070208nb11.tgz
NetBSD 9.0earmv6hfossp-js-1.6.20070208nb11.tgz
NetBSD 9.0earmv7hfossp-js-1.6.20070208nb11.tgz
NetBSD 9.0earmv7hfossp-js-1.6.20070208nb11.tgz
NetBSD 9.0earmv7hfossp-js-1.6.20070208nb11.tgz
NetBSD 9.0earmv7hfossp-js-1.6.20070208nb11.tgz
NetBSD 9.0i386ossp-js-1.6.20070208nb11.tgz
NetBSD 9.0i386ossp-js-1.6.20070208nb11.tgz
NetBSD 9.0i386ossp-js-1.6.20070208nb11.tgz
NetBSD 9.0mips64ebossp-js-1.6.20070208nb11.tgz
NetBSD 9.0mips64ebossp-js-1.6.20070208nb11.tgz
NetBSD 9.0mips64ebossp-js-1.6.20070208nb11.tgz
NetBSD 9.0powerpcossp-js-1.6.20070208nb11.tgz
NetBSD 9.0powerpcossp-js-1.6.20070208nb11.tgz
NetBSD 9.0sparc64ossp-js-1.6.20070208nb11.tgz
NetBSD 9.0sparc64ossp-js-1.6.20070208nb10.tgz
NetBSD 9.0sparc64ossp-js-1.6.20070208nb11.tgz
NetBSD 9.0sparc64ossp-js-1.6.20070208nb11.tgz
NetBSD 9.0sparcossp-js-1.6.20070208nb11.tgz
NetBSD 9.0x86_64ossp-js-1.6.20070208nb11.tgz
NetBSD 9.0x86_64ossp-js-1.6.20070208nb11.tgz
NetBSD 9.0x86_64ossp-js-1.6.20070208nb11.tgz
NetBSD 9.0x86_64ossp-js-1.6.20070208nb11.tgz
NetBSD 9.0x86_64ossp-js-1.6.20070208nb11.tgz
NetBSD 9.0x86_64ossp-js-1.6.20070208nb11.tgz
NetBSD 9.0x86_64ossp-js-1.6.20070208nb11.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.