Daemon Power

The NetBSD Packages Collection: mail/neomutt

Brief description of the package:
Fork of mutt with integrated community patches

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://www.neomutt.org/.

Please note that this package has a gnu-gpl-v2 license.

The package is located in the "mail/neomutt" directory. The current source version of the package is "neomutt-20180716nb1". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for mail/neomutt :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: gnupg2>=2.2.0 pinentry-[0-9]* libassuan>=2.1.0 libgpg-error>=0.6 cwrappers>=20150314 libgpg-error>=1.17 libgpg-error>=1.10nb1 libassuan>=2.4.2 libgpg-error>=1.16 libksba>=0.9.7 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=1.2 libgcrypt>=1.6.0 libksba>=1.3.0nb1 libusb1>=1.0.9 libgcrypt>=1.7 libgpg-error>=1.28 libassuan>=2.5.1 libksba>=1.3.4 npth>=1.2 npth>=1.1 perl>=5.0 cyrus-sasl>=2.1.12 ncursesw>=5.5 ncurses-6.1{,nb*} ncurses>=5.3nb1 ncurses>=6.0 tokyocabinet>=1.3.7 libidn>=0.4.6 gpgme>=0.9.0 libassuan>=2.0.2 notmuch>=0.16 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 readline>=2.2 readline>=6.0 gmime3>=3.0.3 glib2>=2.4.0 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 pcre>=8.30nb1 python27>=2.7.1nb2 glib2>=2.34.0 gpgme>=1.8.0nb1 gmime3>=3.0 xapian>=1.4 libuuid>=2.18 xapian>=1.0.7 talloc>=2.1.0 libxslt-[0-9]* libxml2>=2.6.27 xmlcatmgr>=2.0beta1 libxml2>=2.6.2 libxml2>=2.8.0nb2 docbook-xml-[0-9]* docbook-xsl-[0-9]* docbook-xml>=4.2 xapian>=1.4.1 py27-sphinx-[0-9]* py27-alabaster>=0.7 py27-pygments>=0.8 py27-setuptools>=0.8 py27-expat-[0-9]* py27-nose-[0-9]* py27-babel>=1.3 py27-pytz-[0-9]* py27-docutils>=0.11 py27-roman>=1.4 py27-expat>=0 py27-imagesize-[0-9]* py27-jinja2>=2.3 py27-babel>=0.8 py27-markupsafe>=0.23 py27-packaging-[0-9]* py27-pyparsing>=2.0.2 py27-six-[0-9]* py27-pygments>=2.0 py27-requests>=2.0.0 py27-OpenSSL>=0.14 py27-cryptography>=2.2.1 py27-asn1crypto-[0-9]* py27-cffi>=1.8.2 py27-cparser-[0-9]* py27-test-[0-9]* py27-atomicwrites>=1.0 py27-attrs>=17.4.0 py27-more-itertools>=4.0.0 py27-six>=1.0.0 py27-pluggy>=0.7 py27-setuptools_scm-[0-9]* py27-py>=1.5.0 py27-six>=1.10.0 py27-funcsigs-[0-9]* py27-unittest2-[0-9]* py27-six>=1.4 py27-argparse-[0-9]* py27-traceback2-[0-9]* py27-pbr-[0-9]* py27-pip-[0-9]* py27-linecache2-[0-9]* py27-cparser>=2.10 py27-idna-[0-9]* py27-enum34-[0-9]* py27-ipaddress-[0-9]* py27-six>=1.5.2 py27-certifi>=2017.4.17 py27-chardet>=3.0.2 py27-cryptography>=1.3.4 py27-idna>=2.5 py27-urllib3>=1.12.1 py27-Socks>=1.6.0 py27-certifi-[0-9]* py27-idna>=2.0.0 py27-snowballstemmer>=1.1 py27-sphinxcontrib-websupport-[0-9]* py27-six>=1.5 py27-typing-[0-9]* cyrus-sasl>=2.1.26 ncursesw>=6.0 tokyocabinet>=1.4.41 libidn>=1.20nb1 notmuch>=0.25.2 gettext-tools-[0-9]* gettext-lib>=0.18 .

This package requires the following package(s) to run: gnupg2>=2.2.0 pinentry-[0-9]* libassuan>=2.1.0 libgpg-error>=0.6 libgpg-error>=1.17 libgpg-error>=1.10nb1 libassuan>=2.4.2 libgpg-error>=1.16 libksba>=0.9.7 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=1.2 libgcrypt>=1.6.0 libksba>=1.3.0nb1 libusb1>=1.0.9 libgcrypt>=1.7 libgpg-error>=1.28 libassuan>=2.5.1 libksba>=1.3.4 npth>=1.2 npth>=1.1 perl>=5.0 cyrus-sasl>=2.1.12 ncursesw>=5.5 ncurses-6.1{,nb*} ncurses>=5.3nb1 ncurses>=6.0 tokyocabinet>=1.3.7 libidn>=0.4.6 gpgme>=0.9.0 libassuan>=2.0.2 notmuch>=0.16 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 gmime3>=3.0.3 glib2>=2.4.0 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 pcre>=8.30nb1 glib2>=2.34.0 gpgme>=1.8.0nb1 gmime3>=3.0 xapian>=1.4 libuuid>=2.18 xapian>=1.0.7 talloc>=2.1.0 python27>=2.7.1nb2 xapian>=1.4.1 cyrus-sasl>=2.1.26 ncursesw>=6.0 tokyocabinet>=1.4.41 libidn>=1.20nb1 notmuch>=0.25.2 .

This package supports the following build-time options:

debug
Enable debugging facilities in the package.
gpgme
Enable gpg support, by using the gpgme library.
gssapi
Enable gssapi (Kerberos V) support.
idn
Internationalized Domain Names (IDN) support.
sasl
Enable SASL support.
smime
Enable S/MIME support.
ssl
Enable SSL support.
tokyocabinet
Enable Tokyo Cabinet support.
curses
Enable curses support.
ncurses
Enable ncurses support.
ncursesw
Enable wide character ncurses support.
slang
Enable S-Lang support.

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
earmv6hf:neomutt-20170912.tgz(NetBSD 8.0)
earmv6hf:neomutt-20171215.tgz(NetBSD 8.0)
earmv7hf:neomutt-20180223.tgz(NetBSD 8.0)
i386:neomutt-20180716.tgz(NetBSD 7.0)
i386:neomutt-20170609.tgz(NetBSD 7.0)
i386:neomutt-20170912.tgz(NetBSD 7.0)
i386:neomutt-20171215.tgz(NetBSD 7.0)
i386:neomutt-20180223.tgz(NetBSD 7.0)
i386:neomutt-20180716.tgz(NetBSD 7.1)
i386:neomutt-20171215.tgz(NetBSD 7.1)
i386:neomutt-20180223.tgz(NetBSD 7.1)
i386:neomutt-20180716.tgz(NetBSD 8.0)
i386:neomutt-20171215.tgz(NetBSD 8.0)
i386:neomutt-20180223.tgz(NetBSD 8.0)
powerpc:neomutt-20180512.tgz(NetBSD 7.1)
powerpc:neomutt-20180716.tgz(NetBSD 7.1)
powerpc:neomutt-20180223.tgz(NetBSD 7.1)
powerpc:neomutt-20180512.tgz(NetBSD 8.0)
powerpc:neomutt-20180716.tgz(NetBSD 8.0)
powerpc:neomutt-20180223.tgz(NetBSD 8.0)
sparc64:neomutt-20171215.tgz(NetBSD 8.0)
x86_64:neomutt-20180716.tgz(NetBSD 7.0)
x86_64:neomutt-20170912.tgz(NetBSD 7.0)
x86_64:neomutt-20171215.tgz(NetBSD 7.0)
x86_64:neomutt-20180223.tgz(NetBSD 7.0)
x86_64:neomutt-20170609.tgz(NetBSD 7.0.1_PATCH)
x86_64:neomutt-20180716.tgz(NetBSD 7.1)
x86_64:neomutt-20171215.tgz(NetBSD 7.1)
x86_64:neomutt-20180223.tgz(NetBSD 7.1)
x86_64:neomutt-20180716.tgz(NetBSD 8.0)
x86_64:neomutt-20170609.tgz(NetBSD 8.99.1)
x86_64:neomutt-20170912.tgz(NetBSD 8.0)
x86_64:neomutt-20171215.tgz(NetBSD 8.0)
x86_64:neomutt-20180223.tgz(NetBSD 8.0)
x86_64:neomutt-20170714nb1.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]