Daemon Power

The NetBSD Packages Collection: math/octave

Brief description of the package:
High-level language, intended for numerical computations

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://www.octave.org/.

Please note that this package has a gnu-gpl-v3 license.

The package is located in the "math/octave" directory. The current source version of the package is "octave-4.4.1nb2". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for math/octave :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: gnuplot>=3.7 pango>=1.6.0 Xft2>=2.1.7nb3 fontconfig>=2.2 libuuid>=2.18 cwrappers>=20150314 freetype2>=2.8.1 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 gperf-[0-9]* fontconfig>=2.10.93 fontconfig>=2.1nb2 Xrender>=0.9.0nb2 x11-links>=1.12 osabi-NetBSD-8.0_RC2 xorgproto>=2016.1 Xrender>=0.2 Xrender>=0.8.2 fontconfig>=2.13.0 Xrender>=0.9.0nb1 Xft2>=2.1 Xft2>=2.1nb2 fontconfig>=2.11.91 Xrender>=0.8 fribidi>=0.19.7 fribidi>=0.19.1 glib2>=2.33.12 perl>=5.0 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 readline>=2.2 readline>=6.0 python27>=2.7.1nb2 glib2>=2.4.0 harfbuzz>=0.9.9 icu>=3.4 icu>=62.1 glib2>=2.34.0 harfbuzz>=0.9.4 cairo>=1.12.10 MesaLib>=3.4.2 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 xcb-proto>=1.13 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 xcb-proto>=1.4 py27-mako-[0-9]* py27-setuptools>=0.8 py27-expat-[0-9]* lzo>=2.01 fontconfig>=2.2.95 freetype2>=2.1.9 png>=1.2.4 pixman>=0.30.0 pixman>=0.25.2 MesaLib>=7.11.2 png>=1.6.0nb1 cairo>=1.0.0nb2 cairo-gobject>=1.10.2 cairo>=1.14.12nb1 glib2>=2.14.0 Xft2>=2.1.7nb7 harfbuzz>=1.4.2nb1 cairo-gobject>=1.14.12nb1 help2man-[0-9]* p5-gettext>=1.01 perl>=5.28.0 perl<5.30.0 gobject-introspection>=0.6.14nb1 py27-cElementTree-[0-9]* glib2>=2.54.0 libffi>=3.0.0 gobject-introspection>=1.34.0 libcerf>=1.4 gd>=2.0.15nb1 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 libimagequant>=2.8.2 libwebp>=0.2.0 giflib>=5.1.0 tiff>=4.0.3nb5 libwebp>=0.6.0 pango>=1.42.1 gd>=2.2.5nb2 tex-latex-bin-[0-9]* tex-babel>3.14 tex-carlisle>=2010 tex-cm-[0-9]* kpathsea>=3.5.7 tex-tetex>=3.0.25424 dialog>=1.0 kpathsea-[0-9]* tex-kpathsea>=2012nb1 tex-texlive.infra-[0-9]* tex-graphics-[0-9]* tex-graphics-cfg-[0-9]* tex-graphics-def-[0-9]* tex-latex-[0-9]* tex-latexconfig>=2011 tex-latex-fonts-[0-9]* tex-luatex-[0-9]* luatex>=0.60.1 zziplib>=0.10.82 mpfr>=2.0.3 gmp>=5.0 gmp>=4.2.1 gmp>=5.0.1 kpathsea>=6.2.1 kpathsea>=6.0.0 poppler>=0.5.1 openjpeg>=2.1.0 lcms2>=2.2 zziplib>=0.13.56 mpfr>=4.0.0 poppler>=0.68.0 poppler-includes>=0.22.2 poppler-includes>=0.68.0 tex-etex-[0-9]* tex-plain-[0-9]* tex-amsfonts-[0-9]* tex-hyphen-base-[0-9]* tex-knuth-lib-[0-9]* tex-tex-ini-files-[0-9]* tex-pdftex-[0-9]* tex-dvips-[0-9]* tex-kpathsea-[0-9]* tex-updmap-map-[0-9]* web2c-[0-9]* ptexenc>=1.3.4 ptexenc>=1.1.1 tex-tetex>=3.0.27774 tex-plain>=3.14159265.12854 tex-unicode-data-[0-9]* tex-tools-[0-9]* tex-graphics>=1.0onb1 tex-latex>=2009 tex-latex>=2012 tex-ucs-[0-9]* tex-hyperref-[0-9]* tex-ifxetex>=0.6 tex-latex-bin>=2009nb1 tex-oberdiek>=2009nb1 tex-amsmath-[0-9]* tex-etex-pkg-[0-9]* tex-ifluatex-[0-9]* tex-ifxetex-[0-9]* tex-url>=3.2 bsdtar-[0-9]* gmake>=3.81 hdf5>=1.8.7 qhull>=2003.1 libsndfile>=1.0.0 flac>=1.1.0nb1 libogg>=1.1 libogg>=1.1.2nb1 libogg>=1.1.3 libvorbis>=1.0.1 flac>=1.1.3nb1 libvorbis>=1.1.0nb1 hicolor-icon-theme>=0.4 arpack>=96 g95>=0.91 libtool-fortran>=2.4.2nb9 blas>=1.0nb2 fftw>=3.0 fftwf>=3.0 fftw>=3.2 lapack>=3.1.1 blas>=1.0nb3 curl>=7.12.3 libidn2>=2.0.0 libunistring>=0.9.3 libunistring>=0.9.4 qt5-qtbase>=5.9.1 pcre2>=10.21 dbus>=0.91 xmlto-[0-9]* getopt-[0-9]* docbook-xsl>=1.67.0nb1 docbook-xml>=4.2 libxslt>=1.1.8 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 docbook-xml-[0-9]* docbook-xsl-[0-9]* libxslt>=1.1.28nb2 libproxy>=0.2.3 glu>=3.4.2 glu>=6.0 xcb-util>=0.3.9 gperf>=3.0.1 xcb-util-image>=0.3.9 xcb-util-keysyms>=0.3.9 xcb-util-renderutil>=0.3.8nb1 xcb-util-wm>=0.3.9 xcursor>=1.0 Xfixes>=2.0.0 fixesproto>=3.0.0<5 Xfixes>=2.0.1nb2 xcursor>=1.1.1 Xrandr>=0.99 Xrandr>=1.0.1 libxkbcommon>=0.4.0 libxcb>=1.10 xorg-util-macros>=1.17 xkeyboard-config>=1.9 xkbcomp-[0-9]* pcre2>=10.30 libproxy>=0.4.11 glu>=7.11.2 xcursor>=1.1.2nb1 Xrandr>=1.0.2nb3 libxkbcommon>=0.4.0nb1 qt5-qttools>=5.9.1 xdg-utils-[0-9]* bash-[0-9]* gsed>=3.0.2 w3m-[0-9]* boehm-gc>=7.2 libatomic_ops>=7.4.0<2000 boehm-gc>=7.4 clang>=5.0 llvm-6.0.1{,nb*} llvm>=4.0.1 qt5-qtdeclarative>=5.9.1 qt5-qtxmlpatterns>=5.9.1 qt5-qtbase>=5.11.1nb1 qt5-qtxmlpatterns>=5.11.1nb1 qt5-qtlocation>=5.9.1 qt5-qtdeclarative>=5.11.1nb1 qt5-qtmultimedia>=5.9.1 openal-soft>=1.5.304 pulseaudio>=12.0 avahi>=0.6.23 gtk2+>=2.14.0 shared-mime-info>=0.15 atk>=1.30.0 glib2>=2.31.2 atk>=1.11.4 glib2>=2.28.0 gdk-pixbuf2>=2.22.0 glib2>=2.37.2 shared-mime-info>=1.0nb1 Xft2>=2.1.2nb2 libXi>=1.3.0 libXi>=1.0.0 libXcomposite>=0.3.1 pango>=1.20.0 cairo>=1.6.0 atk>=2.6.0 gdk-pixbuf2>=2.34.0nb1 gobject-introspection>=0.9.3 gtk2+>=2.4.0 libdaemon>=0.14 libdaemon>=0.10 gtk2+>=2.24.32nb3 libXtst>=1.0.1 consolekit>=0.3.0 polkit>=0.103 spidermonkey52>=52.0.0 nspr>=4.9.3.2 libxslt-[0-9]* dbus-glib>=0.61 glib2>=2.40 dbus>=1.8 dbus-glib>=0.100nb1 speexdsp>=1.2rc3 speex>=1.2rc2 speex>=1.2rc1 gdbm>=1.8.3 libltdl>=2.4.2 avahi>=0.6.32nb13 consolekit>=0.3.0nb9 libsndfile>=1.0.18 gdbm>=1.14.1 libltdl>=2.2.6 gst-plugins1-base>=1.0.0 orc>=0.4.6 gstreamer1>=1.14.2 gstreamer1>=1.0.0 qt5-qtsensors>=5.9.1 qt5-qtsvg>=5.9.1 qt5-qtsvg>=5.11.1nb1 qt5-qtwebchannel>=5.9.1 qt5-qtwebsockets>=5.9.1 qt5-qtwebsockets>=5.11.1nb1 qt5-qtlocation>=5.11.1nb2 qt5-qtmultimedia>=5.11.1nb3 qt5-qtsensors>=5.11.1nb1 qt5-qtwebchannel>=5.11.1nb1 fltk>=1.3.0 glut>=3.4.2 glut>=7.11.2 desktop-file-utils>=0.8 hdf5>=1.8.11 qhull>=2015.1 hicolor-icon-theme>=0.9nb1 fftw>=3.1nb1 fftwf>=3.0.1nb1 curl>=7.61.0nb2 qt5-qttools>=5.11.1nb3 fltk>=1.3.3nb4 desktop-file-utils>=0.10nb1 .

This package requires the following package(s) to run: gnuplot>=3.7 pango>=1.6.0 Xft2>=2.1.7nb3 fontconfig>=2.2 libuuid>=2.18 freetype2>=2.8.1 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 fontconfig>=2.10.93 fontconfig>=2.1nb2 Xrender>=0.9.0nb2 Xrender>=0.2 Xrender>=0.8.2 fontconfig>=2.13.0 Xrender>=0.9.0nb1 Xft2>=2.1 Xft2>=2.1nb2 fontconfig>=2.11.91 Xrender>=0.8 fribidi>=0.19.7 fribidi>=0.19.1 glib2>=2.33.12 perl>=5.0 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 glib2>=2.4.0 harfbuzz>=0.9.9 icu>=3.4 icu>=62.1 glib2>=2.34.0 harfbuzz>=0.9.4 cairo>=1.12.10 MesaLib>=3.4.2 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 lzo>=2.01 fontconfig>=2.2.95 freetype2>=2.1.9 png>=1.2.4 pixman>=0.30.0 pixman>=0.25.2 MesaLib>=7.11.2 png>=1.6.0nb1 cairo>=1.0.0nb2 cairo-gobject>=1.10.2 cairo>=1.14.12nb1 glib2>=2.14.0 Xft2>=2.1.7nb7 harfbuzz>=1.4.2nb1 cairo-gobject>=1.14.12nb1 libcerf>=1.4 gd>=2.0.15nb1 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 libimagequant>=2.8.2 libwebp>=0.2.0 giflib>=5.1.0 tiff>=4.0.3nb5 libwebp>=0.6.0 pango>=1.42.1 gd>=2.2.5nb2 bsdtar-[0-9]* gmake>=3.81 hdf5>=1.8.7 qhull>=2003.1 libsndfile>=1.0.0 flac>=1.1.0nb1 libogg>=1.1 libogg>=1.1.2nb1 libogg>=1.1.3 libvorbis>=1.0.1 flac>=1.1.3nb1 libvorbis>=1.1.0nb1 readline>=2.2 hicolor-icon-theme>=0.4 arpack>=96 g95>=0.91 blas>=1.0nb2 fftw>=3.0 fftwf>=3.0 fftw>=3.2 lapack>=3.1.1 blas>=1.0nb3 curl>=7.12.3 libidn2>=2.0.0 libunistring>=0.9.3 libunistring>=0.9.4 qt5-qtbase>=5.9.1 pcre2>=10.21 dbus>=0.91 libproxy>=0.2.3 glu>=3.4.2 glu>=6.0 xcb-util>=0.3.9 xcb-util-image>=0.3.9 xcb-util-keysyms>=0.3.9 xcb-util-renderutil>=0.3.8nb1 xcb-util-wm>=0.3.9 xcursor>=1.0 Xfixes>=2.0.0 Xfixes>=2.0.1nb2 xcursor>=1.1.1 Xrandr>=0.99 Xrandr>=1.0.1 libxkbcommon>=0.4.0 libxcb>=1.10 pcre2>=10.30 libproxy>=0.4.11 glu>=7.11.2 xcursor>=1.1.2nb1 Xrandr>=1.0.2nb3 libxkbcommon>=0.4.0nb1 qt5-qttools>=5.9.1 xdg-utils-[0-9]* bash-[0-9]* gsed>=3.0.2 clang>=5.0 llvm-6.0.1{,nb*} libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 llvm>=4.0.1 qt5-qtdeclarative>=5.9.1 qt5-qtxmlpatterns>=5.9.1 qt5-qtbase>=5.11.1nb1 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 qt5-qtxmlpatterns>=5.11.1nb1 python27>=2.7.1nb2 qt5-qtlocation>=5.9.1 qt5-qtdeclarative>=5.11.1nb1 qt5-qtmultimedia>=5.9.1 openal-soft>=1.5.304 pulseaudio>=12.0 avahi>=0.6.23 gtk2+>=2.14.0 py27-expat-[0-9]* shared-mime-info>=0.15 atk>=1.30.0 glib2>=2.31.2 atk>=1.11.4 glib2>=2.28.0 gdk-pixbuf2>=2.22.0 glib2>=2.37.2 shared-mime-info>=1.0nb1 Xft2>=2.1.2nb2 libXi>=1.3.0 libXi>=1.0.0 libXcomposite>=0.3.1 pango>=1.20.0 cairo>=1.6.0 atk>=2.6.0 gdk-pixbuf2>=2.34.0nb1 gtk2+>=2.4.0 libdaemon>=0.14 libdaemon>=0.10 gtk2+>=2.24.32nb3 libXtst>=1.0.1 consolekit>=0.3.0 polkit>=0.103 spidermonkey52>=52.0.0 nspr>=4.9.3.2 dbus-glib>=0.61 glib2>=2.40 dbus>=1.8 dbus-glib>=0.100nb1 speexdsp>=1.2rc3 speex>=1.2rc2 speex>=1.2rc1 gdbm>=1.8.3 readline>=6.0 libltdl>=2.4.2 avahi>=0.6.32nb13 consolekit>=0.3.0nb9 libsndfile>=1.0.18 gdbm>=1.14.1 libltdl>=2.2.6 gst-plugins1-base>=1.0.0 orc>=0.4.6 gstreamer1>=1.14.2 gobject-introspection>=0.6.14nb1 py27-cElementTree-[0-9]* glib2>=2.54.0 libffi>=3.0.0 gobject-introspection>=1.34.0 gstreamer1>=1.0.0 qt5-qtsensors>=5.9.1 qt5-qtsvg>=5.9.1 qt5-qtsvg>=5.11.1nb1 qt5-qtwebchannel>=5.9.1 qt5-qtwebsockets>=5.9.1 qt5-qtwebsockets>=5.11.1nb1 qt5-qtlocation>=5.11.1nb2 qt5-qtmultimedia>=5.11.1nb3 qt5-qtsensors>=5.11.1nb1 qt5-qtwebchannel>=5.11.1nb1 fltk>=1.3.0 glut>=3.4.2 glut>=7.11.2 desktop-file-utils>=0.8 hdf5>=1.8.11 qhull>=2015.1 hicolor-icon-theme>=0.9nb1 fftw>=3.1nb1 fftwf>=3.0.1nb1 curl>=7.61.0nb2 qt5-qttools>=5.11.1nb3 fltk>=1.3.3nb4 desktop-file-utils>=0.10nb1 .

This package supports the following build-time options:

glpk
graphicsmagick
Use GraphicsMagick as imaging library.
hdf5
qhull

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
x86_64:octave-4.2.0nb10.tgz(NetBSD 8.99.1)
x86_64:octave-4.2.0nb12.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]