Daemon Power

The NetBSD Packages Collection: meta-pkgs/modular-xorg-libs

Brief description of the package:
Modular Xorg library meta-package

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://xorg.freedesktop.org/.

Please note that this package has a 2-clause-bsd license.

The package is located in the "meta-pkgs/modular-xorg-libs" directory. The current source version of the package is "modular-xorg-libs-1.5nb1". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for meta-pkgs/modular-xorg-libs :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: libFS>=1.0.0 xorgproto>=2016.1 cwrappers>=20150314 xtrans>=1.0.3 libWindowsWM>=1.0.1 x11-links>=1.12 osabi-NetBSD-8.0_RC1 libXScrnSaver>=1.1.2 libXTrap>=1.0.0 libXau>=1.0 libXaw3d>=1.6.2 xorg-util-macros>=1.17 libXcomposite>=0.3.1 Xfixes>=2.0.0 fixesproto>=3.0.0<5 Xfixes>=2.0.1nb2 xcursor>=1.0 Xrender>=0.8 Xrender>=0.2 Xrender>=0.8.2 Xrender>=0.9.0nb1 xcursor>=1.1.1 libXdamage>=1.0.3 libXdmcp>=0.99 libXevie>=1.0.2 evieext>=1.0.2 libXfont2>=2.0 freetype2>=2.4.5 freetype2>=2.1.3 libfontenc>=0.99 freetype2>=2.4.11 Xft2>=2.1 fontconfig>=2.2 libuuid>=2.18 freetype2>=2.8.1 gperf-[0-9]* fontconfig>=2.10.93 fontconfig>=2.1nb2 Xrender>=0.9.0nb2 fontconfig>=2.13.0 Xft2>=2.1nb2 libXp>=1.0.0 printproto>=1.0.3 libXpm>=3.5.4.2 libXprintAppUtil>=1.0.1 libXprintUtil>=1.0.1 xp-[0-9]* libXpresent>=1.0.0 Xrandr>=0.99 Xrandr>=1.0.1 Xrandr>=1.0.2nb3 libXres>=1.0.0 libXtst>=1.0.1 libXv>=1.0.1 libXvMC>=1.0.2 libdrm>=2.4.15 liblbxutil>=1.1.0nb1 xcursor>=1.1.2nb1 Xft2>=2.1.7nb7 .

This package requires the following package(s) to run: libFS>=1.0.0 libWindowsWM>=1.0.1 libXScrnSaver>=1.1.2 libXTrap>=1.0.0 libXau>=1.0 libXaw3d>=1.6.2 libXcomposite>=0.3.1 Xfixes>=2.0.0 Xfixes>=2.0.1nb2 xcursor>=1.0 Xrender>=0.8 Xrender>=0.2 Xrender>=0.8.2 Xrender>=0.9.0nb1 xcursor>=1.1.1 libXdamage>=1.0.3 libXdmcp>=0.99 libXevie>=1.0.2 libXfont2>=2.0 freetype2>=2.4.5 freetype2>=2.1.3 libfontenc>=0.99 freetype2>=2.4.11 Xft2>=2.1 fontconfig>=2.2 libuuid>=2.18 freetype2>=2.8.1 fontconfig>=2.10.93 fontconfig>=2.1nb2 Xrender>=0.9.0nb2 fontconfig>=2.13.0 Xft2>=2.1nb2 libXp>=1.0.0 libXpm>=3.5.4.2 libXprintAppUtil>=1.0.1 libXprintUtil>=1.0.1 libXpresent>=1.0.0 Xrandr>=0.99 Xrandr>=1.0.1 Xrandr>=1.0.2nb3 libXres>=1.0.0 libXtst>=1.0.1 libXv>=1.0.1 libXvMC>=1.0.2 libdrm>=2.4.15 liblbxutil>=1.1.0nb1 xcursor>=1.1.2nb1 Xft2>=2.1.7nb7 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:modular-xorg-libs-1.4.tgz(NetBSD 7.0)
alpha:modular-xorg-libs-1.5.tgz(NetBSD 8.0)
arm:modular-xorg-libs-1.1nb3.tgz(NetBSD 6.1_STABLE)
earmv6hf:modular-xorg-libs-1.4.tgz(NetBSD 8.0)
earmv7hfeb:modular-xorg-libs-1.5.tgz(NetBSD 8.0)
i386:modular-xorg-libs-1.4.tgz(NetBSD 6.0)
i386:modular-xorg-libs-1.4.tgz(NetBSD 7.0)
i386:modular-xorg-libs-1.4.tgz(NetBSD 7.0)
i386:modular-xorg-libs-1.4.tgz(NetBSD 7.0)
i386:modular-xorg-libs-1.5.tgz(NetBSD 7.0)
i386:modular-xorg-libs-1.5.tgz(NetBSD 7.1)
i386:modular-xorg-libs-1.5.tgz(NetBSD 8.0)
i386:modular-xorg-libs-1.0nb2.tgz(QNX 6.5.0)
sparc64:modular-xorg-libs-1.1nb3.tgz(NetBSD 7.0)
sparc64:modular-xorg-libs-1.2.tgz(NetBSD 7.0)
sparc64:modular-xorg-libs-1.5.tgz(NetBSD 8.0)
sparc:modular-xorg-libs-1.1nb3.tgz(NetBSD 6.0)
sparc:modular-xorg-libs-1.1nb3.tgz(NetBSD 6.0)
x86_64:modular-xorg-libs-1.4.tgz(NetBSD 7.0)
x86_64:modular-xorg-libs-1.5.tgz(NetBSD 7.0)
x86_64:modular-xorg-libs-1.4.tgz(NetBSD 7.0.1_PATCH)
x86_64:modular-xorg-libs-1.5.tgz(NetBSD 7.1.1)
x86_64:modular-xorg-libs-1.5.tgz(NetBSD 7.1)
x86_64:modular-xorg-libs-1.4.tgz(NetBSD 8.99.1)
x86_64:modular-xorg-libs-1.4.tgz(NetBSD 8.0)
x86_64:modular-xorg-libs-1.5.tgz(NetBSD 8.0)
x86_64:modular-xorg-libs-1.4.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]