Daemon Power

The NetBSD Packages Collection: meta-pkgs/php72-extensions

Brief description of the package:
"meta-package" for the PHP 7.2 HTML-embedded scripting language

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://www.php.net/.

The package is located in the "meta-pkgs/php72-extensions" directory. The current source version of the package is "php72-extensions-7.2.26". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for meta-pkgs/php72-extensions :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: php>=7.2.26<7.3 pcre>=3.4nb1 cwrappers>=20150314 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 openssl>=1.1.1 readline>=2.2 pcre>=8.30nb1 libxml2>=2.8.0nb2 openssl>=1.1.1dnb2 readline>=6.0 ap24-php72>=7.2.26<7.3 pcre2>=10.21 php>=7.3.0<7.3.99 pcre2>=10.30 apache>=2.4.7<2.5 apr>=1.5.0 apr-util>=1.5.3 apr-util>=1.2.8 nghttp2>=1.0.0 python37>=3.7 libffi>=1.20 libuuid>=2.18 openssl>=1.0.2 libffi>=3.0.11 python37>=3.7.0 brotli>=1.0.1 apr-util>=1.6.1nb6 nghttp2>=1.40.0nb2 apache>=2.4.41nb3 php72-fpm>=7.2.26<7.3 php72-bcmath>=7.2.26<7.3 php72-bz2>=7.2.26<7.3 php72-calendar>=7.2.26<7.3 php72-curl>=7.2.26<7.3 curl>=7.12.3 libidn2>=2.0.0 libunistring>=0.9.3 libunistring>=0.9.4 curl>=7.68.0nb2 php72-dba>=7.2.26<7.3 php72-enchant>=7.2.26 enchant>=1.2.4 hunspell-en_US-[0-9]* hunspell>=1.2.2 perl>=5.0 glib2>=2.4.0 meson-[0-9]* ninja-build-[0-9]* re2c>=0.11.3 py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7.6 hunspell>=1.7.0 glib2>=2.34.0 enchant>=1.1.3 enchant>=1.6.0nb5 php72-exif>=7.2.26<7.3 php72-ftp>=7.2.26<7.3 php72-gd>=7.2.26<7.3 gd>=2.0.15nb1 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 fontconfig>=2.11.91 freetype2>=2.8.1 freetype2>=2.1.3 fontconfig>=2.1nb2 libimagequant>=2.8.2 libwebp>=0.2.0 giflib>=5.2.1 png>=1.2.4 tiff>=4.0.3nb5 png>=1.6.0nb1 fontconfig>=2.13.0 libwebp>=0.6.0 gd>=2.2.5nb2 php72-gettext>=7.2.26<7.3 php72-gmp>=7.2.26<7.3 gmp>=4.2.1 gmp>=5.0.1 php72-iconv>=7.2.26<7.3 php72-recode>=7.2.26<7.3 recode>=3.6nb1 recode>=3.6nb5 php72-imap>=7.2.26<7.3 imap-uw>=2007dnb1 imap-uw>=2007fnb8 php72-intl>=7.2.26<7.3 icu>=3.4 icu>=64.1 php72-json>=7.2.26<7.3 php72-ldap>=7.2.26<7.3 openldap-client>=2.4.6 openldap-client>=2.4.48nb1 php72-mbstring>=7.2.26<7.3 php72-mysqli>=7.2.26<7.3 mysql-client>=5.7.12<5.8 editline>=3.0.20130712nb1 lz4>=1.7.3<100 boost-libs-1.72.* boost-jam-1.72.* libevent>=0.6 lz4>=1.7.3 boost-libs>=1.72.0 libevent>=2.1.11nb1 boost-headers-1.72.* mysql-client>=5.7.28nb2 php72-opcache>=7.2.26<7.3 php72-pcntl>=7.2.26<7.3 php72-pdo>=7.2.26<7.3 php72-pdo_dblib>=7.2.26<7.3 freetds>=0.63 libltdl>=2.4.2 libltdl>=2.2.6 freetds>=1.00 php73-pdo-7.* freetds>=1.00.112nb2 php73-pdo>=5.2.9 php72-pdo_mysql>=7.2.26<7.3 php72-sqlite3>=7.2.26<7.3 php72-pdo_pgsql>=7.2.26<7.3 postgresql95-client>=9.5.1 postgresql95-client>=9.5.20nb1 php72-pdo_sqlite>=7.2.26<7.3 php72-pgsql>=7.2.26<7.3 php72-posix>=7.2.26<7.3 php72-pspell>=7.2.26<7.3 aspell>=0.50.3 aspell>=0.60.6nb3 php72-shmop>=7.2.26<7.3 php72-snmp>=7.2.26<7.3 net-snmp>=5.0.9nb3 perl>=5.30.0 perl<5.32.0 osabi-NetBSD-8.0_STABLE net-snmp>=5.7.3nb13 php72-soap>=7.2.26<7.3 php72-sockets>=7.2.26<7.3 php72-sodium>=7.2.26<7.3 libsodium>=0.3 php72-sysvmsg>=7.2.26<7.3 php72-sysvsem>=7.2.26<7.3 php72-sysvshm>=7.2.26<7.3 php72-tidy>=7.2.26<7.3 tidy>=5.1.25<20000000 libxslt-[0-9]* libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 docbook-xml-[0-9]* docbook-xsl-[0-9]* docbook-xml>=4.2 php72-wddx>=7.2.26<7.3 php72-xmlrpc>=7.2.26<7.3 php72-xsl>=7.2.26<7.3 libxslt>=1.1.8 libxslt>=1.1.28nb2 php72-zip>=7.2.26<7.3 libzip>=0.7.1 libzip>=1.5.2nb3 php72-zlib>=7.2.26<7.3 .

This package requires the following package(s) to run: php>=7.2.26<7.3 pcre>=3.4nb1 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 openssl>=1.1.1 readline>=2.2 pcre>=8.30nb1 libxml2>=2.8.0nb2 openssl>=1.1.1dnb2 readline>=6.0 ap24-php72>=7.2.26<7.3 pcre2>=10.21 php>=7.3.0<7.3.99 pcre2>=10.30 apache>=2.4.7<2.5 apr>=1.5.0 apr-util>=1.5.3 apr-util>=1.2.8 nghttp2>=1.0.0 python37>=3.7 libffi>=1.20 libuuid>=2.18 openssl>=1.0.2 libffi>=3.0.11 python37>=3.7.0 brotli>=1.0.1 apr-util>=1.6.1nb6 nghttp2>=1.40.0nb2 apache>=2.4.41nb3 php72-fpm>=7.2.26<7.3 php72-bcmath>=7.2.26<7.3 php72-bz2>=7.2.26<7.3 php72-calendar>=7.2.26<7.3 php72-curl>=7.2.26<7.3 curl>=7.12.3 libidn2>=2.0.0 libunistring>=0.9.3 libunistring>=0.9.4 curl>=7.68.0nb2 php72-dba>=7.2.26<7.3 php72-enchant>=7.2.26 enchant>=1.2.4 hunspell-en_US-[0-9]* hunspell>=1.2.2 perl>=5.0 glib2>=2.4.0 hunspell>=1.7.0 glib2>=2.34.0 enchant>=1.1.3 enchant>=1.6.0nb5 php72-exif>=7.2.26<7.3 php72-ftp>=7.2.26<7.3 php72-gd>=7.2.26<7.3 gd>=2.0.15nb1 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 fontconfig>=2.11.91 freetype2>=2.8.1 freetype2>=2.1.3 fontconfig>=2.1nb2 libimagequant>=2.8.2 libwebp>=0.2.0 giflib>=5.2.1 png>=1.2.4 tiff>=4.0.3nb5 png>=1.6.0nb1 fontconfig>=2.13.0 libwebp>=0.6.0 gd>=2.2.5nb2 php72-gettext>=7.2.26<7.3 php72-gmp>=7.2.26<7.3 gmp>=4.2.1 gmp>=5.0.1 php72-iconv>=7.2.26<7.3 php72-recode>=7.2.26<7.3 recode>=3.6nb1 recode>=3.6nb5 php72-imap>=7.2.26<7.3 imap-uw>=2007dnb1 imap-uw>=2007fnb8 php72-intl>=7.2.26<7.3 icu>=3.4 icu>=64.1 php72-json>=7.2.26<7.3 php72-ldap>=7.2.26<7.3 openldap-client>=2.4.6 openldap-client>=2.4.48nb1 php72-mbstring>=7.2.26<7.3 php72-mysqli>=7.2.26<7.3 mysql-client>=5.7.12<5.8 editline>=3.0.20130712nb1 lz4>=1.7.3<100 boost-libs-1.72.* libevent>=0.6 lz4>=1.7.3 boost-libs>=1.72.0 libevent>=2.1.11nb1 mysql-client>=5.7.28nb2 php72-opcache>=7.2.26<7.3 php72-pcntl>=7.2.26<7.3 php72-pdo>=7.2.26<7.3 php72-pdo_dblib>=7.2.26<7.3 freetds>=0.63 libltdl>=2.4.2 libltdl>=2.2.6 freetds>=1.00 php73-pdo-7.* freetds>=1.00.112nb2 php73-pdo>=5.2.9 php72-pdo_mysql>=7.2.26<7.3 php72-sqlite3>=7.2.26<7.3 php72-pdo_pgsql>=7.2.26<7.3 postgresql95-client>=9.5.1 postgresql95-client>=9.5.20nb1 php72-pdo_sqlite>=7.2.26<7.3 php72-pgsql>=7.2.26<7.3 php72-posix>=7.2.26<7.3 php72-pspell>=7.2.26<7.3 aspell>=0.50.3 aspell>=0.60.6nb3 php72-shmop>=7.2.26<7.3 php72-snmp>=7.2.26<7.3 net-snmp>=5.0.9nb3 perl>=5.30.0 perl<5.32.0 osabi-NetBSD-8.0_STABLE net-snmp>=5.7.3nb13 php72-soap>=7.2.26<7.3 php72-sockets>=7.2.26<7.3 php72-sodium>=7.2.26<7.3 libsodium>=0.3 php72-sysvmsg>=7.2.26<7.3 php72-sysvsem>=7.2.26<7.3 php72-sysvshm>=7.2.26<7.3 php72-tidy>=7.2.26<7.3 tidy>=5.1.25<20000000 php72-wddx>=7.2.26<7.3 php72-xmlrpc>=7.2.26<7.3 php72-xsl>=7.2.26<7.3 libxslt>=1.1.8 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 libxslt>=1.1.28nb2 php72-zip>=7.2.26<7.3 libzip>=0.7.1 libzip>=1.5.2nb3 php72-zlib>=7.2.26<7.3 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
earmv6hf:php72-extensions-7.2.26.tgz(NetBSD 8.0)
earmv6hf:php72-extensions-7.2.24.tgz(NetBSD 8.0)
earmv7hf:php72-extensions-7.2.26.tgz(NetBSD 8.0)
earmv7hf:php72-extensions-7.2.24.tgz(NetBSD 8.0)
i386:php72-extensions-7.2.26.tgz(NetBSD 7.0)
i386:php72-extensions-7.2.19.tgz(NetBSD 7.0)
i386:php72-extensions-7.2.22.tgz(NetBSD 7.0)
i386:php72-extensions-7.2.24.tgz(NetBSD 7.0)
i386:php72-extensions-7.2.19.tgz(NetBSD 7.1)
i386:php72-extensions-7.2.22.tgz(NetBSD 7.1)
i386:php72-extensions-7.2.24.tgz(NetBSD 7.1)
i386:php72-extensions-7.2.26.tgz(NetBSD 7.1)
i386:php72-extensions-7.2.19.tgz(NetBSD 8.0)
i386:php72-extensions-7.2.22.tgz(NetBSD 8.0)
i386:php72-extensions-7.2.24.tgz(NetBSD 8.0)
i386:php72-extensions-7.2.26.tgz(NetBSD 8.0)
sparc64:php72-extensions-7.2.22.tgz(NetBSD 8.0)
x86_64:php72-extensions-7.2.26.tgz(NetBSD 7.0)
x86_64:php72-extensions-7.2.19.tgz(NetBSD 7.0)
x86_64:php72-extensions-7.2.22.tgz(NetBSD 7.0)
x86_64:php72-extensions-7.2.24.tgz(NetBSD 7.0)
x86_64:php72-extensions-7.2.26.tgz(NetBSD 7.1)
x86_64:php72-extensions-7.2.19.tgz(NetBSD 7.1)
x86_64:php72-extensions-7.2.22.tgz(NetBSD 7.1)
x86_64:php72-extensions-7.2.24.tgz(NetBSD 7.1)
x86_64:php72-extensions-7.2.26.tgz(NetBSD 8.0)
x86_64:php72-extensions-7.2.19.tgz(NetBSD 8.0)
x86_64:php72-extensions-7.2.22.tgz(NetBSD 8.0)
x86_64:php72-extensions-7.2.24.tgz(NetBSD 8.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]