misc/ruby-gem_plugin - The NetBSD Packages Collection

Gem-based plugin system

GemPlugin is a system that lets your users install gems and lets you
load them as additional features to use in your software.  It
originated from the Mongrel (mongrel.rubyforge.org) project but proved
useful enough to break out into a separate project.

GemPlugin works by listing the gems installed, and doing a require_gem
on any that have the right dependencies.  For example, if a gem
depends on "gem_plugin" and "mongrel" then it will load as a Mongrel
plugin.  This makes it so that users of the plugins only need to gem
install (and maybe config a bit), and plugin authors only need to make
gems.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/ruby26-base

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfruby25-gem_plugin-0.2.3.tgz
NetBSD 8.0earmv7hfruby26-gem_plugin-0.2.3.tgz
NetBSD 8.0earmv7hfruby27-gem_plugin-0.2.3.tgz
NetBSD 8.0earmv7hfruby25-gem_plugin-0.2.3.tgz
NetBSD 8.0earmv7hfruby26-gem_plugin-0.2.3.tgz
NetBSD 8.0earmv7hfruby27-gem_plugin-0.2.3.tgz
NetBSD 8.0earmv7hfruby25-gem_plugin-0.2.3.tgz
NetBSD 8.0earmv7hfruby26-gem_plugin-0.2.3.tgz
NetBSD 8.0earmv7hfruby27-gem_plugin-0.2.3.tgz
NetBSD 8.0i386ruby25-gem_plugin-0.2.3.tgz
NetBSD 8.0i386ruby26-gem_plugin-0.2.3.tgz
NetBSD 8.0i386ruby27-gem_plugin-0.2.3.tgz
NetBSD 8.0i386ruby25-gem_plugin-0.2.3.tgz
NetBSD 8.0i386ruby26-gem_plugin-0.2.3.tgz
NetBSD 8.0i386ruby27-gem_plugin-0.2.3.tgz
NetBSD 8.0i386ruby25-gem_plugin-0.2.3.tgz
NetBSD 8.0i386ruby26-gem_plugin-0.2.3.tgz
NetBSD 8.0i386ruby27-gem_plugin-0.2.3.tgz
NetBSD 8.0powerpcruby24-gem_plugin-0.2.3.tgz
NetBSD 8.0powerpcruby25-gem_plugin-0.2.3.tgz
NetBSD 8.0powerpcruby26-gem_plugin-0.2.3.tgz
NetBSD 8.0powerpcruby27-gem_plugin-0.2.3.tgz
NetBSD 8.0powerpcruby24-gem_plugin-0.2.3.tgz
NetBSD 8.0powerpcruby25-gem_plugin-0.2.3.tgz
NetBSD 8.0powerpcruby26-gem_plugin-0.2.3.tgz
NetBSD 8.0powerpcruby27-gem_plugin-0.2.3.tgz
NetBSD 8.0powerpcruby24-gem_plugin-0.2.3.tgz
NetBSD 8.0powerpcruby25-gem_plugin-0.2.3.tgz
NetBSD 8.0powerpcruby26-gem_plugin-0.2.3.tgz
NetBSD 8.0powerpcruby27-gem_plugin-0.2.3.tgz
NetBSD 8.0x86_64ruby25-gem_plugin-0.2.3.tgz
NetBSD 8.0x86_64ruby26-gem_plugin-0.2.3.tgz
NetBSD 8.0x86_64ruby27-gem_plugin-0.2.3.tgz
NetBSD 8.0x86_64ruby25-gem_plugin-0.2.3.tgz
NetBSD 8.0x86_64ruby26-gem_plugin-0.2.3.tgz
NetBSD 8.0x86_64ruby27-gem_plugin-0.2.3.tgz
NetBSD 8.0x86_64ruby25-gem_plugin-0.2.3.tgz
NetBSD 8.0x86_64ruby26-gem_plugin-0.2.3.tgz
NetBSD 8.0x86_64ruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0aarch64ruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0aarch64ruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0aarch64ruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0aarch64ruby30-gem_plugin-0.2.3.tgz
NetBSD 9.0aarch64ruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0aarch64ruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0aarch64ruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0aarch64ruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0aarch64ruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0aarch64ruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0alpharuby25-gem_plugin-0.2.3.tgz
NetBSD 9.0alpharuby26-gem_plugin-0.2.3.tgz
NetBSD 9.0alpharuby27-gem_plugin-0.2.3.tgz
NetBSD 9.0alpharuby25-gem_plugin-0.2.3.tgz
NetBSD 9.0alpharuby26-gem_plugin-0.2.3.tgz
NetBSD 9.0alpharuby27-gem_plugin-0.2.3.tgz
NetBSD 9.0alpharuby25-gem_plugin-0.2.3.tgz
NetBSD 9.0alpharuby26-gem_plugin-0.2.3.tgz
NetBSD 9.0alpharuby27-gem_plugin-0.2.3.tgz
NetBSD 9.0earmruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0earmruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0earmruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0earmruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0earmruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0earmruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0earmruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0earmruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0earmv6hfruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0earmv6hfruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0earmv6hfruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0earmv6hfruby30-gem_plugin-0.2.3.tgz
NetBSD 9.0earmv6hfruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0earmv6hfruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0earmv6hfruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0earmv6hfruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0earmv6hfruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0earmv6hfruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0earmv6hfruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0earmv6hfruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0earmv6hfruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0earmv7hfruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0earmv7hfruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0earmv7hfruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0earmv7hfruby30-gem_plugin-0.2.3.tgz
NetBSD 9.0earmv7hfruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0earmv7hfruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0earmv7hfruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0earmv7hfruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0earmv7hfruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0earmv7hfruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0earmv7hfruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0earmv7hfruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0earmv7hfruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0i386ruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0i386ruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0i386ruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0i386ruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0i386ruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0i386ruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0i386ruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0i386ruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0i386ruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0i386ruby30-gem_plugin-0.2.3.tgz
NetBSD 9.0mips64ebruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0mips64ebruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0mips64ebruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0mips64ebruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0mips64ebruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0mips64ebruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0mips64ebruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0mips64ebruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0mips64ebruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0mipselruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0mipselruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0mipselruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0mipselruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0powerpcruby24-gem_plugin-0.2.3.tgz
NetBSD 9.0powerpcruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0powerpcruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0powerpcruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0powerpcruby24-gem_plugin-0.2.3.tgz
NetBSD 9.0powerpcruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0powerpcruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0powerpcruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0sh3elruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0sh3elruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0sparc64ruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0sparc64ruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0sparc64ruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0sparc64ruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0sparc64ruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0sparc64ruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0sparc64ruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0sparc64ruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0sparc64ruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0sparc64ruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0sparc64ruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0sparc64ruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0sparcruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0sparcruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0sparcruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0sparcruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0sparcruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0sparcruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0vaxruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0vaxruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0vaxruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0vaxruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0x86_64ruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0x86_64ruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0x86_64ruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0x86_64ruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0x86_64ruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0x86_64ruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0x86_64ruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0x86_64ruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0x86_64ruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0x86_64ruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0x86_64ruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0x86_64ruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0x86_64ruby30-gem_plugin-0.2.3.tgz
NetBSD 9.0x86_64ruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0x86_64ruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0x86_64ruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0x86_64ruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0x86_64ruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0x86_64ruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0x86_64ruby25-gem_plugin-0.2.3.tgz
NetBSD 9.0x86_64ruby26-gem_plugin-0.2.3.tgz
NetBSD 9.0x86_64ruby27-gem_plugin-0.2.3.tgz
NetBSD 9.0x86_64ruby30-gem_plugin-0.2.3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.