net/ORBit2 - The NetBSD Packages Collection

High-performance CORBA ORB with C language support

  ORBit is a CORBA 2.2-compliant Object Request Broker (ORB) featuring
mature C and Perl bindings.  Bindings (in various degrees of completeness)
are also available for C++, Lisp, Pascal, Python, Ruby, and TCL; others
are in-progress.  It supports POA, DII, DSI, TypeCode, Any, IR and IIOP.

  Optional features including INS and threading are available.  ORBit is
engineered for the desktop workstation environment, with a focus on
performance, low resource usage, and security.

  The core ORB is written in C, and runs under Linux, UNIX (BSD, Solaris,
HP-UX, ...), and Windows.  ORBit is developed and released as open source
software under GPL/LGPL.

Build dependencies

pkgtools/cwrappers devel/glib2-tools devel/libtool-base devel/gmake devel/pkgconf

Runtime dependencies

devel/glib2 devel/glib2 net/libIDL devel/glib2 net/libIDL

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfORBit2-2.14.19nb5.tgz
NetBSD 8.0earmv7hfORBit2-2.14.19nb5.tgz
NetBSD 8.0earmv7hfORBit2-2.14.19nb5.tgz
NetBSD 8.0i386ORBit2-2.14.19nb5.tgz
NetBSD 8.0i386ORBit2-2.14.19nb5.tgz
NetBSD 8.0i386ORBit2-2.14.19nb5.tgz
NetBSD 8.0powerpcORBit2-2.14.19nb5.tgz
NetBSD 8.0powerpcORBit2-2.14.19nb5.tgz
NetBSD 8.0powerpcORBit2-2.14.19nb5.tgz
NetBSD 8.0x86_64ORBit2-2.14.19nb5.tgz
NetBSD 8.0x86_64ORBit2-2.14.19nb5.tgz
NetBSD 8.0x86_64ORBit2-2.14.19nb5.tgz
NetBSD 9.0aarch64ORBit2-2.14.19nb5.tgz
NetBSD 9.0aarch64ORBit2-2.14.19nb5.tgz
NetBSD 9.0aarch64ORBit2-2.14.19nb5.tgz
NetBSD 9.0alphaORBit2-2.14.19nb5.tgz
NetBSD 9.0alphaORBit2-2.14.19nb5.tgz
NetBSD 9.0alphaORBit2-2.14.19nb5.tgz
NetBSD 9.0earmORBit2-2.14.19nb5.tgz
NetBSD 9.0earmORBit2-2.14.19nb5.tgz
NetBSD 9.0earmORBit2-2.14.19nb5.tgz
NetBSD 9.0earmv6hfORBit2-2.14.19nb5.tgz
NetBSD 9.0earmv6hfORBit2-2.14.19nb5.tgz
NetBSD 9.0earmv6hfORBit2-2.14.19nb5.tgz
NetBSD 9.0earmv6hfORBit2-2.14.19nb5.tgz
NetBSD 9.0earmv7hfORBit2-2.14.19nb5.tgz
NetBSD 9.0earmv7hfORBit2-2.14.19nb5.tgz
NetBSD 9.0earmv7hfORBit2-2.14.19nb5.tgz
NetBSD 9.0earmv7hfORBit2-2.14.19nb5.tgz
NetBSD 9.0i386ORBit2-2.14.19nb5.tgz
NetBSD 9.0i386ORBit2-2.14.19nb5.tgz
NetBSD 9.0i386ORBit2-2.14.19nb5.tgz
NetBSD 9.0m68kORBit2-2.14.19nb5.tgz
NetBSD 9.0m68kORBit2-2.14.19nb5.tgz
NetBSD 9.0m68kORBit2-2.14.19nb5.tgz
NetBSD 9.0mips64ebORBit2-2.14.19nb5.tgz
NetBSD 9.0mips64ebORBit2-2.14.19nb5.tgz
NetBSD 9.0mips64ebORBit2-2.14.19nb5.tgz
NetBSD 9.0mipselORBit2-2.14.19nb5.tgz
NetBSD 9.0mipselORBit2-2.14.19nb5.tgz
NetBSD 9.0powerpcORBit2-2.14.19nb5.tgz
NetBSD 9.0powerpcORBit2-2.14.19nb5.tgz
NetBSD 9.0sh3elORBit2-2.14.19nb5.tgz
NetBSD 9.0sh3elORBit2-2.14.19nb5.tgz
NetBSD 9.0sh3elORBit2-2.14.19nb5.tgz
NetBSD 9.0sparc64ORBit2-2.14.19nb5.tgz
NetBSD 9.0sparc64ORBit2-2.14.19nb5.tgz
NetBSD 9.0sparc64ORBit2-2.14.19nb5.tgz
NetBSD 9.0sparc64ORBit2-2.14.19nb5.tgz
NetBSD 9.0sparcORBit2-2.14.19nb5.tgz
NetBSD 9.0sparcORBit2-2.14.19nb5.tgz
NetBSD 9.0sparcORBit2-2.14.19nb5.tgz
NetBSD 9.0x86_64ORBit2-2.14.19nb5.tgz
NetBSD 9.0x86_64ORBit2-2.14.19nb5.tgz
NetBSD 9.0x86_64ORBit2-2.14.19nb5.tgz
NetBSD 9.0x86_64ORBit2-2.14.19nb5.tgz
NetBSD 9.0x86_64ORBit2-2.14.19nb5.tgz
NetBSD 9.0x86_64ORBit2-2.14.19nb5.tgz
NetBSD 9.0x86_64ORBit2-2.14.19nb5.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

inet6
Enable support for IPv6.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.