net/libdlna - The NetBSD Packages Collection

Reference DLNA open-source implementation

libdlna aims at being the reference open-source implementation of DLNA (Digital
Living Network Alliance) standards. Its primary goal is to provide DLNA support
to uShare, an embedded DLNA & UPnP A/V Media Server, but it will be used to
build both DLNA servers and players in the long term.

libdlna is written in C and relies on FFMPEG librairies (libavformat and
libavcodec) to handle and demux A/V streams. You still need libupnp to provide
basic UPnP support to your project.

libdlna is based on official DLNA specifications and aims at a providing a
complete respect of the defined standards. Right now, libdlna can be used to
build compliant DLNA Media Servers.

libdlna is free software - it is licensed under the terms of the GNU Lesser
General Public License (LGPL).

Build dependencies

pkgtools/x11-links pkgtools/cwrappers devel/gmake

Runtime dependencies

multimedia/ffmpeg4 multimedia/ffmpeg4

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibdlna-0.2.4nb10.tgz
NetBSD 8.0earmv7hflibdlna-0.2.4nb10.tgz
NetBSD 8.0i386libdlna-0.2.4nb10.tgz
NetBSD 8.0i386libdlna-0.2.4nb10.tgz
NetBSD 8.0i386libdlna-0.2.4nb10.tgz
NetBSD 8.0powerpclibdlna-0.2.4nb10.tgz
NetBSD 8.0powerpclibdlna-0.2.4nb10.tgz
NetBSD 8.0powerpclibdlna-0.2.4nb10.tgz
NetBSD 8.0x86_64libdlna-0.2.4nb10.tgz
NetBSD 8.0x86_64libdlna-0.2.4nb10.tgz
NetBSD 8.0x86_64libdlna-0.2.4nb10.tgz
NetBSD 9.0aarch64libdlna-0.2.4nb10.tgz
NetBSD 9.0aarch64libdlna-0.2.4nb10.tgz
NetBSD 9.0aarch64libdlna-0.2.4nb10.tgz
NetBSD 9.0alphalibdlna-0.2.4nb10.tgz
NetBSD 9.0alphalibdlna-0.2.4nb10.tgz
NetBSD 9.0earmv6hflibdlna-0.2.4nb10.tgz
NetBSD 9.0earmv6hflibdlna-0.2.4nb10.tgz
NetBSD 9.0earmv6hflibdlna-0.2.4nb10.tgz
NetBSD 9.0earmv6hflibdlna-0.2.4nb10.tgz
NetBSD 9.0earmv7hflibdlna-0.2.4nb10.tgz
NetBSD 9.0earmv7hflibdlna-0.2.4nb10.tgz
NetBSD 9.0earmv7hflibdlna-0.2.4nb10.tgz
NetBSD 9.0earmv7hflibdlna-0.2.4nb10.tgz
NetBSD 9.0i386libdlna-0.2.4nb10.tgz
NetBSD 9.0i386libdlna-0.2.4nb10.tgz
NetBSD 9.0i386libdlna-0.2.4nb10.tgz
NetBSD 9.0powerpclibdlna-0.2.4nb10.tgz
NetBSD 9.0powerpclibdlna-0.2.4nb10.tgz
NetBSD 9.0sparc64libdlna-0.2.4nb10.tgz
NetBSD 9.0sparc64libdlna-0.2.4nb9.tgz
NetBSD 9.0sparc64libdlna-0.2.4nb10.tgz
NetBSD 9.0sparc64libdlna-0.2.4nb10.tgz
NetBSD 9.0sparclibdlna-0.2.4nb10.tgz
NetBSD 9.0sparclibdlna-0.2.4nb10.tgz
NetBSD 9.0sparclibdlna-0.2.4nb10.tgz
NetBSD 9.0x86_64libdlna-0.2.4nb10.tgz
NetBSD 9.0x86_64libdlna-0.2.4nb10.tgz
NetBSD 9.0x86_64libdlna-0.2.4nb10.tgz
NetBSD 9.0x86_64libdlna-0.2.4nb10.tgz
NetBSD 9.0x86_64libdlna-0.2.4nb10.tgz
NetBSD 9.0x86_64libdlna-0.2.4nb10.tgz
NetBSD 9.0x86_64libdlna-0.2.4nb10.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.