Daemon Power

The NetBSD Packages Collection: net/netdisco

Brief description of the package:
Open Source web-based network management tool

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://www.netdisco.org/.

Please note that this package has a modified-bsd license.

The package is located in the "net/netdisco" directory. The current source version of the package is "netdisco-1.3.3nb3". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for net/netdisco :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: p5-CGI-[0-9]* p5-HTML-Parser-[0-9]* p5-HTML-Tagset>=3.0 perl>=5.28.0 cwrappers>=20150314 perl<5.30.0 p5-URI-[0-9]* p5-Test-Needs-[0-9]* p5-SNMP-Info>=2.04 net-snmp>=5.1.2 osabi-NetBSD-8.0_RC2 p5-NetAddr-IP>=4.068 p5-Test-Pod-[0-9]* p5-Module-Build>=0.42050 p5-inc-latest-[0-9]* p5-CPAN-Meta>=2.142060 p5-Scalar-List-Utils>=1.33 p5-Apache-DBI-[0-9]* p5-Digest-SHA1>=2.01 p5-DBI>=1.612 p5-DBI>=1.641nb1 p5-Apache-Session-[0-9]* p5-Test-Deep>=0.082 p5-Test-Simple>=1.001010 p5-Test-Exception>=0.15 p5-Sub-Uplevel>=0.18 p5-DBD-postgresql-[0-9]* p5-DBI>=1.614 postgresql95-client>=9.5.1 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 postgresql95-client>=9.5.1nb1 p5-MasonX-Request-WithApacheSession-[0-9]* p5-Apache-Session-Wrapper>=0.13 p5-Class-Container-[0-9]* p5-Params-Validate>=0.23 p5-Module-Implementation-[0-9]* p5-Module-Runtime>=0.12 p5-Try-Tiny-[0-9]* p5-Capture-Tiny>=0.12 p5-Test-Fatal>=0.006 p5-Try-Tiny>=0.07 p5-Test-Requires-[0-9]* p5-File-Slurp-[0-9]* p5-Test-Fatal-[0-9]* p5-Exception-Class-[0-9]* p5-Class-Data-Inheritable>=0.02 p5-Devel-StackTrace>=1.20 p5-Apache-Session>=1.6 p5-HTML-Mason>=1.16 p5-Cache-Cache>=1 p5-Error>=0.15 p5-Digest-SHA1>=2.02 p5-IPC-ShareLite>=0.09 p5-Class-Container>=0.07 p5-Exception-Class>=1.15 p5-Log-Any>=0.08 p5-Params-Validate>=0.70 p5-Test-Deep-[0-9]* apache>=2.4.7<2.5 apr>=1.5.0 apr-util>=1.5.3 apr-util>=1.2.8 pcre>=3.4nb1 nghttp2>=1.0.0 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 readline>=2.2 readline>=6.0 python27>=2.7.1nb2 apr-util>=1.5.4nb4 pcre>=8.30nb1 nghttp2>=1.32.0nb1 apache>=2.4.34nb2 p5-Graph-[0-9]* p5-GraphViz-[0-9]* p5-IPC-Run>=0.6 p5-IO-tty>=1.08 graphviz-[0-9]* gd>=2.0.15nb1 perl>=5.0 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 fontconfig>=2.10.93 libuuid>=2.18 freetype2>=2.8.1 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 gperf-[0-9]* fontconfig>=2.1nb2 libimagequant>=2.8.2 libwebp>=0.2.0 giflib>=5.1.0 png>=1.2.4 tiff>=4.0.3nb5 png>=1.6.0nb1 fontconfig>=2.13.0 libwebp>=0.6.0 gtk2+>=2.4.0 py27-expat-[0-9]* shared-mime-info>=0.15 glib2>=2.4.0 libelf>=0.8.5 pcre>=8.31 glib2>=2.34.0 atk>=1.30.0 glib2>=2.31.2 gobject-introspection>=0.6.14nb1 py27-cElementTree-[0-9]* glib2>=2.54.0 libffi>=3.0.0 gobject-introspection>=1.34.0 atk>=1.11.4 glib2>=2.28.0 gdk-pixbuf2>=2.22.0 glib2>=2.37.2 shared-mime-info>=1.0nb1 xcursor>=1.0 Xfixes>=2.0.0 x11-links>=1.12 fixesproto>=3.0.0<5 xorgproto>=2016.1 Xrender>=0.8 Xrender>=0.2 Xrender>=0.8.2 Xfixes>=2.0.1nb2 Xrender>=0.9.0nb1 xcursor>=1.1.1 Xft2>=2.1.2nb2 fontconfig>=2.2 Xrender>=0.9.0nb2 Xft2>=2.1 Xft2>=2.1nb2 libXi>=1.3.0 libXi>=1.0.0 Xrandr>=0.99 Xrandr>=1.0.1 libXcomposite>=0.3.1 pango>=1.20.0 Xft2>=2.1.7nb3 fontconfig>=2.11.91 fribidi>=0.19.7 fribidi>=0.19.1 glib2>=2.33.12 harfbuzz>=0.9.9 icu>=3.4 icu>=62.1 harfbuzz>=0.9.4 cairo>=1.12.10 MesaLib>=3.4.2 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 xcb-proto>=1.13 xcb-proto>=1.4 py27-mako-[0-9]* py27-setuptools>=0.8 lzo>=2.01 fontconfig>=2.2.95 freetype2>=2.1.9 pixman>=0.30.0 pixman>=0.25.2 MesaLib>=7.11.2 cairo>=1.0.0nb2 cairo-gobject>=1.10.2 cairo>=1.14.12nb1 glib2>=2.14.0 Xft2>=2.1.7nb7 harfbuzz>=1.4.2nb1 cairo-gobject>=1.14.12nb1 help2man-[0-9]* p5-gettext>=1.01 pango>=1.6.0 cairo>=1.6.0 atk>=2.6.0 gdk-pixbuf2>=2.34.0nb1 xcursor>=1.1.2nb1 Xrandr>=1.0.2nb3 pango>=1.42.1 gobject-introspection>=0.9.3 lua52>=5.2.0<5.3 tk>=8.5.7 tcl>=8.5.7 sqlite3>=3.21.0 sqlite3>=3.0.8 sqlite3>=3.24.0nb1 tcl>=8.6.1nb1 libltdl>=2.4.2 gts>=0.7.6 netpbm>=10.11.6 jasper>=1.600.0 jasper>=1.900.1nb7 netpbm>=10.35.80nb6 gd>=2.2.5nb2 gtk2+>=2.24.32nb3 tk>=8.6.8nb1 libltdl>=2.2.6 swig>=1.3.24<2.0 swig>=1.3.31<2.0 p5-File-Which-[0-9]* p5-Net-NBName-[0-9]* p5-ap24-libapreq2-[0-9]* p5-ExtUtils-XSBuilder>=0.23 p5-Parse-RecDescent-[0-9]* p5-Text-Balanced-[0-9]* p5-Tie-IxHash-[0-9]* ap24-perl>=2.0.1 ap24-perl>=2.0.10nb2 apache>=2.0.48 p5-Parallel-ForkManager-[0-9]* p5-Test-Warn-[0-9]* p5-Sub-Uplevel>=0.12 .

This package requires the following package(s) to run: p5-CGI-[0-9]* p5-HTML-Parser-[0-9]* p5-HTML-Tagset>=3.0 perl>=5.28.0 perl<5.30.0 p5-URI-[0-9]* p5-SNMP-Info>=2.04 net-snmp>=5.1.2 osabi-NetBSD-8.0_RC2 p5-NetAddr-IP>=4.068 p5-Apache-DBI-[0-9]* p5-Digest-SHA1>=2.01 p5-DBI>=1.612 p5-DBI>=1.641nb1 p5-Apache-Session-[0-9]* p5-Test-Deep>=0.082 p5-Test-Simple>=1.001010 p5-Test-Exception>=0.15 p5-Sub-Uplevel>=0.18 p5-DBD-postgresql-[0-9]* p5-DBI>=1.614 postgresql95-client>=9.5.1 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 postgresql95-client>=9.5.1nb1 p5-MasonX-Request-WithApacheSession-[0-9]* p5-Apache-Session-Wrapper>=0.13 p5-Class-Container-[0-9]* p5-Params-Validate>=0.23 p5-Module-Implementation-[0-9]* p5-Module-Runtime>=0.12 p5-Try-Tiny-[0-9]* p5-Exception-Class-[0-9]* p5-Class-Data-Inheritable>=0.02 p5-Devel-StackTrace>=1.20 p5-Apache-Session>=1.6 p5-HTML-Mason>=1.16 p5-Cache-Cache>=1 p5-Error>=0.15 p5-Digest-SHA1>=2.02 p5-IPC-ShareLite>=0.09 p5-Class-Container>=0.07 p5-Exception-Class>=1.15 p5-Log-Any>=0.08 p5-Params-Validate>=0.70 p5-Graph-[0-9]* p5-GraphViz-[0-9]* p5-IPC-Run>=0.6 p5-IO-tty>=1.08 graphviz-[0-9]* gd>=2.0.15nb1 perl>=5.0 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 fontconfig>=2.10.93 libuuid>=2.18 freetype2>=2.8.1 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 fontconfig>=2.1nb2 libimagequant>=2.8.2 libwebp>=0.2.0 giflib>=5.1.0 png>=1.2.4 tiff>=4.0.3nb5 png>=1.6.0nb1 fontconfig>=2.13.0 libwebp>=0.6.0 gtk2+>=2.4.0 py27-expat-[0-9]* python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 python27>=2.7.1nb2 shared-mime-info>=0.15 glib2>=2.4.0 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 pcre>=8.30nb1 glib2>=2.34.0 atk>=1.30.0 glib2>=2.31.2 atk>=1.11.4 glib2>=2.28.0 gdk-pixbuf2>=2.22.0 glib2>=2.37.2 shared-mime-info>=1.0nb1 xcursor>=1.0 Xfixes>=2.0.0 Xrender>=0.8 Xrender>=0.2 Xrender>=0.8.2 Xfixes>=2.0.1nb2 Xrender>=0.9.0nb1 xcursor>=1.1.1 Xft2>=2.1.2nb2 fontconfig>=2.2 Xrender>=0.9.0nb2 Xft2>=2.1 Xft2>=2.1nb2 libXi>=1.3.0 libXi>=1.0.0 Xrandr>=0.99 Xrandr>=1.0.1 libXcomposite>=0.3.1 pango>=1.20.0 Xft2>=2.1.7nb3 fontconfig>=2.11.91 fribidi>=0.19.7 fribidi>=0.19.1 glib2>=2.33.12 harfbuzz>=0.9.9 icu>=3.4 icu>=62.1 harfbuzz>=0.9.4 cairo>=1.12.10 MesaLib>=3.4.2 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 lzo>=2.01 fontconfig>=2.2.95 freetype2>=2.1.9 pixman>=0.30.0 pixman>=0.25.2 MesaLib>=7.11.2 cairo>=1.0.0nb2 cairo-gobject>=1.10.2 cairo>=1.14.12nb1 glib2>=2.14.0 Xft2>=2.1.7nb7 harfbuzz>=1.4.2nb1 cairo-gobject>=1.14.12nb1 pango>=1.6.0 cairo>=1.6.0 atk>=2.6.0 gdk-pixbuf2>=2.34.0nb1 xcursor>=1.1.2nb1 Xrandr>=1.0.2nb3 pango>=1.42.1 lua52>=5.2.0<5.3 tk>=8.5.7 tcl>=8.5.7 sqlite3>=3.21.0 sqlite3>=3.0.8 sqlite3>=3.24.0nb1 tcl>=8.6.1nb1 libltdl>=2.4.2 gts>=0.7.6 netpbm>=10.11.6 jasper>=1.600.0 jasper>=1.900.1nb7 netpbm>=10.35.80nb6 gd>=2.2.5nb2 gtk2+>=2.24.32nb3 tk>=8.6.8nb1 libltdl>=2.2.6 p5-Net-NBName-[0-9]* p5-ap24-libapreq2-[0-9]* p5-ExtUtils-XSBuilder>=0.23 p5-Parse-RecDescent-[0-9]* p5-Text-Balanced-[0-9]* p5-Tie-IxHash-[0-9]* ap24-perl>=2.0.1 apache>=2.4.7<2.5 apr>=1.5.0 apr-util>=1.5.3 apr-util>=1.2.8 nghttp2>=1.0.0 readline>=2.2 apr-util>=1.5.4nb4 nghttp2>=1.32.0nb1 readline>=6.0 apache>=2.4.34nb2 ap24-perl>=2.0.10nb2 p5-Parallel-ForkManager-[0-9]* .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
arm:netdisco-1.1nb4.tgz(NetBSD 6.1_STABLE)
earm:netdisco-1.3.3.tgz(NetBSD 7.0)
earm:netdisco-1.3.3.tgz(NetBSD 7.0)
earmv6hf:netdisco-1.3.3.tgz(NetBSD 7.0)
earmv6hf:netdisco-1.3.3nb2.tgz(NetBSD 8.0)
earmv7hf:netdisco-1.3.3.tgz(NetBSD 7.0)
earmv7hf:netdisco-1.3.3nb2.tgz(NetBSD 8.0)
i386:netdisco-1.3.3nb2.tgz(NetBSD 7.0)
i386:netdisco-1.3.3nb2.tgz(NetBSD 7.0)
i386:netdisco-1.3.3nb2.tgz(NetBSD 7.0)
i386:netdisco-1.3.3nb2.tgz(NetBSD 7.0)
i386:netdisco-1.3.3nb2.tgz(NetBSD 7.1)
i386:netdisco-1.3.3nb2.tgz(NetBSD 7.1)
i386:netdisco-1.3.3nb2.tgz(NetBSD 7.1)
i386:netdisco-1.3.3nb2.tgz(NetBSD 8.0)
i386:netdisco-1.3.3nb2.tgz(NetBSD 8.0)
i386:netdisco-1.3.3nb2.tgz(NetBSD 8.0)
powerpc:netdisco-1.3.3nb2.tgz(NetBSD 7.1)
powerpc:netdisco-1.3.3nb2.tgz(NetBSD 7.1)
powerpc:netdisco-1.3.3nb2.tgz(NetBSD 8.0)
powerpc:netdisco-1.3.3nb2.tgz(NetBSD 8.0)
sparc64:netdisco-1.3.3nb2.tgz(NetBSD 8.0)
x86_64:netdisco-1.3.3nb2.tgz(NetBSD 7.0)
x86_64:netdisco-1.3.3nb2.tgz(NetBSD 7.0)
x86_64:netdisco-1.3.3nb2.tgz(NetBSD 7.0)
x86_64:netdisco-1.3.3nb2.tgz(NetBSD 7.0)
x86_64:netdisco-1.3.3nb2.tgz(NetBSD 7.0.1_PATCH)
x86_64:netdisco-1.3.3nb2.tgz(NetBSD 7.1)
x86_64:netdisco-1.3.3nb2.tgz(NetBSD 7.1)
x86_64:netdisco-1.3.3nb2.tgz(NetBSD 7.1)
x86_64:netdisco-1.3.3nb2.tgz(NetBSD 8.0)
x86_64:netdisco-1.3.3nb2.tgz(NetBSD 8.99.1)
x86_64:netdisco-1.3.3nb2.tgz(NetBSD 8.0)
x86_64:netdisco-1.3.3nb2.tgz(NetBSD 8.0)
x86_64:netdisco-1.3.3nb2.tgz(NetBSD 8.0)
x86_64:netdisco-1.3.3nb2.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]