net/py-ORBit - The NetBSD Packages Collection

Python bindings for ORBit2

This is a Python language binding for the ORBit2 CORBA implementation.
It aims to take advantage of new features found in ORBit2 to make
language bindings more efficient.  This includes:
  - Use of ORBit2 type libraries to generate stubs
  - use of the ORBit_small_invoke_stub() call for operation
    invocation, which allows for short circuited invocation on local
    objects.

Build dependencies

pkgtools/cwrappers devel/glib2-tools devel/libtool-base devel/gmake devel/pkgconf

Runtime dependencies

net/ORBit2 lang/python27 net/ORBit2 lang/python27

Available binary packages

aarch64:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
aarch64:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
aarch64:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
alpha:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
alpha:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
alpha:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
earm:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
earmv6hf:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
earmv6hf:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
earmv6hf:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
earmv6hf:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
earmv7hf:py27-ORBit-2.24.0nb6.tgz(NetBSD 8.0)
earmv7hf:py27-ORBit-2.24.0nb6.tgz(NetBSD 8.0)
earmv7hf:py27-ORBit-2.24.0nb6.tgz(NetBSD 8.0)
earmv7hf:py27-ORBit-2.24.0nb6.tgz(NetBSD 8.0)
earmv7hf:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
earmv7hf:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
earmv7hf:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
earmv7hf:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
earmv7hf:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
i386:py27-ORBit-2.24.0nb6.tgz(NetBSD 8.0)
i386:py27-ORBit-2.24.0nb6.tgz(NetBSD 8.0)
i386:py27-ORBit-2.24.0nb6.tgz(NetBSD 8.0)
i386:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
i386:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
i386:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
m68k:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
mips64eb:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
mips64eb:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
mipsel:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
powerpc:py27-ORBit-2.24.0nb5.tgz(NetBSD 8.0)
powerpc:py27-ORBit-2.24.0nb6.tgz(NetBSD 8.0)
powerpc:py27-ORBit-2.24.0nb5.tgz(NetBSD 8.0)
powerpc:py27-ORBit-2.24.0nb6.tgz(NetBSD 8.0)
powerpc:py27-ORBit-2.24.0nb5.tgz(NetBSD 9.0)
powerpc:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
powerpc:py27-ORBit-2.24.0nb5.tgz(NetBSD 9.0)
powerpc:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
powerpc:py27-ORBit-2.24.0nb5.tgz(NetBSD 9.0)
powerpc:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
sh3el:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
sparc64:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
sparc64:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
sparc64:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
sparc:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
sparc:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
sparc:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
x86_64:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
x86_64:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
x86_64:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
x86_64:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
x86_64:py27-ORBit-2.24.0nb6.tgz(NetBSD 8.0)
x86_64:py27-ORBit-2.24.0nb6.tgz(NetBSD 8.0)
x86_64:py27-ORBit-2.24.0nb6.tgz(NetBSD 8.0)
x86_64:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
x86_64:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
x86_64:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)
x86_64:py27-ORBit-2.24.0nb6.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]