security/gpgme - The NetBSD Packages Collection

GnuPG Made Easy

GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG
easier for applications. It provides a High-Level Crypto API for
encryption, decryption, signing, signature verification and key
management.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/gmake

Runtime dependencies

security/gnupg2 security/libassuan2 security/libgpg-error security/libgpg-error security/libgpg-error

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgpgme-1.14.0.tgz
NetBSD 8.0earmv7hfgpgme-1.14.0.tgz
NetBSD 8.0earmv7hfgpgme-1.15.1.tgz
NetBSD 8.0i386gpgme-1.14.0.tgz
NetBSD 8.0i386gpgme-1.14.0.tgz
NetBSD 8.0i386gpgme-1.15.1.tgz
NetBSD 8.0powerpcgpgme-1.14.0.tgz
NetBSD 8.0powerpcgpgme-1.14.0.tgz
NetBSD 8.0powerpcgpgme-1.14.0.tgz
NetBSD 8.0x86_64gpgme-1.15.1.tgz
NetBSD 8.0x86_64gpgme-1.14.0.tgz
NetBSD 8.0x86_64gpgme-1.14.0.tgz
NetBSD 9.0aarch64gpgme-1.15.1.tgz
NetBSD 9.0aarch64gpgme-1.14.0.tgz
NetBSD 9.0aarch64gpgme-1.14.0.tgz
NetBSD 9.0alphagpgme-1.15.1.tgz
NetBSD 9.0alphagpgme-1.14.0.tgz
NetBSD 9.0alphagpgme-1.14.0.tgz
NetBSD 9.0earmgpgme-1.14.0.tgz
NetBSD 9.0earmgpgme-1.15.1.tgz
NetBSD 9.0earmv6hfgpgme-1.15.1.tgz
NetBSD 9.0earmv6hfgpgme-1.14.0.tgz
NetBSD 9.0earmv6hfgpgme-1.14.0.tgz
NetBSD 9.0earmv6hfgpgme-1.14.0.tgz
NetBSD 9.0earmv7hfgpgme-1.15.1.tgz
NetBSD 9.0earmv7hfgpgme-1.14.0.tgz
NetBSD 9.0earmv7hfgpgme-1.14.0.tgz
NetBSD 9.0earmv7hfgpgme-1.14.0.tgz
NetBSD 9.0i386gpgme-1.14.0.tgz
NetBSD 9.0i386gpgme-1.14.0.tgz
NetBSD 9.0i386gpgme-1.15.1.tgz
NetBSD 9.0m68kgpgme-1.14.0.tgz
NetBSD 9.0mips64ebgpgme-1.15.1.tgz
NetBSD 9.0mips64ebgpgme-1.14.0.tgz
NetBSD 9.0mips64ebgpgme-1.14.0.tgz
NetBSD 9.0mipselgpgme-1.14.0.tgz
NetBSD 9.0mipselgpgme-1.15.1.tgz
NetBSD 9.0powerpcgpgme-1.14.0.tgz
NetBSD 9.0powerpcgpgme-1.14.0.tgz
NetBSD 9.0sh3elgpgme-1.14.0.tgz
NetBSD 9.0sh3elgpgme-1.14.0.tgz
NetBSD 9.0sh3elgpgme-1.15.1.tgz
NetBSD 9.0sparc64gpgme-1.15.1.tgz
NetBSD 9.0sparc64gpgme-1.13.1.tgz
NetBSD 9.0sparc64gpgme-1.14.0.tgz
NetBSD 9.0sparc64gpgme-1.14.0.tgz
NetBSD 9.0sparcgpgme-1.15.1.tgz
NetBSD 9.0sparcgpgme-1.14.0.tgz
NetBSD 9.0sparcgpgme-1.14.0.tgz
NetBSD 9.0vaxgpgme-1.14.0.tgz
NetBSD 9.0x86_64gpgme-1.14.0.tgz
NetBSD 9.0x86_64gpgme-1.14.0.tgz
NetBSD 9.0x86_64gpgme-1.15.1.tgz
NetBSD 9.0x86_64gpgme-1.15.1.tgz
NetBSD 9.0x86_64gpgme-1.14.0.tgz
NetBSD 9.0x86_64gpgme-1.14.0.tgz
NetBSD 9.0x86_64gpgme-1.15.1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

gnupg1
Use GNU Privacy Guard (GnuPG) Version 1.x
gnupg2
Use GNU Privacy Guard (GnuPG) Version 2.0

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.