security/john - The NetBSD Packages Collection

Unix Password Cracker

John the Ripper is a password cracker, currently available for UNIX, DOS,
WinNT/Win95. Its primary purpose is to detect weak UNIX passwords. It has
been tested with Linux x86/Alpha/SPARC, FreeBSD x86, OpenBSD x86, Solaris
2.x SPARC and x86, Digital UNIX, AIX, HP-UX, and IRIX.

The DOS and Win32 ports are done with DJGPP and Cygnus Developer's Kit,
respectively.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfjohn-1.9.0nb1.tgz
NetBSD 8.0earmv7hfjohn-1.9.0nb1.tgz
NetBSD 8.0earmv7hfjohn-1.9.0nb1.tgz
NetBSD 8.0i386john-1.9.0nb1.tgz
NetBSD 8.0i386john-1.9.0nb1.tgz
NetBSD 8.0i386john-1.9.0nb1.tgz
NetBSD 8.0powerpcjohn-1.9.0nb1.tgz
NetBSD 8.0powerpcjohn-1.9.0nb1.tgz
NetBSD 8.0powerpcjohn-1.9.0nb1.tgz
NetBSD 8.0x86_64john-1.9.0nb1.tgz
NetBSD 8.0x86_64john-1.9.0nb1.tgz
NetBSD 8.0x86_64john-1.9.0nb1.tgz
NetBSD 9.0aarch64john-1.9.0nb1.tgz
NetBSD 9.0aarch64john-1.9.0nb1.tgz
NetBSD 9.0aarch64john-1.9.0nb1.tgz
NetBSD 9.0alphajohn-1.9.0nb1.tgz
NetBSD 9.0alphajohn-1.9.0nb1.tgz
NetBSD 9.0alphajohn-1.9.0nb1.tgz
NetBSD 9.0earmv6hfjohn-1.9.0nb1.tgz
NetBSD 9.0earmv6hfjohn-1.9.0nb1.tgz
NetBSD 9.0earmv6hfjohn-1.9.0nb1.tgz
NetBSD 9.0earmv6hfjohn-1.9.0nb1.tgz
NetBSD 9.0earmv7hfjohn-1.9.0nb1.tgz
NetBSD 9.0earmv7hfjohn-1.9.0nb1.tgz
NetBSD 9.0earmv7hfjohn-1.9.0nb1.tgz
NetBSD 9.0earmv7hfjohn-1.9.0nb1.tgz
NetBSD 9.0i386john-1.9.0nb1.tgz
NetBSD 9.0i386john-1.9.0nb1.tgz
NetBSD 9.0i386john-1.9.0nb1.tgz
NetBSD 9.0mips64ebjohn-1.9.0nb1.tgz
NetBSD 9.0mips64ebjohn-1.9.0nb1.tgz
NetBSD 9.0mips64ebjohn-1.9.0nb1.tgz
NetBSD 9.0powerpcjohn-1.9.0nb1.tgz
NetBSD 9.0powerpcjohn-1.9.0nb1.tgz
NetBSD 9.0sparc64john-1.9.0nb1.tgz
NetBSD 9.0sparc64john-1.8.0.tgz
NetBSD 9.0sparc64john-1.9.0nb1.tgz
NetBSD 9.0sparc64john-1.9.0nb1.tgz
NetBSD 9.0sparcjohn-1.9.0nb1.tgz
NetBSD 9.0x86_64john-1.9.0nb1.tgz
NetBSD 9.0x86_64john-1.9.0nb1.tgz
NetBSD 9.0x86_64john-1.9.0nb1.tgz
NetBSD 9.0x86_64john-1.9.0nb1.tgz
NetBSD 9.0x86_64john-1.9.0nb1.tgz
NetBSD 9.0x86_64john-1.9.0nb1.tgz
NetBSD 9.0x86_64john-1.9.0nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.