security/p5-Crypt-DES_EDE3 - The NetBSD Packages Collection

Perl5 module for Triple-DES EDE encryption/decryption

Crypt::DES_EDE3 implements DES-EDE3 encryption. This is triple-DES
encryption where an encrypt operation is encrypt-decrypt-encrypt, and
decrypt is decrypt-encrypt-decrypt. This implementation uses Crypt::DES
to do its dirty DES work, and simply provides a wrapper around that
module: setting up the individual DES ciphers, initializing the keys,
and performing the encryption/decryption steps.

DES-EDE3 encryption requires a key size of 24 bytes.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

security/p5-Crypt-DES lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 8.0earmv7hfp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 8.0earmv7hfp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 8.0i386p5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 8.0i386p5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 8.0i386p5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 8.0powerpcp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 8.0powerpcp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 8.0powerpcp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 8.0powerpcp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 8.0x86_64p5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 8.0x86_64p5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 8.0x86_64p5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0aarch64p5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0aarch64p5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0aarch64p5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0alphap5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0alphap5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0alphap5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0earmp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0earmp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0earmp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0earmv6hfp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0earmv6hfp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0earmv6hfp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0earmv6hfp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0earmv7hfp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0earmv7hfp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0earmv7hfp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0earmv7hfp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0earmv7hfp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0i386p5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0i386p5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0i386p5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0m68kp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0m68kp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0m68kp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0mips64ebp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0mips64ebp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0mips64ebp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0mipselp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0mipselp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0powerpcp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0powerpcp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0powerpcp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0sh3elp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0sh3elp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0sh3elp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0sparc64p5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0sparc64p5-Crypt-DES_EDE3-0.01nb14.tgz
NetBSD 9.0sparc64p5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0sparc64p5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0sparcp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0sparcp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0sparcp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0vaxp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0vaxp5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0x86_64p5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0x86_64p5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0x86_64p5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0x86_64p5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0x86_64p5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0x86_64p5-Crypt-DES_EDE3-0.01nb15.tgz
NetBSD 9.0x86_64p5-Crypt-DES_EDE3-0.01nb15.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.