security/p5-Crypt-OpenPGP - The NetBSD Packages Collection

Pure-Perl OpenPGP implementation

Crypt::OpenPGP is a pure-Perl implementation of the OpenPGP standard.
In addition to support for the standard itself, Crypt::OpenPGP claims
compatibility with many other PGP implementations, both those that
support the standard and those that preceded it.

Build dependencies

devel/p5-Test-Exception pkgtools/cwrappers

Runtime dependencies

security/p5-Crypt-Blowfish security/p5-Crypt-CAST5_PP security/p5-Crypt-DES security/p5-Crypt-DES_EDE3 security/p5-Crypt-DSA security/p5-Crypt-RIPEMD160 security/p5-Crypt-RSA security/p5-Crypt-Rijndael security/p5-Crypt-Twofish devel/p5-Data-Buffer security/p5-Digest-SHA1 devel/p5-File-HomeDir www/p5-URI www/p5-libwww lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 8.0earmv7hfp5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 8.0earmv7hfp5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 8.0i386p5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 8.0i386p5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 8.0i386p5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 8.0powerpcp5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 8.0powerpcp5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 8.0powerpcp5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 8.0x86_64p5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 8.0x86_64p5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 8.0x86_64p5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 9.0aarch64p5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 9.0aarch64p5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 9.0aarch64p5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 9.0earmp5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 9.0earmp5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 9.0earmv6hfp5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 9.0earmv6hfp5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 9.0earmv6hfp5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 9.0earmv6hfp5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 9.0earmv7hfp5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 9.0earmv7hfp5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 9.0earmv7hfp5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 9.0earmv7hfp5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 9.0i386p5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 9.0i386p5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 9.0i386p5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 9.0mipselp5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 9.0powerpcp5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 9.0powerpcp5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 9.0x86_64p5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 9.0x86_64p5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 9.0x86_64p5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 9.0x86_64p5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 9.0x86_64p5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 9.0x86_64p5-Crypt-OpenPGP-1.12nb5.tgz
NetBSD 9.0x86_64p5-Crypt-OpenPGP-1.12nb5.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

pgp2-compat

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.