security/p5-Tie-EncryptedHash - The NetBSD Packages Collection

Perl5 module for hashes with encrypting fields

Tie::EncryptedHash augments Perl hash semantics to build secure, encrypting
containers of data.  Tie::EncryptedHash introduces special hash fields that
are coupled with encrypt/decrypt routines to encrypt assignments at STORE()
and decrypt retrievals at FETCH().  By design, encrypting fields are
associated with keys that begin in single underscore.  The remaining keyspace
is used for accessing normal hash fields, which are retained without
modification.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

security/p5-Crypt-CBC security/p5-Crypt-Blowfish security/p5-Crypt-DES lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 8.0earmv7hfp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 8.0earmv7hfp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 8.0i386p5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 8.0i386p5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 8.0i386p5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 8.0powerpcp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 8.0powerpcp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 8.0powerpcp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 8.0x86_64p5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 8.0x86_64p5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 8.0x86_64p5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0aarch64p5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0aarch64p5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0aarch64p5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0alphap5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0alphap5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0alphap5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0earmp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0earmp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0earmp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0earmv6hfp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0earmv6hfp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0earmv6hfp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0earmv6hfp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0earmv7hfp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0earmv7hfp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0earmv7hfp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0earmv7hfp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0i386p5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0i386p5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0i386p5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0m68kp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0m68kp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0m68kp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0mips64ebp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0mips64ebp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0mips64ebp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0mipselp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0mipselp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0powerpcp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0powerpcp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0sh3elp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0sh3elp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0sh3elp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0sparc64p5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0sparc64p5-Tie-EncryptedHash-1.24nb11.tgz
NetBSD 9.0sparc64p5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0sparc64p5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0sparcp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0sparcp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0sparcp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0vaxp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0vaxp5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0x86_64p5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0x86_64p5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0x86_64p5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0x86_64p5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0x86_64p5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0x86_64p5-Tie-EncryptedHash-1.24nb12.tgz
NetBSD 9.0x86_64p5-Tie-EncryptedHash-1.24nb12.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.