sysutils/crashme - The NetBSD Packages Collection

Try to crash machine by executing random data as instructions

A bit of background on crashme. It is a tool for testing the robustness
of an operating environment using a technique of "Random Input" response
analysis. This I first saw formally proposed in the book Cybernetics
by Norbert Wiener, but which any parent who has observed his children
playing and learning would be well disposed to describe in detail.

* The operating environment under consideration is the user-mode process.

* The Random Input is provided by the execution of a sequence of pseudo-random
  data as an instruction stream.

* The response analysis is to catch and record machine and software
  generated exceptions/errors/signals and to retry using new random data
  in both the current user-mode process and in newly created subprocesses.

Crashme: (c) Copyright 1990, 1991 George J. Carrette

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfcrashme-2.4.tgz
NetBSD 8.0earmv7hfcrashme-2.4.tgz
NetBSD 8.0earmv7hfcrashme-2.4.tgz
NetBSD 8.0i386crashme-2.4.tgz
NetBSD 8.0i386crashme-2.4.tgz
NetBSD 8.0i386crashme-2.4.tgz
NetBSD 8.0powerpccrashme-2.4.tgz
NetBSD 8.0powerpccrashme-2.4.tgz
NetBSD 8.0powerpccrashme-2.4.tgz
NetBSD 8.0x86_64crashme-2.4.tgz
NetBSD 8.0x86_64crashme-2.4.tgz
NetBSD 8.0x86_64crashme-2.4.tgz
NetBSD 9.0aarch64crashme-2.4.tgz
NetBSD 9.0aarch64crashme-2.4.tgz
NetBSD 9.0aarch64crashme-2.4.tgz
NetBSD 9.0alphacrashme-2.4.tgz
NetBSD 9.0alphacrashme-2.4.tgz
NetBSD 9.0alphacrashme-2.4.tgz
NetBSD 9.0earmv6hfcrashme-2.4.tgz
NetBSD 9.0earmv6hfcrashme-2.4.tgz
NetBSD 9.0earmv6hfcrashme-2.4.tgz
NetBSD 9.0earmv6hfcrashme-2.4.tgz
NetBSD 9.0earmv7hfcrashme-2.4.tgz
NetBSD 9.0earmv7hfcrashme-2.4.tgz
NetBSD 9.0earmv7hfcrashme-2.4.tgz
NetBSD 9.0earmv7hfcrashme-2.4.tgz
NetBSD 9.0i386crashme-2.4.tgz
NetBSD 9.0i386crashme-2.4.tgz
NetBSD 9.0i386crashme-2.4.tgz
NetBSD 9.0m68kcrashme-2.4.tgz
NetBSD 9.0mips64ebcrashme-2.4.tgz
NetBSD 9.0mips64ebcrashme-2.4.tgz
NetBSD 9.0mips64ebcrashme-2.4.tgz
NetBSD 9.0powerpccrashme-2.4.tgz
NetBSD 9.0powerpccrashme-2.4.tgz
NetBSD 9.0sparc64crashme-2.4.tgz
NetBSD 9.0sparc64crashme-2.4.tgz
NetBSD 9.0sparc64crashme-2.4.tgz
NetBSD 9.0sparc64crashme-2.4.tgz
NetBSD 9.0sparccrashme-2.4.tgz
NetBSD 9.0vaxcrashme-2.4.tgz
NetBSD 9.0x86_64crashme-2.4.tgz
NetBSD 9.0x86_64crashme-2.4.tgz
NetBSD 9.0x86_64crashme-2.4.tgz
NetBSD 9.0x86_64crashme-2.4.tgz
NetBSD 9.0x86_64crashme-2.4.tgz
NetBSD 9.0x86_64crashme-2.4.tgz
NetBSD 9.0x86_64crashme-2.4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.