sysutils/fabric - The NetBSD Packages Collection

Simple Pythonic remote deployment tool

Fabric is a Python library and command-line tool for streamlining the use of SSH
for application deployment or systems administration tasks.

It provides a basic suite of operations for executing local or remote shell
commands (normally or via sudo) and uploading/downloading files, as well as
auxiliary functionality such as prompting the running user for input, or
aborting execution.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

security/py-paramiko devel/py-setuptools44 lang/python27 lang/python27

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hffabric-1.12.0nb2.tgz
NetBSD 8.0earmv7hffabric-1.12.0nb2.tgz
NetBSD 8.0i386fabric-1.12.0nb1.tgz
NetBSD 8.0i386fabric-1.12.0nb2.tgz
NetBSD 8.0i386fabric-1.12.0nb2.tgz
NetBSD 8.0powerpcfabric-1.12.0nb1.tgz
NetBSD 8.0powerpcfabric-1.12.0nb2.tgz
NetBSD 8.0powerpcfabric-1.12.0nb2.tgz
NetBSD 8.0x86_64fabric-1.12.0nb2.tgz
NetBSD 8.0x86_64fabric-1.12.0nb1.tgz
NetBSD 8.0x86_64fabric-1.12.0nb2.tgz
NetBSD 9.0aarch64fabric-1.12.0nb2.tgz
NetBSD 9.0aarch64fabric-1.12.0nb1.tgz
NetBSD 9.0aarch64fabric-1.12.0nb2.tgz
NetBSD 9.0alphafabric-1.12.0nb2.tgz
NetBSD 9.0alphafabric-1.12.0nb1.tgz
NetBSD 9.0alphafabric-1.12.0nb2.tgz
NetBSD 9.0earmfabric-1.12.0nb1.tgz
NetBSD 9.0earmv6hffabric-1.12.0nb2.tgz
NetBSD 9.0earmv6hffabric-1.12.0nb1.tgz
NetBSD 9.0earmv6hffabric-1.12.0nb2.tgz
NetBSD 9.0earmv6hffabric-1.12.0nb2.tgz
NetBSD 9.0earmv7hffabric-1.12.0nb2.tgz
NetBSD 9.0earmv7hffabric-1.12.0nb1.tgz
NetBSD 9.0earmv7hffabric-1.12.0nb2.tgz
NetBSD 9.0earmv7hffabric-1.12.0nb2.tgz
NetBSD 9.0i386fabric-1.12.0nb1.tgz
NetBSD 9.0i386fabric-1.12.0nb2.tgz
NetBSD 9.0i386fabric-1.12.0nb2.tgz
NetBSD 9.0mips64ebfabric-1.12.0nb2.tgz
NetBSD 9.0mips64ebfabric-1.12.0nb1.tgz
NetBSD 9.0mips64ebfabric-1.12.0nb2.tgz
NetBSD 9.0powerpcfabric-1.12.0nb2.tgz
NetBSD 9.0powerpcfabric-1.12.0nb1.tgz
NetBSD 9.0sparc64fabric-1.12.0nb2.tgz
NetBSD 9.0sparc64fabric-1.12.0nb1.tgz
NetBSD 9.0sparc64fabric-1.12.0nb1.tgz
NetBSD 9.0sparc64fabric-1.12.0nb2.tgz
NetBSD 9.0sparcfabric-1.12.0nb2.tgz
NetBSD 9.0sparcfabric-1.12.0nb1.tgz
NetBSD 9.0sparcfabric-1.12.0nb2.tgz
NetBSD 9.0x86_64fabric-1.12.0nb1.tgz
NetBSD 9.0x86_64fabric-1.12.0nb2.tgz
NetBSD 9.0x86_64fabric-1.12.0nb2.tgz
NetBSD 9.0x86_64fabric-1.12.0nb2.tgz
NetBSD 9.0x86_64fabric-1.12.0nb1.tgz
NetBSD 9.0x86_64fabric-1.12.0nb2.tgz
NetBSD 9.0x86_64fabric-1.12.0nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.