sysutils/fix4SA110rev2 - The NetBSD Packages Collection

Modify arm32 binaries to work around SA rev2 problems

fix4SA110rev2 modifies arm32 binaries in an attempt to work around
StrongARM rev2 problems

It attempts to identify the instructions that will cause problems
and moves them to a safe location.  The "safe" location is final
page of the text (code) segment of the executable, which normally
has some spare bytes before the start of the data segment.  Having
moved the instruction, it then puts a branch to the new location
where the old instruction used to be so that things will continue
to work.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hffix4SA110rev2-1.0nb2.tgz
NetBSD 8.0earmv7hffix4SA110rev2-1.0nb2.tgz
NetBSD 8.0earmv7hffix4SA110rev2-1.0nb2.tgz
NetBSD 8.0i386fix4SA110rev2-1.0nb2.tgz
NetBSD 8.0i386fix4SA110rev2-1.0nb2.tgz
NetBSD 8.0i386fix4SA110rev2-1.0nb2.tgz
NetBSD 8.0powerpcfix4SA110rev2-1.0nb2.tgz
NetBSD 8.0powerpcfix4SA110rev2-1.0nb2.tgz
NetBSD 8.0powerpcfix4SA110rev2-1.0nb2.tgz
NetBSD 8.0x86_64fix4SA110rev2-1.0nb2.tgz
NetBSD 8.0x86_64fix4SA110rev2-1.0nb2.tgz
NetBSD 8.0x86_64fix4SA110rev2-1.0nb2.tgz
NetBSD 9.0aarch64fix4SA110rev2-1.0nb2.tgz
NetBSD 9.0aarch64fix4SA110rev2-1.0nb2.tgz
NetBSD 9.0aarch64fix4SA110rev2-1.0nb2.tgz
NetBSD 9.0alphafix4SA110rev2-1.0nb2.tgz
NetBSD 9.0alphafix4SA110rev2-1.0nb2.tgz
NetBSD 9.0alphafix4SA110rev2-1.0nb2.tgz
NetBSD 9.0earmv6hffix4SA110rev2-1.0nb2.tgz
NetBSD 9.0earmv6hffix4SA110rev2-1.0nb2.tgz
NetBSD 9.0earmv6hffix4SA110rev2-1.0nb2.tgz
NetBSD 9.0earmv6hffix4SA110rev2-1.0nb2.tgz
NetBSD 9.0earmv7hffix4SA110rev2-1.0nb2.tgz
NetBSD 9.0earmv7hffix4SA110rev2-1.0nb2.tgz
NetBSD 9.0earmv7hffix4SA110rev2-1.0nb2.tgz
NetBSD 9.0earmv7hffix4SA110rev2-1.0nb2.tgz
NetBSD 9.0i386fix4SA110rev2-1.0nb2.tgz
NetBSD 9.0i386fix4SA110rev2-1.0nb2.tgz
NetBSD 9.0i386fix4SA110rev2-1.0nb2.tgz
NetBSD 9.0powerpcfix4SA110rev2-1.0nb2.tgz
NetBSD 9.0powerpcfix4SA110rev2-1.0nb2.tgz
NetBSD 9.0sparc64fix4SA110rev2-1.0nb2.tgz
NetBSD 9.0sparc64fix4SA110rev2-1.0nb2.tgz
NetBSD 9.0sparc64fix4SA110rev2-1.0nb2.tgz
NetBSD 9.0sparc64fix4SA110rev2-1.0nb2.tgz
NetBSD 9.0sparcfix4SA110rev2-1.0nb2.tgz
NetBSD 9.0x86_64fix4SA110rev2-1.0nb2.tgz
NetBSD 9.0x86_64fix4SA110rev2-1.0nb2.tgz
NetBSD 9.0x86_64fix4SA110rev2-1.0nb2.tgz
NetBSD 9.0x86_64fix4SA110rev2-1.0nb2.tgz
NetBSD 9.0x86_64fix4SA110rev2-1.0nb2.tgz
NetBSD 9.0x86_64fix4SA110rev2-1.0nb2.tgz
NetBSD 9.0x86_64fix4SA110rev2-1.0nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.